Closed Bug 1303379 Opened 3 years ago Closed 2 years ago

Remove all uses of the old TopSites once AS is enabled for everyone

Categories

(Firefox for iOS :: Home screen, defect, P1)

Other
iOS
defect

Tracking

()

RESOLVED FIXED
Iteration:
1.27
Tracking Status
fxios 8.2 ---

People

(Reporter: farhan, Assigned: farhan)

References

Details

(Whiteboard: [mobileAS])

Attachments

(1 file)

55 bytes, text/x-github-pull-request
garvan
: review+
Details | Review
There are a few small hacks that I'm having to make in order to support both the old topSites and the new ActivityStream. This bug is to track the changes I'll need to make once AS is fully launched. 

- Remove TopSitesPanel.swift
- Remove ThumbnailCell.swift
- Remove default TopSite images in assets folder.
- Change metadata in DefaultSuggestedSites to use a simpler asset path for images.
- Make amazon/Wikipedia have white backgrounds.
- Remove color hack in TopSitesCell that changes black backgrounds to white ones.
Assignee: nobody → fpatel
Iteration: --- → 1.19
Priority: P3 → P1
Iteration: 1.19 → ---
Priority: P1 → P3
Assignee: fpatel → nobody
Farhan, is this something that should be done for v8.0?
Flags: needinfo?(fpatel)
Nope. We are enabling AS for 50 percent of the audience so we'll need the old Topsites.
Flags: needinfo?(fpatel)
Rank: 3
Assignee: nobody → fpatel
Iteration: --- → 1.25
Priority: P3 → P1
Iteration: 1.25 → 1.26
Iteration: 1.26 → 1.27
Attached file Pull Request
Attachment #8893126 - Flags: review?(gkeeley)
Attachment #8893126 - Flags: review?(gkeeley) → review+
master https://github.com/mozilla-mobile/firefox-ios/commit/fa10eae3f278860424dde87965f3a107a62b85ed
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Whiteboard: [mobileAS] → [mobileAS][needsuplift]
Uplifted to v8.x
Whiteboard: [mobileAS][needsuplift] → [mobileAS]
Duplicate of this bug: 1384152
You need to log in before you can comment on or make changes to this bug.