xpcshell test fails on Taskcluster Windows tests due to lack of signed binaries (win7/win10)

RESOLVED FIXED

Status

Release Engineering
General
P2
normal
RESOLVED FIXED
2 years ago
2 months ago

People

(Reporter: grenade, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
at least some of the failures look to be caused by insufficient access rights for the task user. eg:
https://treeherder.allizom.org/#/jobs?repo=try&revision=8bd76076ce73120290fc16a62c0ef9f233dfef75&filter-tier=2&group_state=expanded&selectedJob=28199940

Updated

2 years ago
Assignee: nobody → gbrown
devtools/shared/heapsnapshot/tests/unit/test_saveHeapSnapshot_e10s_01.js fails when CreateProcessAsUserW() fails with "access denied", as discussed in https://bugzilla.mozilla.org/show_bug.cgi?id=1303455#c8.
Depends on: 1303455
A few other tests fail with reports that they failed to create a process, like:

toolkit/components/extensions/test/xpcshell/test_ext_native_messaging.js
toolkit/components/extensions/test/xpcshell/test_ext_native_messaging_perf.js
toolkit/components/extensions/test/xpcshell/test_ext_native_messaging_unresponsive.js
toolkit/components/search/tests/xpcshell/test_bug930456_child.js
toolkit/components/telemetry/tests/unit/test_ChildHistograms.js
Almost all of the tests in toolkit/mozapps/update/tests/unit_service_updater fail (debug only?) with:

"the updater.exe binary should be signed (if not, build system configuration bug?)"

Updated

2 years ago
Assignee: gbrown → nobody
(Reporter)

Comment 4

2 years ago
latest failures (https://treeherder.mozilla.org/#/jobs?repo=try&revision=b8ba3bb131c95e6562898c39b2eb14057373c39e&filter-tier=3&group_state=expanded&filter-searchStr=tc-X) appear to be only the file access problems identified in bug 1322722
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1322722
AIUI, this is still failing due to bug 1323732
Status: RESOLVED → REOPENED
Depends on: 1323732
Resolution: DUPLICATE → ---
(Reporter)

Comment 6

a year ago
now that edge is installed on win 10, we have issues with no typed url history in edge which is tracked in bug 1261188
Depends on: 1261188
(Reporter)

Comment 7

a year ago
on windows 7, xpcshell chunks 7 & 8 fail due to unsigned binaries which depends on bug 1277591

Updated

a year ago
Duplicate of this bug: 1352185

Updated

a year ago
Depends on: 1277591
Summary: xpcshell test fails on taskcluster windows tests → xpcshell test fails on Taskcluster Windows tests due to lack of signed binaries (win7/win10)
Priority: -- → P2

Comment 9

11 months ago
This was fixed as part of https://bugzilla.mozilla.org/show_bug.cgi?id=1384792 and the landing of date to central for overall tc migration.
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago11 months ago
Resolution: --- → FIXED
(Assignee)

Updated

2 months ago
Component: General Automation → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.