Open Bug 1306425 Opened 3 years ago Updated 2 years ago

"Tabs" in various dialogs don't render anymore, in Ubuntu 16.10 (e.g. for add-on preferences & Certificate Viewer dialog)

Categories

(Core :: Widget: Gtk, defect, P3)

defect

Tracking

()

REOPENED
Tracking Status
firefox52 --- wontfix

People

(Reporter: dholbert, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: tpi:+)

Attachments

(5 files)

STR:
 1. Install Ubuntu 16.10 (currently in final beta)
 2. Start Firefox with a fresh profile.
 3. Install AdBlock Plus:
     https://addons.mozilla.org/en-US/firefox/addon/adblock-plus/
 4. Click AdBlock Plus icon on toolbar, and choose "Filter Preferences"

EXPECTED RESULTS:
The Filter Preferences dialog should have two "tabs" at the top ("Filter subscriptions" and "Custom filters") which should render in a way that makes it clear they're clickable tabs.

ACTUAL RESULTS:
These "tabs" just render as text on the dialog's background, without any border / separator. See screenshot.

I believe this is a regression in Ubuntu 16.10.  Might be a bug in the Ubuntu theme or in GTK; not sure.  But for comparison, Firefox's native print dialog renders with "tabs" just fine.  So maybe we're using some newly-deprecated method for providing tabs to add-on dialogs?
This bug affects current Firefox release (49) as well as Firefox Nightly 52.0a1 (2016-09-28).
This isn't specific to AdBlock Plus -- it affects e.g. NoScript, too. To see it there: Install NoScript[1], restart Firefox, and then click the NoScript icon & choose "Options".

I'm attach a screenshot of its Options dialog. The option-pane tab titles ( General Whitelist Embeddings [...]) are just text on the background) and are not clearly distinguished as tabs.

[1] https://addons.mozilla.org/en-US/firefox/addon/noscript/
For comparison, here's a screenshot of what these tabs should probably look like (from a system integration perspective).  Here's the Firefox print dialog on the left, and the gedit preferences on the right. Both have tabs which are clearly visible.
Here's a screenshot of NoScript's "Options" dialog in Ubuntu 16.04 [the previous Ubuntu release].  The tabs are nicely visible.  Compare this to screenshot 2, attachment 8796271 [details] (the same dialog but in Ubuntu 16.10).
This sounds like a gfx rendering problem, not a widget problem.

Daniel, have you tried safe mode?
Component: Widget: Gtk → Graphics
Flags: needinfo?(dholbert)
(In reply to Jim Mathies [:jimm] from comment #5)
> This sounds like a gfx rendering problem, not a widget problem.

I was guessing "widget" (or OS integration in some form) since these "tabs" probably come from the OS theme, in some way or another, and the OS/theme is what changed when I upgraded to Ubuntu 16.10.  I guess this could conceivably be an interaction with some graphics library upgrade, too, though.

> Daniel, have you tried safe mode?

So, I *have* tried with a fresh profile, with just one or both of these add-ons installed.

It's impossible to test this in Safe Mode, as far as I know, because Safe Mode disables add-ons, and these "tabs" are in add-on dialogs.  (If these "tabs" show up anywhere else in our UI, then it would be possible to test without add-ons though.)
Flags: needinfo?(dholbert)
I've raised the following bug report on Launchpad to track this issue in Ubuntu:

  * https://bugs.launchpad.net/ubuntu/+source/ubuntu-themes/+bug/1631208

In the comments you'll find my merge proposal for ubuntu-themes to address this issue for the Ambiance and Radiance themes in Ubuntu 16.10:

  * https://code.launchpad.net/~flexiondotorg/ubuntu-themes/lp1631208/+merge/307899
I guess that means this is INVALID as a Mozilla bug, since really it seems it's a regression in the theme [which happily Martin has a fix for -- otherwise we might need to consider workarounds or somesuch].

So, since there's nothing to be done here in Mozilla code, I'll resolve this as INVALID.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → INVALID
This bug is visible in the Firefox's built-in "Certificate Viewer" dialog, too.

Easier STR involving that UI (no add-ons required):
 1. At some SSL page (including this one), right-click some blank space and choose "View Page Info"
 2. Click the "Security" icon at the top of the info dialog.
 3. Click "View Certificate"
 4. Look at the "General" & "Details" labels at the top.

EXPECTED RESULTS: General & Details should look like tabs (e.g. they should have a bar between them)
ACTUAL RESULTS: General & Details just look like plain text and aren't clearly separated.
Summary: "Tabs" in add-on preference dialogs don't render anymore, in Ubuntu 16.10 → "Tabs" in various dialogs don't render anymore, in Ubuntu 16.10 (e.g. for add-on preferences & Certificate Viewer dialog)
This probably got worse with ABI changes in GTK 3.20, but there were already problems with GTK3 native tabs.

I think it is worth keeping this open to track finishing off bug 1271524.
Blocks: gtk-3.20
Status: RESOLVED → REOPENED
Component: Graphics → Widget: Gtk
Depends on: 1271524
Priority: -- → P3
Resolution: INVALID → ---
See Also: → 1190163
Whiteboard: tpi:+
Duplicate of this bug: 1323191
Mass wontfix for bugs affecting firefox 52.
Does it make sense to have this bug opened here still? The Ubuntu themes are finally getting some love from Canonical: https://code.launchpad.net/~flexiondotorg/ubuntu-themes/notebook-refactor/+merge/329593
Maybe. Especially since this is somewhat broken as well in Adwaita (the stock gtk3 theme). A fix from Firefox's side will help everyone.
Duplicate of this bug: 1467396
You need to log in before you can comment on or make changes to this bug.