Closed Bug 1306695 Opened 4 years ago Closed 4 years ago

Comment text too small in Gmail

Categories

(bugzilla.mozilla.org :: General, defect, P1)

Production
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: jryans, Assigned: dylan)

References

Details

Attachments

(2 files)

It appears Gmail's display of comments in bugmail has changed, making the text appear too small.  Talking with :dylan on IRC, the BMO email template hasn't changed in years, so it's likely related to a change in Gmail.

Additionally, some changes were recently announced[1] to Gmail CSS processing to better support media queries, perhaps this is related.

[1]: https://gsuite-developers.googleblog.com/2016/09/your-emails-optimized-for-every-screen-with-responsive-design.html
I too noticed this. The text is uncomfortably small.
Assignee: nobody → dylan
Dylan, Perhaps, I can try taking this up?
Flags: needinfo?(dylan)
I am having trouble reproducing it. Are you seeing this in your email inbox?
Flags: needinfo?(dylan)
Attached image bugmail.png
Yep, the text is considerably small and difficult to read on gmail, as you can see the comparison. But Apple's Mail Client doesn't have a problem. So I guess, it is from the gmail side? Is it possible from our side, to do anything about this?
cool, you can maybe fix this. I imagine google is slowly rolling out support for CSS or something.

I would recommend taking the body text of one of the emails, and tweaking the CSS in it, and sending it to yourself
until it looks okay. Then you can edit the email template in https://github.com/mozilla-bteam/bmo/blob/master/extensions/BMO/template/en/default/email/bugmail.html.tmpl
Assignee: dylan → sebastinssanty
(In reply to Sebastin Santy [:seban] from comment #4)
> Created attachment 8800422 [details]
> bugmail.png
> 
> Yep, the text is considerably small and difficult to read on gmail, as you
> can see the comparison. But Apple's Mail Client doesn't have a problem. So I
> guess, it is from the gmail side? Is it possible from our side, to do
> anything about this?

Hmm, the text looks ok to me. It is slightly smaller than the bolder text but now so much where it is unreadable. How much larger are we trying to make it?

dkl
120%.

The pre element already has style="font-size:120%" on it, but there's a rule that overrides it:

div.m157bac68a3b98f0a .m_-7520413524076946868comment {
    font-size: 100% !important;
}

My guess is that this overriding rule wasn't respected (or wasn't present) before the recent change.
Duplicate of this bug: 1310856
See also the screenshot in bug 1310856.
Yeah, that screenshot offers a better perspective.
I found the fix for this. Thanks for the debugging in comment 7!
Assignee: sebastinssanty → dylan
Priority: -- → P1
Attached patch 1306695_1.patchSplinter Review
our .comments rule is now translated into a css rule (reported in comment 7 by :mstange), so we should just change that.

I tested the emails produced this way in gmail and fastmail, both look fine.
Attachment #8802304 - Flags: review?(dkl)
Comment on attachment 8802304 [details] [diff] [review]
1306695_1.patch

Review of attachment 8802304 [details] [diff] [review]:
-----------------------------------------------------------------

r=dkl
Attachment #8802304 - Flags: review?(dkl) → review+
To git@github.com:mozilla-bteam/bmo.git
   6e204f4..96fc28e  master -> master
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
I can confirm that the font size has gone back to the old, larger size. Thank you.
Status: RESOLVED → VERIFIED
This change makes comment text in HTML notifications too large in Mail on OS X. Please revert it and fix properly for Gmail.
Fixing this for both apple mail and gmail will be challenging because of media queries.
Blocks: 1314984
Thank you for fixing for Gmail! :-)
Depends on: 1315849
You need to log in before you can comment on or make changes to this bug.