Remove DOM/tv and related code

RESOLVED FIXED in Firefox 52

Status

()

RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: mds, Assigned: mds)

Tracking

(Blocks: 1 bug, {dev-doc-complete})

unspecified
mozilla52
dev-doc-complete
Points:
---

Firefox Tracking Flags

(firefox52 fixed)

Details

Attachments

(1 attachment)

Comment hidden (empty)
No longer depends on: 1306772
Summary: (nukeb2g) Remove DOM/tv and related code → Remove DOM/tv and related code
Comment hidden (mozreview-request)

Comment 3

2 years ago
mozreview-review
Comment on attachment 8799521 [details]
Bug 1306778 - Remove DOM/tv and related code.

https://reviewboard.mozilla.org/r/84666/#review83290
Attachment #8799521 - Flags: review?(jst) → review+
Keywords: checkin-needed
Michelangelo, in the try run is a android bustage like https://treeherder.mozilla.org/logviewer.html#?job_id=28909127&repo=try - is this related to this code changes ?
Flags: needinfo?(michelangelo)

Updated

2 years ago
Keywords: checkin-needed
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
(In reply to Carsten Book [:Tomcat] from comment #4)

> Michelangelo, in the try run is a android bustage like
> https://treeherder.mozilla.org/logviewer.html#?job_id=28909127&repo=try - is
> this related to this code changes ?

Yes, my fault. Apologies. It should be ok now; running a new try job to be sure.
Flags: needinfo?(michelangelo)
Component: Build Config → DOM
On IRC :bholley has suggested that the bustage on Android (see: https://mzl.la/2etdlRa) may be due to bug 946906.
An identical bustage is also affecting bug 1309719.

It seems due to some XRay/Expando header (js/xpconnect/wrappers/XrayWrapper.h ???) not being included correctly and/or at the right time.

:bohlley has also added: "the problem is presumably that http://searchfox.org/mozilla-central/source/dom/bindings/Codegen.py#13647 and http://searchfox.org/mozilla-central/source/dom/bindings/Codegen.py#40 are not always generated under the same conditions"

Probably :bz has some insight on this.
Flags: needinfo?(bzbarsky)
See Also: → bug 946906
Is that try push on top of the fix for bug 1309239 or not?  Without that fix, you can end up with bustage as unified boundaries shift, for sure.
Flags: needinfo?(bzbarsky)
Comment hidden (mozreview-request)
(In reply to Boris Zbarsky [:bz] (still a bit busy) from comment #12)

> Is that try push on top of the fix for bug 1309239 or not?  Without that
> fix, you can end up with bustage as unified boundaries shift, for sure.

Looks good now, thanks!
Keywords: checkin-needed

Comment 16

2 years ago
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a71215ad8ab8
Remove DOM/tv and related code. r=jst
Keywords: checkin-needed

Comment 17

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/a71215ad8ab8
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox52: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla52

Comment 18

2 years ago
https://hg.mozilla.org/comm-central/rev/8166f30a47b0f4cf32f63ad7d875d638ae2305cc
Update package-manifest after file removal in bug 1306778 and bug 1261019. rs=bustage-fix
No longer blocks: 1369194
Adding ddn, just to check the docs for this.
Keywords: dev-doc-needed
We never documented any of this stuff either.

I've added a note to the Fx52 rel notes:

https://developer.mozilla.org/en-US/Firefox/Releases/52#Changes_and_removals_3

Let me know if you think anything else needs fixing. Thanks!
Keywords: dev-doc-needed → dev-doc-complete
You need to log in before you can comment on or make changes to this bug.