Closed Bug 1307101 Opened 5 years ago Closed 4 years ago

WebExtensions: browserAction popup text briefly appears blurred after opening popup

Categories

(WebExtensions :: Frontend, defect)

51 Branch
Unspecified
Windows 10
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 1303570

People

(Reporter: dw-dev, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160823121617

Steps to reproduce:

I have created a new WebExtensions add-on (Zoom Page WE) based on my well-established XUL/XPCOM Zoom Page add-on.

When I click on the Zoom Page WE browserAction toolbar button, the popup opens, but all of the text appears slightly bolder and slightly blurred for brief period (probably half a second).

This problem was introduced in Firefox 51.0 and does not happen with earlier versions.

This problem does not happen if the browserAction is replaced by a pageAction using the same popup.html file.

I suggest you install Zoom Page WE 2.1 to reproduce and see the problem.



Actual results:

The text in the browserAction popup appears slightly bolder and slightly blurred for a brief period (probably half a second) after the popup is opened.



Expected results:

The text in the browserAction popup should appear correctly rendered immediately the popup is opened.
I suspect this problem is related to Bug 1215025, and more specifically to the extra 1px width mentioned in Bug 1280146.
OS: Unspecified → Windows 10
Version: 48 Branch → 51 Branch
Component: Untriaged → WebExtensions: Untriaged
Product: Firefox → Toolkit
Vasilica, can you or someone on your team please test this, and attach a screencast if you can confirm it? I tested on Linux and could not reproduce on Linux or OS-X, and I don't currently have access to Windows 10 to test on.

dw-dev, a screencast from you would also be helpful, if you can provide one.

Thanks!
No longer blocks: webext-popups
Flags: needinfo?(vasilica.mihasca)
Component: WebExtensions: Untriaged → WebExtensions: Frontend
I was able to reproduce this issue on Firefox 51.0a2 (2016-10-10) under Windows 10 64-bit (http://screencast.com/t/GTRIisODWy) but it is not reproducible in Firefox 52.0a1 (2016-10-09).

Performed a regression range and I suspect that this is a dupe of Bug 1303570 (https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=9baec74b3db1bf005c66ae2f50bafbdb02c3be38&tochange=6f31b67533799bd84fe3b207681bcef2c78dac47)


dw-dev , can you please confirm that this issue is not reproducible in latest Nightly (http://archive.mozilla.org/pub/firefox/nightly/latest-mozilla-central/firefox-52.0a1.en-US.win64.zip)?
Flags: needinfo?(vasilica.mihasca) → needinfo?(dw-dev)
agreed looks like duplicate in triage
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1303570
No longer blocks: webext-popups
Status: RESOLVED → VERIFIED
Flags: needinfo?(dw-dev)
I can confirm that this issue does not happen with Nightly 52.0a1 (2016-10-11).
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.