Last Comment Bug 130774 - Conn: Offline: disconnect when you go offline
: Conn: Offline: disconnect when you go offline
Status: RESOLVED WONTFIX
: helpwanted
Product: Core
Classification: Components
Component: Networking (show other bugs)
: Trunk
: x86 Windows XP
: -- minor with 1 vote (vote)
: Future
Assigned To: general
: benc
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-13 18:42 PST by Paul F. Stevenson
Modified: 2015-12-21 11:29 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Paul F. Stevenson 2002-03-13 18:42:36 PST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031104

Initial launch of Mozilla browser does not display dial-up connection dialog. 
Unable to go on-line unless I use IE or ISP browser (based on IE).  
Also, Clicking on File | Work Offline, does not break telephone connection as it
does in IE6 (& Earthlink).  

This seems so amazing, that I am wondering I am doing something very wrong or
this is something not scheduled to be included, yet. If so, I apologize. I
searched Bugzilla for about an hour using every combo of words relating to login
or connection failure that I could think of.) My point here would then be: 
Please make the dial-up connection dialog an automatic function or have real
obvious help in the help area. I could find no help on this subject in the Help
Menu area.   

Reproducible: Always
Steps to Reproduce:
1. Double-click on desktop Mozilla icon (with no currently connection available).
2. Try to figure out a way to use Mozilla to dial-up my ISP connection
(Earthlink.net).
3.  No dial-up window appears. Unable to login to my ISP.



Actual Results:  Mozilla launches OK. No way found to connect to or disconnect
from ISP.

Expected Results:  1. Present login window with form for dialing in and
connecting to my ISP when I start Mozilla for the first time after boot.
2. Break telephone connection when "Work Offline" is clicked. 

I am really Sorry, if I missed something obvious.  Maybe it should be more
obvious to folk using Mozilla for the first time. :)  (And I am a programmer, too!)
Comment 1 Matthias Versen [:Matti] 2002-03-13 19:08:39 PST
what is your setting in 
start/systemcontrol/Internetoptions/connection ? (transleted from a german 
win2k)

It should work if you enable automatic dialing.

That mozilla doesn't close the connection is bug 106044

*** This bug has been marked as a duplicate of 106044 ***
Comment 2 benc 2002-09-11 08:02:34 PDT
REOPEN:

The auto-dial in NT feature you wanted is implemented in Bug 93002. Please get a
Mozilla 1.1 or later build, and you should find it works. If you see any
complications, please look for a dupe, but if nothing is obvious, just file a
new bug.

I'm renaming this bug to reflect comments you made about integrating offline w/
the connection controls. I was not able to find a dupe of that, so I think you
are the first to request this.

If you have specific ideas of what should go in the help system, please file a
new bug and include as much detail as you can.
Comment 3 benc 2002-09-11 08:04:14 PDT
-> NEW.

This does not currently work, so it needs no confirmation via a second contributor.
Comment 4 Doug Turner (:dougt) 2002-10-15 13:27:24 PDT
as we understand this bug, it is a rfe.  good idea, but no one working on this
now.  steve, are you interested in doing something like this.
Comment 5 Chris Lyon 2003-01-31 11:32:08 PST
*** Bug 188537 has been marked as a duplicate of this bug. ***
Comment 6 benc 2003-06-18 19:05:20 PDT
-> minor.
Comment 7 Wayne Mery (:wsmwk, NI for questions) 2012-02-09 17:52:20 PST
Mehrali, what do you think?
Comment 8 Parkhideh 2012-02-12 20:04:55 PST
(In reply to Wayne Mery (:wsmwk) from comment #7)
> Mehrali, what do you think?

Wayne, this renews a gripe that I have voiced on many occasions about Firefox, and I will explain:
1) If we accept that Netscape was the parent and tradition setter of Firefox and Thunderbird; then there is a legitimate question to ask:
   a) Why has the online/offline icon of Netscape disappeared from the lower corner of Firefox?
   b) Why is the online/offline icon on the lower left corner of Thunderbird?
   c) Is there any design review where some "look and feel" is maintained within Mozilla?
   d) To make matters worse, who thought the "JUMPING BEAN" status line is a good idea in Firefox 7.0.1?  Obviously those who do not read serious documents via Firefox, for soon they would have seen that the last line requires TWO mouse movements because the status line's information covers first the left side, then the right side of the line; one cannot read that line in full.
2) So I think the complaint on " File / Work Offline " is valid; follow Thunderbird is my advice.
3) Since Firefox 3 my dialer, and to my annoyance, does come up.  So, may be this item has been corrected since 2002.  I agree that most users would want the dialer dialogue show up when there is no connection.  So this is a none issue now.
4) This could be my lack of knowledge about Firefox; when I put Firefox in offline mode and then close Firefox; I expect to be able to start it in offline mode, so that the dialer does not bother me in my local work.  Unfortunately the dialer dialog shows up every time.  Opening the browser in its closing condition was a good feature of Netscape  :) .
5) Let me up you on this one, before you add my name to it Wayne;  bug 106044 is requesting a no-no.  Imagine going offline or closing Firefox and seeing the dialog that asks you to close your connection AND accidentally clicking YES.  What happens to all other online activities, like FTP that may be going on.  I am glad that this bug is still the case.

So, in summary, a live online/offline Icon on the Firefox is badly missing;
                there is no dialer dialog issue that I know of;
                going offline should not ask questions about disconnect;
                closing a browser should not be responsible for disconnect.
Comment 9 Parkhideh 2012-02-13 10:54:49 PST
(In reply to Parkhideh from comment #8)

> 3) Since Firefox 3 my dialer, and to my annoyance, does come up.  So, may be
> this item has been corrected since 2002.  I agree that most users would want
> the dialer dialogue show up when there is no connection.  So this is a none
> issue now.
> 
> So, in summary, a live online/offline Icon on the Firefox is badly missing;
>                 there is no dialer dialog issue that I know of;


Folks, please stop playing with Firefox.

    Yesterday in comment 8 I wrote that the dialer dialog shows up since version 3 up to and including version 7.0.1 of Firefox.
    Today I downloaded version 10.0 and you guessed it; the dialer does not show up any longer.  I have not changed any settings and expected Firefox to have been using all the settings of my previous version 7.0.1 and behave likewise.

    Fortunately, I do not use the Firefox dialer the way the originator of this bug requested.  So you have not heard me complain; but what else is broken?  :)

Note You need to log in before you can comment on or make changes to this bug.