Conn: prompt users to disconnect when quiting

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
17 years ago
3 years ago

People

(Reporter: msanz, Unassigned)

Tracking

(Blocks: 1 bug, {helpwanted})

Trunk
x86
All
helpwanted
Points:
---
Dependency tree / graph
Bug Flags:
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: l10n impact unknown)

(Reporter)

Description

17 years ago
every time I close or exit the program it never prompts about disconnecting. It
should prompt to disconnect the dial up connection
(Reporter)

Comment 1

17 years ago
addigning to myself for now
Assignee: neeti → msanz

Comment 2

17 years ago
How does the application know it's dialed up?
(Reporter)

Comment 3

17 years ago
I don't know; this used to be the scenario in 4.x, some users have requested
this feature in 6.x as well

Comment 4

17 years ago
taking it from msanz (unless there is an objection)
Assignee: msanz → tao

Comment 5

17 years ago
reassign to new owner ->dbragg
Assignee: tao → dbragg

Comment 6

17 years ago
Let's try 1.0.
Priority: -- → P2
Target Milestone: --- → mozilla1.0

Updated

17 years ago
Target Milestone: mozilla1.0 → mozilla1.0.1

Updated

17 years ago
Status: NEW → ASSIGNED
Whiteboard: ETA: 2/15/01

Updated

17 years ago
Whiteboard: ETA: 2/15/01 → ETA: 2/15/02

Updated

17 years ago
Whiteboard: ETA: 2/15/02

Updated

17 years ago
Blocks: 124418
*** Bug 130774 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
Searched MSDN and found these pages:

Remote Access Service (RAS) Overview
http://msdn.microsoft.com/library/en-us/rras/ras4over_4e5o.asp

RAS Disconnecting
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/rras/ras4over_34oj.asp

   ...A RAS client application might need to end a connection even though it
   does not have the handle returned by RasDial. For example, the application
   that called RasDial might have exited once the connection was successfully
   established. In this case, the disconnecting application can use the
   RasEnumConnections function to get all the current connections....

Updated

17 years ago
Severity: normal → major
Target Milestone: mozilla1.0.1 → mozilla1.2alpha

Updated

17 years ago
Summary: mozilla should prompt users to close dial up connection after closing app → Conn: mozilla should prompt users to close dial up connection after closing app

Comment 9

17 years ago
->smeredith
Assignee: dbragg → smeredith
Status: ASSIGNED → NEW

Comment 10

17 years ago
I confirm on WinME with M1.1b b:2002072104. As said - after closing the
navigator it should offer to hang up the dialed line
Daniel

Comment 11

17 years ago
This would best be deployed as part of a "network profile", which is described
in bug 88218.
Summary: Conn: mozilla should prompt users to close dial up connection after closing app → Conn: prompt users to disconnect when quiting

Comment 12

17 years ago
*** Bug 165957 has been marked as a duplicate of this bug. ***

Comment 13

17 years ago
+nsbeta1, really should have been done as part of the other auto-dial work we
did recently.
Keywords: nsbeta1

Comment 14

17 years ago
OS -> all. Dupe was for windows.

This bug is actually somewhat ambiguous, because some people would want a
prompt, others would want Mozilla to auto-disconnect.

We need to decide on a desired behavior. Also, if we decided to implement
auto-disconnect in non-Windows environments, lets create separate bugs.
OS: Windows NT → All

Comment 15

16 years ago
adt: nsbeta1-
Keywords: nsbeta1 → nsbeta1-

Comment 16

16 years ago
ran into the same bug with version 1.4 running on Windows 2000 Professional.  
On closing the browser, the telephone connection is not broken and there is no 
dialog box to offer to end the connection, as there is in Internet Explorer.  
One caveat, though. Downloaded on IE 6.0 that was very buggy and disconnected 
at regular intervals. charliegood@att.net

Comment 17

15 years ago
It appears that this bug has been ignored for the past 18 months.  Is anyone
aware of a patch to the registry or a fix in Mozilla 1.6 or a previous version?  

Netscape had a patch to the registry for Automation Shutdown using a new string
name of NNPE.SHUTDOWN.1.

This bug refers to the fact that when connected via modem and then the Mozilla
session is closed, neither an auto-disconnect or a prompt is issued to terminate
the modem connection.

Comment 18

15 years ago
-> defaults
Assignee: smeredith → darin
Blocks: 61689

Comment 19

15 years ago
*** Bug 241995 has been marked as a duplicate of this bug. ***
*** Bug 251504 has been marked as a duplicate of this bug. ***
Flags: blocking-aviary1.0?

Updated

15 years ago
Keywords: helpwanted
Priority: P2 → --
Target Milestone: mozilla1.2alpha → Future

Comment 21

15 years ago
Does this affect l10n, or does this piggyback on windows stock dialogs?
Whiteboard: l10n impact unknown

Updated

15 years ago
Blocks: 241995

Comment 22

14 years ago
Reading MSDN, it does not look like there is a stock dialog for terminating a
RAS connection.  I believe we'd have to show our own UI, which means that we
would need localized strings.

Another interesting thing I found:

RasHangUp, which is the function used to terminate a connection, does not
complete synchronously.  Instead, an application that calls that function must
sit in a loop polling the system to determine when it is safe to exit the
application.  The documentation actually suggests calling Sleep(3000) after
calling RasHangUp or busy waiting on the result of RasGetConnectStatus! :-(

Comment 23

14 years ago
talking with darin doesn't look like a fix for this will come in time for 1.0. 
renominate if a patch appears.
Flags: blocking-aviary1.0? → blocking-aviary1.0-

Updated

13 years ago
Assignee: darin → nobody
QA Contact: benc → networking
Target Milestone: Future → ---

Comment 24

13 years ago
Similar behaviour has been requested after dial up download of emails in Thunderbird.   <a href="show_bug.cgi?id=160484" >See bug 160484</a>.  What is the point of the "Offline" function in TB if it doesn't actually take the user offline?

It seems what is required is a hang up function which is triggered by options:

TB:
1 - Automatic hang up when closing application
2 - Automatic hang up when completed download of emails
3 - Automatic hang up when status is changed to "Offline"
3 - Ask before automatic hang up (this is for people who might be using the connection for something else, ie FF)

FF:
1 - Automatic hang up when closing application
2 - Ask before automatic hang up (this is for people who might be using the connection for something else, ie TB)

I'm posting this as a end user, not a programmer, so will let pthers more experienced than me to decide if this is a duplicate of 160484 or perhaps they are similar but subtley different?

Comment 25

12 years ago
This is just really-hard-to-do, because for most platforms, there aren't a whole lot of hooks into an application. Some environments allow the modem to dial automatically when an appliaction access an off-line network for the first time, but they usually have auto-disconnect via a timeout.

At best, you might be able to create a network profile with a "this is a dialup profile" flag (assuming we were to add network profiles), and then one of the features of the profile would be "nag me about disconnecting when I quit".

Updated

8 years ago
Blocks: 160484
Severity: major → enhancement
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.