Open Bug 1309037 Opened 5 years ago Updated 4 years ago

Unresponsive Script & Slowness with canvas drawing

Categories

(Core :: Graphics, defect)

49 Branch
All
Windows
defect
Not set
normal

Tracking

()

REOPENED

People

(Reporter: mfunches, Unassigned)

References

()

Details

(Whiteboard: hold)

Attachments

(1 file)

Ensure Firefox 49.0.1, Adobe Flash 23.0.0.162 & Async Rendering Plugin 1.0
Access either of these sites
https://airtightinteractive.com/demos/flash/stage3d/cubes/
http://www.flare3d.com/demos/AncientChina/ (this site is most consistent in the unresponsive script)
Observe: Extremely slow. Unresponsive Script messages. Adobe averaging 50% CPU.
Noticeable on Windows 10 with Fx 64 bit physical as well as Windows 7 and 8.1 virtual machines with Firefox 32bit.
Blocks: 1307108
OS: Unspecified → Windows
Hardware: Unspecified → All
This site http://www.cnn.com/2016/10/10/us/weather-matthew/index.html produces unresponsive script message
Script: http://js.moatads.com/freewhee…/moatvideo.js#_moatApi93784913:32
Windows 8.1 Firefox 32bit, e10s is disabled by addon. 
When e10s is force enabled, the site is faster, and so far I have not been able to produce the script message
Blocks: 1217665
No longer blocks: 1307108
I receive the slow page notification and a spinner with e10s enabled on the china site. The site recovers after it finishes loading. In non-e10s, I get a hung browser followed by a successful load. Similar behavior.
I think this should also block bug 1307108, since I don't want to ship the add-on to release users with this kind of perf regression.
Blocks: 1307108
(In reply to Michelle Funches - QA from comment #1)
> This site http://www.cnn.com/2016/10/10/us/weather-matthew/index.html
> produces unresponsive script message
> Script: http://js.moatads.com/freewhee…/moatvideo.js#_moatApi93784913:32
> Windows 8.1 Firefox 32bit, e10s is disabled by addon. 
> When e10s is force enabled, the site is faster, and so far I have not been
> able to produce the script message

Hey Michelle, can you reproduce that script issue reliably on the cnn page?
Flags: needinfo?(mfunches)
Hi Jim, today I have been unable to reproduce this e10s enabled or disabled, all is well. I am not seeing the slowness or unresponsive script messages. 
Note: yesterday I applied the signed XPI and e10s was disabled by the addon. Kirk provided the install instruction for the system addon (extensions.systemAddon.update.url) and e10 did not need force enable, not sure what difference that could make but thought useful to pass it along.
Flags: needinfo?(mfunches) → needinfo?(jmathies)
Summary: Async Rendering Plugin 1.0 AddOn-Firefox 49.0.1-Adobe Flas 23.0 - Unresponsive Script & Slowness → Async Rendering Plugin 1.0 AddOn-Firefox 49.0.1-Adobe Flash 23.0 - Unresponsive Script & Slowness
Michelle, I'm confused about the status of this bug. Does comment 5 mean this should be resolved WORKSFORME, and if so can you do that? Otherwise please clarify what you think next steps are.
Flags: needinfo?(jmathies)
QA Update: Ancient China site still experiencing issues. Additional investigation needed.

http://www.flare3d.com/demos/AncientChina/
49.0.1 Fx 32bit; "A web page is slowing down your browser. What would you like to do." Self recovered and fully functional within seconds. I did not have to answer by clicking Stop it or Wait. This only applied to the Ancient China link in my original comment.
49.0.2 Fx 32bit; same as detailed above. Screen shot attached.
49.0.1 Fx 64bit; same as detailed above.
49.0.2 Fx64 bit; same as detailed above.

http://www.cnn.com/2016/10/10/us/weather-matthew/index.html as detailed in Comment 1
49.0.2 Fx 64bit site is working w/o errors 
49.0.2 Fx 32bit site is working w/o errors
Attached image Fx32bit_SlowPageMsg.jpg
In comment 7, you report testing against 49.0.1 and 49.0.2, but it's not clear what exactly that means. Are you testing before async rendering (49.0.1 without system addon, async pref off) versus after (49.0.1 with system addon, async pref on)?

The slow script message is not necessarily a sign of a regression. And in this case we have evidence that this is being caused by an ad, which is almost always going to be intermittent.

I'd really like to understand whether you have proved that this is a regression from async rendering or proved that it isn't.
Blocks: 1229961
Flags: needinfo?(mfunches)
Ancient China: The site is slow, however I observe the slowness occurs more frequently when dom.ipc.plugins.asyncdrawing.enabled pref is true
Yes it is intermittent; there may be pauses and the slow message is not always displayed

CNN: previous errors were not observed; testing was with the pref true and false
Flags: needinfo?(mfunches)
Blocks: 1312528
Whiteboard: hold
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → INCOMPLETE
Summary: Async Rendering Plugin 1.0 AddOn-Firefox 49.0.1-Adobe Flash 23.0 - Unresponsive Script & Slowness → Unresponsive Script & Slowness with async plugin drawing
This still happens, although the game is not flash based. it's using emscripten and canvas.
Status: RESOLVED → REOPENED
Component: Plug-ins → Graphics
Resolution: INCOMPLETE → ---
Summary: Unresponsive Script & Slowness with async plugin drawing → Unresponsive Script & Slowness with canvas drawing
No longer blocks: 1229961
The issue is still reproducible on Windows 7/10 x86 with latest Nightly/Beta builds using latest Flash beta build 26.0.0.123

https://airtightinteractive.com/demos/flash/stage3d/cubes/  - cubes are running very slowly and choppy
http://www.flare3d.com/demos/AncientChina/  - Navigation is running frame by frame. Flash has crashed a couple of times during testing.

Flipping the asyncdrawing pref does not make any difference.
You need to log in before you can comment on or make changes to this bug.