Add OAuth2 support for AOL mail accounts

RESOLVED FIXED in Thunderbird 63.0

Status

--
enhancement
RESOLVED FIXED
2 years ago
4 months ago

People

(Reporter: gffletch, Assigned: nvikram.iphone)

Tracking

(Blocks: 1 bug)

Trunk
Thunderbird 63.0

Thunderbird Tracking Flags

(thunderbird52+)

Details

(URL)

(Reporter)

Description

2 years ago
Currently today, Thunderbird only support OAuth2 authorization for IMAP and SMTP for gmail and mail.ru. I'd like to add OAuth2 support for AOL mail accounts. I've successfully modified the ./mailnews/base/util/OAuth2Providers.jsm file allowing me to use OAuth2 to read and send mail via AOL IMAP and SMTP servers.

The change is just the necessary config for AOL's OAuth2 server. I can provide the updated file in whatever is the most expedient way possible. Also if there are automated tests written for OAuth2 mail access, please point me in the correct direction and I'll update those as well.

Updated

2 years ago
Blocks: 1310389

Comment 1

2 years ago
With the purchase of AOL by by Verizon and their subsequent migration of all their existing customers to AOL mail following the finalization of the purchase.  AOL is actually going to be moving back into the mainstream.

As AOL offer oAuth 2.0, we probably should be including them in our offering of supported providers, although from reading their documentation they do not appear to have a desktop application class of application in their documentation.
Status: UNCONFIRMED → NEW
Component: Untriaged → Account Manager
Ever confirmed: true
OS: Unspecified → All
Hardware: Unspecified → All
Version: unspecified → Trunk
(Reporter)

Comment 2

2 years ago
AOL does not externally classify applications as mobile, desktop or web if that's what you mean by "desktop application class". What specific attributes are you interested in by designating a "desktop application class"?

Comment 3

2 years ago
(In reply to George Fletcher from comment #2)
> AOL does not externally classify applications as mobile, desktop or web if
> that's what you mean by "desktop application class". What specific
> attributes are you interested in by designating a "desktop application
> class"?

What I know about the technical requirement is minimal.  I will leave it to Kent to comment on the scope of what is required.  He has the experience in this area, I am no coder.

Comment 4

2 years ago
We should make sure this is in TB 52
tracking-thunderbird52: --- → +

Comment 5

2 years ago
I was going to add a bug to enable OAuth2 support for outlook.com/office365.com, and mention that Yahoo now supports it too.

I strongly recommend this bug just be changed to enable generic Oauth2 support for any server that supports it.

Then just deal with any problematic servers in new bugs, rather than adding servers one by one.

If this idea is not acceptable, and this bug won't be changed to just adding generic OAuth2 support to TB, then please respond/let me know and I'll go open a new bug for adding support for outlook.com/office365.com.

Comment 6

2 years ago
Adding in the Mail.ru bug to see also as an example for the OP on what has to be done.
See Also: → bug 1231642
Just in case I could be helpful, I am CC myself here.
(Assignee)

Comment 8

4 months ago
I have added a review on https://bugzilla.mozilla.org/show_bug.cgi?id=1293958 for Yahoo! and AOL OAuth.

Comment 9

4 months ago
Fixed by bug 1293958.
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 63.0

Updated

4 months ago
Assignee: nobody → nvikram.iphone
You need to log in before you can comment on or make changes to this bug.