Surrogate characters can not be pasted into XP MS word as source format

RESOLVED WORKSFORME

Status

()

Core
Internationalization
P3
normal
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: Yuying Long, Assigned: Jungshik Shin)

Tracking

({intl, topembed})

Trunk
mozilla1.2beta
x86
Windows XP
intl, topembed
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Build: 03-14 trunk build

Steps:
1. Load a page that contains surrogate characters, e.g.:
   http://warp/u/ftang/utf8test/gb18030.cgi?page=596
2. Highlight a character and copy/paste into MS WinXP word.

Result:
Will be pasted as a small square by default(original source format).  A work
around is paste as text only.
(there are 3 options, only this one will work)

IE can be pasted in all 3 options.

Also with gb2312 or non-surrogate 18030 characters can be pasted as original
source format.
(Reporter)

Updated

16 years ago
Keywords: intl
QA Contact: ruixu → ylong

Comment 1

16 years ago
I think we somehow does not generate NCR correctly for surroagte, that may cause
the problem. reassign to ftang for now. 
Assignee: yokoyama → ftang
Priority: -- → P3

Comment 2

16 years ago
assign
Status: NEW → ASSIGNED

Comment 3

15 years ago
give to shanjian. I think this is a serialization issue. We save into a wrong
&#; NCR (two NCR for one surrogate pair instead of one). I think it is a dup of
one bug already assign to shanjian
This is NOT a high priority item. But we should fix it by Q4 2002
Assignee: ftang → shanjian
Status: ASSIGNED → NEW

Comment 4

15 years ago
if frank's guess is true, this is most likely a duplicate of one of my existing
bug. I have no way to verify it because I don't have the latest word software. I
am aware of the problem mentioned by frank  and it should have been fixed in my
local tree. 
Status: NEW → ASSIGNED

Updated

15 years ago
Blocks: 157673

Comment 5

15 years ago
this might be dup of 137657

Comment 6

15 years ago
I want to see we solve all surrogate editing problem by m1.2final. mark it as
nsbeta1+ and tm=m1.2beta
Keywords: nsbeta1+
Target Milestone: --- → mozilla1.2beta

Comment 7

15 years ago
I didn't see any problem with my local build. I will keep it open until I check
in my other surrogate patch. 

Comment 8

15 years ago
batch: adding topembed per Gecko2 document
http://rocknroll.mcom.com/users/marek/publish/Gecko/Gecko2Tasks.html
Keywords: topembed

Comment 9

15 years ago
It works fine on build 2002100409, after those surrogate conversion patches
checked in. 
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Updated

15 years ago
Blocks: 176349

Updated

15 years ago
Depends on: 180372

Updated

15 years ago
No longer blocks: 157673
(Reporter)

Comment 10

14 years ago
This actually still exising in 06-10 1.4 branch build, re-open...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 11

13 years ago
Original demonstration page has disapeared.

I did some test, but unfortunately without the needed fonts so I only saw
questions marks.

With http://bugzilla.mozilla.org/attachment.cgi?id=67079&action=view
All three paste method are problematic. Raw and unicode give twice more question
mark than the number of selected character. 
HTML insert gives one question mark less than the number of character copied if
3 or more character were selected. When selecting only one or two character, I
get nothing.

With http://www.unicode.org/charts/collation/chart_Cypriot.html
HTML seems correct. Raw and unicode still give twice more question mark than the
number of selected character.

Comment 12

13 years ago
shanjian is no longer working on mozilla for 2 years and these bugs are still
here. Mark them won't fix. If you want to reopen it, find a good owner first. 
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago13 years ago
Resolution: --- → WONTFIX
(Assignee)

Comment 13

13 years ago
Perhaps, depends on bug 239279
Status: RESOLVED → REOPENED
Depends on: 239279
Resolution: WONTFIX → ---
(Assignee)

Updated

13 years ago
Assignee: shanjian → jshin1987
Status: REOPENED → NEW
I don't have XP Word here to test, but as far as I can tell from the clipboard
viewer this may be WORKSFORME. Note that an unrelated bug (bug 120114) affecting
Cypriot characters was fixed a little while ago.
All 3 paste methods seem correct in current trunk.
Status: NEW → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.