Closed Bug 1310741 Opened 3 years ago Closed 3 years ago

GL 0:2(12): error: extension `GL_ARB_gpu_shader5' unsupported in vertex shader

Categories

(Core :: Canvas: WebGL, defect, P1)

52 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1319801
Tracking Status
firefox50 --- wontfix
firefox51 --- wontfix
firefox52 --- affected
firefox53 --- affected
firefox62 --- affected
firefox63 --- affected
firefox64 --- affected

People

(Reporter: pavol, Unassigned)

References

Details

(Whiteboard: [gfx-noted])

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20161017030209

Steps to reproduce:

49 "works". Please use ES 3 and do not break this again.
Component: Untriaged → Canvas: WebGL
Product: Firefox → Core
Priority: -- → P1
Whiteboard: [gfx-noted]
I'm experiencing this while viewing a WebGL demo I created.

Steps to reproduce:

1. For reference, in Chrome/Brave, visit http://palebluepixel.org/static/projects/fireflies/
2. Visit http://palebluepixel.org/static/projects/fireflies/ in Firefox

Expected: orange/red particle system appears and flies around, forming a sequence of shapes
Actual: Particle system does not appear.  Console shows "gl.getShaderInfoLog() vertex 0:2(12): warning: extension `GL_ARB_gpu_shader5' unsupported in vertex shader".

Thanks!
I neglected to mention that I'm running Firefox 50.1.0.
(In reply to mwc from comment #2)
> I neglected to mention that I'm running Firefox 50.1.0.

Please test in Beta or Nightly as well.
I tested with Nightly, 54.0a1 (2017-02-10) (64-bit), and the problem persists.

I did see something in the CLI output from Nightly that could be related:

> ATTENTION: default value of option force_s3tc_enable overridden by environment.

I should also note that the 'extension `GL_ARB_gpu_shader5' unsupported' occurs in fragment shaders too.  The error I pasted above only mentioned vertex shaders.
I've seen this on our web site for close to a year -- currently in Nightly. The site uses the Three JS library.
Jeff, I was pointed at this bug via https://github.com/mrdoob/three.js/issues/9716 .

Could you see whether this change is in the version of ANGLE that Firefox is using?

https://chromium-review.googlesource.com/416195/

(from http://crbug.com/671280)

If not, could you try patching it in or upgrading ANGLE? Thanks.
(In reply to Kenneth Russell from comment #6)
> Jeff, I was pointed at this bug via
> https://github.com/mrdoob/three.js/issues/9716 .
> 
> Could you see whether this change is in the version of ANGLE that Firefox is
> using?
> 
> https://chromium-review.googlesource.com/416195/
> 
> (from http://crbug.com/671280)
> 
> If not, could you try patching it in or upgrading ANGLE? Thanks.

It is: bug 1319801
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1319801
Please confirm whether or not you're still seeing this on Nightly.
Flags: needinfo?(burleigh)
Duplicate of this bug: 1350675
@Jeff, still seeing it in Nightly 55.0a1 (2017-03-29) (64-bit), updated a minute ago.

> WARNING: 0:1: extension 'GL_ARB_gpu_shader5' is not supported
https://bugzilla.mozilla.org/show_bug.cgi?id=1319801 says "fixed in 54" - I guess not.
Hi confirming with this three.js demo this bug is still displaying. This is also displaying in Safari on macOS. On Windows this log does not display. 

https://threejs.org/examples/webgl_video_panorama_equirectangular.html

See this ticket also

https://github.com/mrdoob/three.js/issues/9716
Firefox 56 - still have this error: `GL_ARB_gpu_shader5' unsupported in vertex shader

https://yanlinma.com/GeoSound2.github.io/
I have confirmed it has the error: `GL_ARB_gpu_shader5' in FF 56 on OSX, but it doesn't be showed in FF 57, 58. Please look forward our next update. Thanks!
I experienced this problem in Firefox Nightly 59 on Arch linux.

https://codepen.io/Yakudoo/pen/YXxmYR

Works in GNOME Web & Chrome.

GPU description:
Intel Open Source Technology Center -- Mesa DRI Intel(R) HD Graphics 520 (Skylake GT2) 
Driver version: 3.0 Mesa 17.2.6

GPU failure log from about:support (not sure if it is relevant)
Failure Log
(#0) 	CP+[GFX1-]: Failed buffer for 0, 0, 24, 24
I am also seeing this bug. Console warning:

gl.getShaderInfoLog() 0:2(12): warning: extension `GL_ARB_gpu_shader5' unsupported in fragment shader

Firefox 59.0.2 (64-bit) Ubuntu.

Test page: https://threejs.org/examples/#webgl_geometries

I do not get the error viewing the same page in Chrome.
I'm getting the same warning.

THREE.WebGLShader: gl.getShaderInfoLog() fragment 0:2(12): warning: extension `GL_ARB_gpu_shader5' unsupported in fragment shader

https://threejs.org/examples/#webgl_geometries

Firefox 60.0.2 (64-bit) Ubuntu 18.04 LTS
Can confirm this for https://threejs.org/examples/#webgl_geometries. Can this bug be reopened again, please? It's definitely not fixed.
Ubuntu 18.04 FF 61.0.1 this the problem
THREE.WebGLShader: gl.getShaderInfoLog() vertex 0:2(12): warning: extension `GL_ARB_gpu_shader5' unsupported in vertex shader
This is now coming up in Firefox on Ubuntu 16.04.5 LTS (62.0+build2-0ubuntu0.16.04.5).

Visiting https://trac.webkit.org/export/220983/webkit/trunk/LayoutTests/fast/canvas/webgl/no-info-log-for-simple-shaders.html show the following:

    0:1(12): warning: extension `GL_ARB_gpu_shader5' unsupported in vertex shader
    0:1(12): warning: extension `GL_ARB_gpu_shader5' unsupported in fragment shader 

From that test, the vertex shader is:

    attribute vec2 position;
   
    void main() {
      gl_Position = vec4(position.x, position.y, 1.0, 1.0);
    }

and the fragment shader:

    void main() {
      gl_FragColor = vec4(0.0, 0.7, 0.0, 1.0);
    }
This bug is still present in Nightly 64.  I don't think anyone is watching this bug because it is marked as resolved and as a duplicate of another issue and unassigned.  I'm going to file a new bug report that references this one and see if we can get someones attention.
Flags: needinfo?(burleigh)
You need to log in before you can comment on or make changes to this bug.