Closed Bug 1311374 Opened 5 years ago Closed 5 years ago

Video fails to update after exiting full screen and scrolling the video in and out of view

Categories

(Core :: Plug-ins, defect, P2)

x86_64
Windows
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox49 + wontfix
firefox50 --- wontfix
firefox51 --- wontfix
firefox52 --- wontfix
firefox53 --- verified
firefox55 --- verified

People

(Reporter: cbadau, Unassigned)

References

Details

(Keywords: regression, Whiteboard: gfx, layout, STR in comment #0)

Attachments

(1 file)

[Affected versions]:
- Firefox 49.0.2 RC 
- latest Nightly 52.0a1 (2016-10-18)
- latest Aurora 51.0a2 (2016-10-19)
- Firefox 50 Beta 6 

[Affected platforms]:
- Windows 7 
- Windows 10

[Steps to reproduce]:
1. Open Firefox and go to one of the following pages: http://www.nasa.gov/multimedia/nasatv/index.html#public or http://edition.cnn.com/2016/10/10/us/weather-matthew/index.html
2. Play the video. 
3. Enter Full Screen (by clicking the "full screen" button).
4. Press ESC to exit Full Screen.
5. Immediately, scroll down and up and observe the video. 

[Expected result]:
- Video plays without issues. 

[Actual result]:
- The video is blocked: sound goes further, but the image is blocked. 

[Regression range]:
- The issue is not reproducible on 49.0.1 build 3 (buildID: 20160922113459).

[Additional notes]:
- The issue is reproducible only on Windows with 32-bit Firefox builds (on 64-bit builds, the issue is NOT reproducible). 
- The issue is reproducible with and without e10s.
If this is not reproducible in 49.0.1 and *is* reproducible in 49.0.2 RC then it should be a pretty small range. Can you bisect that range please?
Flags: needinfo?(camelia.badau)
Also ni? to :lizzard as FYI as this might be a regression in 49.0.2
Flags: needinfo?(lhenry)
[Tracking Requested - why for this release]:
New regression identified in 49.0.2-build1 (20161018030522), that might affect other websites as well.
This is Flash video (not <video>).
This is almost certainly related to the async painting feature that we already shipped via system addon to 49.0.1 and also enabled by default in 49.0.2.

Matt, can we figure out whether we're sending the wrong visibility signal to Flash, or whether they are incorrectly not sending us frame updates?

I personally do not believe that this should be considered a stop-ship issue.
Flags: needinfo?(matt.woodrow)
Moving to plug-ins based on comment 5.
Component: Panning and Zooming → Plug-ins
I don't know much about async painting of plugins, maybe Jimm is better?
Flags: needinfo?(matt.woodrow) → needinfo?(jmathies)
I'm not having any luck reproducing this in Nightly. I see some weirdness on the cnn video when scrolling, but that appears to be a side effect of the site's treatment of the video when you scroll the main video frame out of view.

Can anyone else reproduce? If so, can you try setting dom.ipc.plugins.asyncdrawing.enabled to false, restart, and see if the issue goes away.
Also, if you can reproduce, please post your about:support text so we can confirm your flash version.
I tried the STR on the cnn video link from comment 0 in my win10 laptop on 50.0b8 and I can see a smooth audio/video playback. My user agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
The issue is no longer reproducible with "dom.ipc.plugins.asyncdrawing.enabled" set to false. 

Also, I want to mention that I have Flash Player 23.0.0.185 installed. 

Please see the gifs with the issue here: 
http://imgur.com/a/GKSDk
http://imgur.com/a/IoOJx
Flags: needinfo?(camelia.badau)
I can reproduce this on nightly x64, Flash 23.0.0.195.
The issue is reproducible on 49.0.1 with Asynchronous Plugin Rendering shipped as a system add-on. 

Therefore, it is not a regression since the bug is also present in release.
I don't think we need to hold up the dot release for this issue. 

Though that may still be a regression from the system add-on (i.e. from enabling async rendering) as Benjamin mentions.  
Jimm can you help find an owner for this? May be good to try to fix it for 50 though we are late in the cycle.
Flags: needinfo?(lhenry)
Keywords: qablockerregression
Blocks: 1229961
I can reproduce this issue with the following specs:
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0

Asynchronous Plugin Rendering is set to true.
More details from Comment 15

Reproducible on Windows 10
CPU             Intel Core i7-4790 CPU @ 3.60GHz
RAM             16.0 GB
Graphics        NVIDIA GeForce GTX 745
Version 	49.0.2
Build ID 	20161019084923
User Agent 	Mozilla/5.0 (Windows NT 10.0; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
Shockwave Flash:23.0.0.162
Aynchronous Rendering Plugin - true
e10s - Disabled
Flags: needinfo?(jmathies)
Whiteboard: gfx, layout
Bas, can you reproduce this?
Flags: needinfo?(bas)
It doesn't appear like I can.
Flags: needinfo?(bas)
Summary: The video is blocked after exiting full screen and scrolling the page on 32bit builds → Video fails to update after exiting full screen and scrolling the video in and out of view
We've reverted the pref dom.ipc.plugins.asyncdrawing.enabled to false in 50.0b10. 50 should be unaffected now. Wontfix for 50 (when the pref is set to true).
(In reply to Grover Wimberly IV [:Grover-QA] from comment #16)
> More details from Comment 15
> 
> Reproducible on Windows 10
> CPU             Intel Core i7-4790 CPU @ 3.60GHz
> RAM             16.0 GB
> Graphics        NVIDIA GeForce GTX 745
> Version 	49.0.2
> Build ID 	20161019084923
> User Agent 	Mozilla/5.0 (Windows NT 10.0; WOW64; rv:49.0) Gecko/20100101
> Firefox/49.0
> Shockwave Flash:23.0.0.162
> Aynchronous Rendering Plugin - true
> e10s - Disabled

Hey Grover, please post the about:support text for this system.
Flags: needinfo?(gwimberly)
(In reply to Camelia Badau, QA [:cbadau] from comment #11)
> The issue is no longer reproducible with
> "dom.ipc.plugins.asyncdrawing.enabled" set to false. 
> 
> Also, I want to mention that I have Flash Player 23.0.0.185 installed. 
> 
> Please see the gifs with the issue here: 
> http://imgur.com/a/GKSDk
> http://imgur.com/a/IoOJx

Camelia, could you please post your about:support text for this system? Thanks!
Flags: needinfo?(camelia.badau)
Attached file aboutsupport.txt
(In reply to Jim Mathies [:jimm] from comment #21)
> (In reply to Camelia Badau, QA [:cbadau] from comment #11)
> > The issue is no longer reproducible with
> > "dom.ipc.plugins.asyncdrawing.enabled" set to false. 
> > 
> > Also, I want to mention that I have Flash Player 23.0.0.185 installed. 
> > 
> > Please see the gifs with the issue here: 
> > http://imgur.com/a/GKSDk
> > http://imgur.com/a/IoOJx
> 
> Camelia, could you please post your about:support text for this system?
> Thanks!

Please see my about:support text in the attachment "aboutsupport.txt" .
Flags: needinfo?(camelia.badau)
Application Basics
------------------

Name: Firefox
Version: 49.0.2
Build ID: 20161019084923
Update Channel: release
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
OS: Windows_NT 10.0
Multiprocess Windows: 0/1 (Disabled)
Safe Mode: false

Crash Reports for the Last 3 Days
---------------------------------

All Crash Reports

Extensions
----------

Name: Multi-process staged rollout
Version: 1.3
Enabled: true
ID: e10srollout@mozilla.org

Name: Pocket
Version: 1.0.4
Enabled: true
ID: firefox@getpocket.com

Name: Web Compat
Version: 1.0
Enabled: true
ID: webcompat@mozilla.org

Graphics
--------

Features
Compositing: Direct3D 11
Asynchronous Pan/Zoom: none
WebGL Renderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 745 Direct3D11 vs_5_0 ps_5_0)
Hardware H264 Decoding: Yes; D3D11 blacklisted with DLL nvwgf2um.dll (10.18.13.5891); Using D3D9 API
Direct2D: true
DirectWrite: true (10.0.14393.351)
GPU #1
Active: Yes
Description: NVIDIA GeForce GTX 745
Vendor ID: 0x10de
Device ID: 0x1382
Driver Version: 10.18.13.5891
Driver Date: 11-5-2015
Drivers: nvd3dumx,nvwgf2umx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um,nvwgf2um
Subsys ID: 106510de
RAM: 4095

Diagnostics
AzureCanvasAccelerated: 0
AzureCanvasBackend: direct2d 1.1
AzureContentBackend: direct2d 1.1
AzureFallbackCanvasBackend: cairo
Decision Log
D3D9_COMPOSITING:
disabled by default: Disabled by default




Important Modified Preferences
------------------------------

browser.cache.disk.capacity: 358400
browser.cache.disk.filesystem_reported: 1
browser.cache.disk.smart_size.first_run: false
browser.cache.frecency_experiment: 2
browser.download.importedFromSqlite: true
browser.places.smartBookmarksVersion: 8
browser.sessionstore.upgradeBackup.latestBuildID: 20161019084923
browser.startup.homepage_override.buildID: 20161019084923
browser.startup.homepage_override.mstone: 49.0.2
browser.tabs.remote.autostart.2: false
browser.urlbar.daysBeforeHidingSuggestionsPrompt: 0
browser.urlbar.lastSuggestionsPromptDate: 20161031
dom.apps.lastUpdate.buildID: 20161019084923
dom.apps.lastUpdate.mstone: 49.0.2
dom.apps.reset-permissions: true
extensions.lastAppVersion: 49.0.2
gfx.crash-guard.d3d11layers.appVersion: 49.0.2
gfx.crash-guard.d3d11layers.deviceID: 0x1382
gfx.crash-guard.d3d11layers.driverVersion: 10.18.13.5891
gfx.crash-guard.d3d11layers.feature-d2d: true
gfx.crash-guard.d3d11layers.feature-d3d11: true
gfx.crash-guard.status.d3d11layers: 2
gfx.crash-guard.status.d3d9video: 2
media.benchmark.vp9.fps: 214
media.benchmark.vp9.versioncheck: 1
media.gmp-eme-adobe.abi: x86-msvc-x64
media.gmp-eme-adobe.lastUpdate: 1477427434
media.gmp-eme-adobe.version: 17
media.gmp-gmpopenh264.abi: x86-msvc-x64
media.gmp-gmpopenh264.lastUpdate: 1477427436
media.gmp-gmpopenh264.version: 1.6
media.gmp-manager.buildID: 20161025030205
media.gmp-manager.lastCheck: 1477585275
media.gmp-widevinecdm.abi: x86-msvc-x64
media.gmp-widevinecdm.lastUpdate: 1477427439
media.gmp-widevinecdm.version: 1.4.8.903
media.gmp.storage.version.observed: 1
media.hardware-video-decoding.failed: false
media.webrtc.debug.log_file: C:\Users\Grover\AppData\Local\Temp\WebRTC.log
network.cookie.prefsMigrated: true
network.predictor.cleaned-up: true
places.database.lastMaintenance: 1477432768
places.history.expiration.transient_current_max_pages: 122334
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
security.sandbox.content.tempDirSuffix: {10a1a3e9-ffe6-45e6-b2f6-c7cd88ec8100}
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1477432768
ui.osk.debug.keyboardDisplayReason: IKPOS: Touch screen not found.

Important Locked Preferences
----------------------------

Places Database
---------------

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.12
Version in use: 4.12

NSS
Expected minimum version: 3.25
Version in use: 3.25

NSSSMIME
Expected minimum version: 3.25
Version in use: 3.25

NSSSSL
Expected minimum version: 3.25
Version in use: 3.25

NSSUTIL
Expected minimum version: 3.25
Version in use: 3.25

Experimental Features
---------------------
Flags: needinfo?(gwimberly)
Camilia, would you please try reproducing with the try build here - 

https://bugzilla.mozilla.org/show_bug.cgi?id=1312242#c26
Flags: needinfo?(camelia.badau)
(In reply to Jim Mathies [:jimm] from comment #24)
> Camilia, would you please try reproducing with the try build here - 
> 
> https://bugzilla.mozilla.org/show_bug.cgi?id=1312242#c26

I've tested with the try build (https://bugzilla.mozilla.org/show_bug.cgi?id=1312242#c26) on Windows 7 x64: the issue is NOT reproducible on this try build, video plays without issues after exiting full screen and scrolling the video in and out of view.
Flags: needinfo?(camelia.badau)
thanks!
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1312242
I'm making the release status the same as bug 1312242 (with a ? for 51 since that bug's patch may still be uplifted).
This is not fixed by 1312242.  In latest Nightly 53.0a1, 20161201030205, after coming out of full screen then trying to scroll the page, the video still hangs while audio continues on.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Whiteboard: gfx, layout → gfx, layout, STR in comment #0
Too late for a fix for 53, fix-optional for 54, minor carryover regression.
Flags: needinfo?(cpeterson)
Priority: -- → P2
The NASA video in comment 0 now uses HTML5 video.

The CNN video is still Flash, but I am not able to reproduce the bug with 64-bit Firefox 53 or Nightly 55.
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Flags: needinfo?(cpeterson)
Resolution: --- → WORKSFORME
I am using Flash version 26.0.0.115 Beta, which might include some async drawing fixes from Adobe that are not in Flash 25.
You need to log in before you can comment on or make changes to this bug.