Closed Bug 1312530 Opened 4 years ago Closed 4 years ago

Force Flash windowless mode under 64-bit firefox in Fx50

Categories

(Core :: Plug-ins, defect)

48 Branch
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla52
Tracking Status
firefox49 --- affected
firefox50 blocking fixed
firefox51 --- fixed
firefox52 --- fixed

People

(Reporter: jimm, Assigned: jimm)

References

Details

(Keywords: dev-doc-needed, flashplayer, site-compat)

Attachments

(1 file)

Async plugin rendering is coming out of 49 and 50. In 50 we'll need to re-establish our forced windowless mode policy.
Assignee: nobody → jmathies
Implementing bug 1305595 will fix this.
Blocks: 1305595
Attached patch patchSplinter Review
Async plugin rendering caused some regressions out on release channel so we've disabled it using a system add-on (bug 1312528).

Internally we have a "force windowless" switch tied to support for async rendering that currently ignore the pref and just checks for support in the flash dll. Add a check for the pref to this switch. 

This patch should land on dev channels and beta.
Attachment #8804237 - Flags: review?(aklotz)
Duplicate of this bug: 1305595
Attachment #8804237 - Flags: review?(aklotz) → review+
Pushed by jmathies@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/14277a31e124
Force windowless plugin mode in 64-bit builds if async rendering is disabled. r=akotz
Comment on attachment 8804237 [details] [diff] [review]
patch

Approval Request Comment
[Feature/regressing bug #]:
async plugin rendering
[User impact if declined]:
broken ime in 64-bit builds in fx 50.
[Describe test coverage new/current, TreeHerder]:
on nightly, manual testing. this is pretty minor patch, it simply checks a new pref.
[Risks and why]:
low, minimal change.
[String/UUID change made/needed]:
none
Attachment #8804237 - Flags: approval-mozilla-beta?
Attachment #8804237 - Flags: approval-mozilla-aurora?
Comment on attachment 8804237 [details] [diff] [review]
patch

This is needed to fix IME related regressions since 49, Aurora51+, Beta50+
Attachment #8804237 - Flags: approval-mozilla-beta?
Attachment #8804237 - Flags: approval-mozilla-beta+
Attachment #8804237 - Flags: approval-mozilla-aurora?
Attachment #8804237 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/14277a31e124
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
Depends on: 1318385
Depends on: 1317995
No longer depends on: 1317995
You need to log in before you can comment on or make changes to this bug.