Closed Bug 1314032 Opened 3 years ago Closed 3 years ago

Crash in mozilla::dom::DOMIntersectionObserver::Update

Categories

(Core :: DOM: Core & HTML, defect, critical)

52 Branch
Unspecified
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla52
Tracking Status
firefox51 --- unaffected
firefox52 + fixed

People

(Reporter: nayinain, Assigned: tschneider)

References

Details

(Keywords: crash, regression, topcrash)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-b17928c2-4a65-44c9-902a-9489f2161031.
=============================================================
Steps to reproduce:

1. Run the following code in Web console (Shift-Ctrl-K).

window.open(URL.createObjectURL(new Blob([
'<meta charset="utf-8">\
<script>\
  let observer = new IntersectionObserver(([entry]) => {\
    document.body.textContent += entry.time\
  });\
  observer.observe(document.documentElement);\
</script>'
], {'type': 'text/html'})));

2. Allow pop-ups If needed.



Actual results:
Browser crash.
I just hit this in Nightly, too. Can you take a look at this, Tobias? Thanks.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(tschneider)
Duplicate of this bug: 1314059
[Tracking Requested - why for this release]: high volume crash
Crash Signature: [@ mozilla::dom::DOMIntersectionObserver::Update] → [@ mozilla::dom::DOMIntersectionObserver::Update] [@ mozilla::dom::CheckSimilarOrigin]
Keywords: crash, topcrash
Duplicate of this bug: 1314061
Looking into it
Assignee: nobody → tschneider
Flags: needinfo?(tschneider)
Blocks: 1314027
Attachment #8806076 - Flags: review?(mstange) → review+
Thanks for the fast review!
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/1e58a5a4ba4a
Add null checks to fix crash in mozilla::dom::DOMIntersectionObserver::Update. r=mstange
Keywords: checkin-needed
Tracking 52+ high volume crash that is new in nightly.
https://hg.mozilla.org/mozilla-central/rev/1e58a5a4ba4a
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
Crash Signature: [@ mozilla::dom::DOMIntersectionObserver::Update] [@ mozilla::dom::CheckSimilarOrigin] → [@ mozilla::dom::DOMIntersectionObserver::Update] [@ mozilla::dom::CheckSimilarOrigin] [@ mozilla::dom::Element::UpdateIntersectionObservation]
This is still a top crash on Nightly. For instance, this crash is from the November 6 Nightly:
  bp-e76cc856-efe5-4ac5-a9e0-367da2161106

Should a new bug get filed for these crashes, or does this need to be reopened?
Flags: needinfo?(tschneider)
Yeah, I'm encountering crashes and sending reports from Nightly while testing my app that I've just added some Intersection Observer API code [1]. The crash is intermittent; sometimes it happens in a few seconds after the app launched, but not always.

[1] https://github.com/bzdeck/bzdeck/commit/6dc07fc
Andrew, please file a new one, since these crashes seem to happen in mozilla::dom::Element::UpdateIntersectionObservation which I'm pretty sure is unrelated to this bug.
See Also: → 1315837
Component: Layout → DOM
Flags: needinfo?(tschneider)
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.