Get Msgs in Newsgroup causes 100% CPU hang

VERIFIED WORKSFORME

Status

MailNews Core
Networking: NNTP
--
critical
VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: WD, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({hang, qawanted})

Trunk
x86
All
hang, qawanted

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.9+)
Gecko/20020316
BuildID:    2002031608

When I click Get Msgs button in MailNews, Mozilla hangs.
Also (probably related), the thread pane is blank.  It doesn't show any message
headers.

Reproducible: Always
Steps to Reproduce:
1.Open MailNews
2.Click on subscribed Newsgroup
3.

Actual Results:  No Hang, headers are shown.

Expected Results:  Mozilla shows no headers when the newsgroup is clicked.
Hangs when Get Msgs is clicked
(Reporter)

Comment 1

17 years ago
Created attachment 74631 [details]
NNTP Log
(Reporter)

Comment 2

17 years ago
I'm not sure if it's related, but I did enable the "Keep only unread messages"
option in the "Ofline & Disk Space" section of the prefs before seeing this
problem.   Disabling the option does not fix the problem, though.

Comment 3

16 years ago
I am seeing this currently with alt.music.mp3 on Linux, trunk CVS.
NNTP log and profile forthcoming
OS: Windows 2000 → All

Comment 4

16 years ago
Created attachment 91301 [details]
profile during attempt to open alt.music.mp3

using news.freeserve.co.uk, profile of Mozilla whilst it is
looping at 100% CPU. I didn't get any output in my nntp log
for some reason.

Comment 5

16 years ago
when I remove the .msf file I don't have the problem. I suspect the file
got corrupt after I ran out of disk space during a previous session ?

Comment 6

16 years ago
.msf file : http://movementarian.org/alt.music.mp3.msf.gz

bug 134866 is possibly a dupe of this.
Keywords: qawanted

Comment 7

16 years ago
I experienced the same problem when subscribing to a large newsgroup (13000
messages). While Mozilla was downloading headers, it was using 100% CPU and the
UI was completely unresponsive (no redraw). Given that I have a 512 kbit DSL
connection, this operation really should not be CPU-bound !

(Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826)

Updated

16 years ago
Blocks: 165832

Comment 8

16 years ago
W2KSP3, Mozilla 13b 20030210
( Maybe this is no longer "NEW" :-)
I'm having the same problem, only up to 99% CPU (as low as 87% when other
taskbar resident process is running.)

This is a new setup, with freshly re-installed OS and clean first install of
Mozilla 1.3b. There is only one irregularity in the setup of Mozilla, which may
give a programmer a clue about where the bug comes in.

Yesterday, while reinstalling all my applications, before I had figured out
(again) how to set up Mozilla to use my mail profile and data saved on disk, I
was checking the Web for updates to WordPerfect. At that time I got onto the NG
fine in the temporary default profile Mozilla had set up for me, and posted a
question. Then, after I got my old Mozilla profile set up (and deleted the
default profile), I cannot get any messages from the NG; trying to see any
messages hangs Mozilla (but not necessarily other programs already running).

Comment 9

16 years ago
Followup to Comment #8

I set up a W2K user account for myself, invoked Mozilla Profile Manager, deleted
the default profile and associated files, and directed PM to the old profile.
Other NGs work OK, and I can subscribe to new NGs, as I just subscribed again to
netscape.mozilla.public.general. There is a problem at the Corel NG. I can
subscribe to the Quattro NG, but it does not list any messages. (I don't think
I've used the context menu for "Get Messages for Account" on that NG, and I'm
afraid that maybe it will hang now if I try that. When unsubscribed from and
resubscribed to the WordPerfect NG, I got the same hangup.

Comment 10

16 years ago
Followup to Comment #8 and Comment #9

I deleted the Corel account and re-subscribed, and now it is working.
WD: Can you reproduce this with current builds ?
(Reporter)

Updated

15 years ago
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
No response, and I can't reproduce this with build 2004-05-12-08 on Windows XP
with news.verizon.net
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.