Closed Bug 1319164 Opened 3 years ago Closed Last year

Message XP/Vista users running ESR 52.9 to inform them that support/security updates have ended (2018 Q2)

Categories

(Firefox :: Security, enhancement, P3)

x86
Windows XP
enhancement

Tracking

()

RESOLVED FIXED
Tracking Status
firefox-esr52 61+ fixed

People

(Reporter: pdol, Assigned: jlorenzo)

References

(Blocks 1 open bug)

Details

User Story

As Mozilla, we want to message XP/Vista users upon final XP/Vista end of life so that they are aware and can take appropriate action to protect themselves should they choose to.

We will use the de-support xml notice that is already in the product - that is, no need for new localization.
Here is the SUMO link to be used in the product: https://support.mozilla.org/1/firefox/%VERSION%/%OS%/%LOCALE%/xp-eol
+++ This bug was initially created as a clone of Bug #1319162 +++
No longer depends on: 1315153
Michelle, we'll need copy for this message as well.

While message 2 (Bug #1319162) was to tell the user that all updates (including security updates) will stop on a certain date, this message is to tell the user that they will no longer get updates (as in that date has arrived), again linking to a blog post.

It would likely make sense to say something like "...because Windows XP and Vista are no longer supported".

For reference, Chrome's message was: "This computer will no longer receive Google Chrome updates because Windows XP and Windows Vista are no longer supported".
Flags: needinfo?(mheubusch)
Added copy
User Story: (updated)
Flags: needinfo?(mheubusch)
For this particular message, we will simply use the de-support xml notice that is already in the product - that is, no need for new localization.  I'm told release management can trigger it via an xml file.  I'll update the other bugs to describe the new plan as well (which also won't require localization in the product).
User Story: (updated)
Summary: Message XP/Vista users to inform them that support/security updates have ended → Message XP/Vista users to inform them that support/security updates have ended (2018 Q1)
User Story: (updated)
Added SUMO link to user story
User Story: (updated)
User Story: (updated)
Severity: normal → enhancement
Priority: -- → P3
Romain, Peter, is that still on the roadmap for XP EOL?
Flags: needinfo?(rtestard)
Flags: needinfo?(pdolanjski)
The next ESR has moved from 59 to 60, so ESR 52 will have one extra release (52.9) on 2018-07-03. This will push our XP EOL messages back by one release.
Summary: Message XP/Vista users to inform them that support/security updates have ended (2018 Q1) → Message XP/Vista users to inform them that support/security updates have ended (2018 Q2)
ESR 52.9, the last ESR 52 version, will be released on June 26.
Summary: Message XP/Vista users to inform them that support/security updates have ended (2018 Q2) → Message XP/Vista users running ESR 52.9 to inform them that support/security updates have ended (2018 Q2)
(In reply to Chris Peterson [:cpeterson] from comment #8)
> ESR 52.9, the last ESR 52 version, will be released on June 26.

The last _planned_ ESR-52 release. It's still supported until ESR 60.2 is released (September) and there's always a small chance of a point release if there's some kind of a zero-day in that period.
Note that SUMO has a list of locales slightly different from the ones we ship in product.

ja -> means ja, ja-JP-mac
es -> means es-AR, es-CL, es-ES, es-MX
no -> means nb-NO, nn-NO
Mihai, here is the link to the XP EOL SUMO page:

https://support.mozilla.org/kb/end-support-windows-xp-and-vista

Here is the list of localized versions of the SUMO page:

https://support.mozilla.org/en-US/kb/end-support-windows-xp-and-vista/show_translations

We want to show this WNP only to Windows XP and Vista users when they update to ESR 52.9. We do *not* need to show this page to Windows 7/8/10, macOS, or Linux users updating to ESR 52.9 or ESR 60.x.

We also want to add a desupport notice (in the "About Firefox" dialog) for Windows XP and Vista users on ESR 52.9. Rail added a desupport notice for Firefox Nightly and Aurora users on XP and Vista last year in bug 1319167.
Assignee: nobody → mtabara
Flags: needinfo?(mtabara)
(In reply to Chris Peterson [:cpeterson] from comment #11)
> Mihai, here is the link to the XP EOL SUMO page:
> 
> https://support.mozilla.org/kb/end-support-windows-xp-and-vista
> 
> Here is the list of localized versions of the SUMO page:
> 
> https://support.mozilla.org/en-US/kb/end-support-windows-xp-and-vista/
> show_translations

Thanks for providing these.
 
> We want to show this WNP only to Windows XP and Vista users when they update
> to ESR 52.9. We do *not* need to show this page to Windows 7/8/10, macOS, or
> Linux users updating to ESR 52.9 or ESR 60.x.

We've already set that up for 52.9.0esr build1 and that applies for 52.9.0esr build2 as well (most recent build).
QA confirmed that's working fine in https://public.etherpad-mozilla.org/p/esr-52.9.0-build1 so that should apply for build2 as well. Cornel Ionce confirmed in IRC "we'll make sure to also cover the WNP for xp/vista on esr 52.9.0 today".

> We also want to add a desupport notice (in the "About Firefox" dialog) for
> Windows XP and Vista users on ESR 52.9. Rail added a desupport notice for
> Firefox Nightly and Aurora users on XP and Vista last year in bug 1319167.

Hm, I'm confused. I thought the Desupport page would come up only in September when we specifically have this EOL. Settting this up Balrog is easy, but let me double-check with :Rail, maybe I misunderstood the mechanics behind the updates rules. 

I'll leave the NI info until I reach back later in the day with a confirmed answer.
(In reply to Mihai Tabara [:mtabara]⌚️GMT from comment #12)
> We've already set that up for 52.9.0esr build1 and that applies for
> 52.9.0esr build2 as well (most recent build).
> QA confirmed that's working fine in
> https://public.etherpad-mozilla.org/p/esr-52.9.0-build1 so that should apply
> for build2 as well. Cornel Ionce confirmed in IRC "we'll make sure to also
> cover the WNP for xp/vista on esr 52.9.0 today".

Looks good!

> > We also want to add a desupport notice (in the "About Firefox" dialog) for
> > Windows XP and Vista users on ESR 52.9. Rail added a desupport notice for
> > Firefox Nightly and Aurora users on XP and Vista last year in bug 1319167.
> 
> Hm, I'm confused. I thought the Desupport page would come up only in
> September when we specifically have this EOL. Settting this up Balrog is
> easy, but let me double-check with :Rail, maybe I misunderstood the
> mechanics behind the updates rules. 

September does make more sense since we will continue to provide 52.9.x dot releases until then. Sorry for the confusion. I'll make a note to follow up about the desupport notice then.

You mention a desupport *page*. Does the feature open a page in a new tab? I thought it was just a short message in the About dialog?
(In reply to Chris Peterson [:cpeterson] from comment #13)
> September does make more sense since we will continue to provide 52.9.x dot
> releases until then. Sorry for the confusion. I'll make a note to follow up
> about the desupport notice then.

No worries, more double-checking is good. Better safe than sorry :)
Mea culpa for the delays in replying here.

> You mention a desupport *page*. Does the feature open a page in a new tab? I
> thought it was just a short message in the About dialog?

Sorry, bad terminology from me. You're absolutely right, that's what a desupport page is: a short message in the About Firefox dialog.
Flags: needinfo?(mtabara)
Mihai published the WNP for 52.9, but we should leave this bug open as a reminder to publish the desupport notice after 52.9 EOL on September 5.
(In reply to Chris Peterson [:cpeterson] from comment #15)
> Mihai published the WNP for 52.9, but we should leave this bug open as a
> reminder to publish the desupport notice after 52.9 EOL on September 5.

Tom and Johan are releaseduty this cycle, with Jordan as backup. I've CC'ed all three in this bug. One of them will take care of the Desupport blob next week so please feel free to ping them here or in #releaseduty.
Assignee: mtabara → nobody
Thanks, Mihai. I was just about to email you about the desupport notice. :)

Kohei is adding a similar warning to the Firefox download pages for XP/Vista visitors (in bug 1339226).
Tom or Johan, do you need any more information about the XP desupport notice? Firefox ESR 52.9 is the last version to support Windows XP or Vista and ESR 52.9 will be EOL'd this week.

We stopped support XP and Vista in the Rapid Release channel after Firefox 52.0. Will this desupport notice show up for XP and Vista users running Firefox versions < 52.9?
Flags: needinfo?(mozilla)
Flags: needinfo?(jlorenzo)
Yes, it will! I think we're all good in terms of what page needs to be displayed. Thank you for asking :)

Yesterday, I configured [1] so that XP/Vista users on esr-localtest get the desupport notice. It points to [2], which does display the ESR notice.

I'm waiting to hear back from QE to see if I missed some implementation detail. If not, I'll be happy to promote the rule to esr-cdntest and then to esr. 

[1] https://aus5.mozilla.org/api/v1/rules/828
[2] https://support.mozilla.org/1/firefox/52.0/win/en-US/xp-eol
Flags: needinfo?(mozilla)
Flags: needinfo?(jlorenzo)
This was done.
Assignee: nobody → jlorenzo
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Blocks: 1480476
You need to log in before you can comment on or make changes to this bug.