Closed Bug 1319398 Opened 6 years ago Closed 6 years ago

Shortcuts in the new debugger conflict with global shortcuts (like F10/F11)

Categories

(DevTools :: Debugger, defect)

52 Branch
x86_64
Windows 10
defect
Not set
normal

Tracking

(firefox50 unaffected, firefox51 unaffected, firefox52 disabled, firefox53 fixed)

VERIFIED FIXED
Tracking Status
firefox50 --- unaffected
firefox51 --- unaffected
firefox52 --- disabled
firefox53 --- fixed

People

(Reporter: terrawheat, Unassigned)

References

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20161121004022

Steps to reproduce:

Create any script with a `debugger` statement or use a breakpoint from Dev tools


Actual results:

The debugger triggers, but when using keyboard shortcuts to navigate through the code (particularly F10 and F11 for step over/in) the native key function is also triggered, results in the menu bar or full screen behaviour respectively.


Expected results:

Just the debugger behaviour while debugger is active, the code under debug should have advanced a statement (in or over, depending on the key).
Component: Untriaged → Developer Tools: Debugger
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
I've also just noticed that this bug doesn't happen if the developer tools are detached in their own window.
Hey Greg,

Is this something that you know about? Or where it should go etc?

Thanks!
Flags: needinfo?(gtatum)
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=68be9a5221854bcb29884f648bcebc706125e943&tochange=4850895eb2fbee98b74a885ea00be1cadc352313
Blocks: 1300861
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Summary: Debugger shortcuts conflict with global shortcuts → Shortcuts in the new debugger conflict with global shortcuts (like F10/FF11)
Summary: Shortcuts in the new debugger conflict with global shortcuts (like F10/FF11) → Shortcuts in the new debugger conflict with global shortcuts (like F10/F11)
IIUC, the new debugger is still Nightly-only. Does this reproduce on Aurora/DevEdition?
(In reply to Ryan VanderMeulen [:RyanVM] from comment #4)
> IIUC, the new debugger is still Nightly-only. Does this reproduce on
> Aurora/DevEdition?

Yes, Aurora is affected too.
I have never had my shortcuts work on my mac with the debugger where there is a system shortcut over it. I can reproduce on any version of Firefox. Chrome has the following convention on Mac that I think we should follow, especially in light of the function bar going away with new Macbooks.

Resume Script Execution: ⌘ + \
Step Over: ⌘ + '
Step In: ⌘ + ;
Step Out: ⌘ + shift + ;
Flags: needinfo?(gtatum) → needinfo?(jlaster)
terrawheat, we're fixing function shortcuts here: https://github.com/devtools-html/debugger.html/pull/1373

:gregtatum, that's interesting I wasn't aware that these shortcuts were supposed to be handled. I created a new issue for it here https://github.com/devtools-html/debugger.html/issues/1430
Flags: needinfo?(jlaster)
Sorry if this is documented somewhere but how often do we import from github? My quick glances at the issue and PR you reference in comment 7 make me think this is fixed and maybe just needs to be imported (or maybe it already is?)? Thanks.
Flags: needinfo?(jlaster)
(In reply to [PTO 20-Dec to 28-Dec] Ryan VanderMeulen [:RyanVM] from comment #4)
> IIUC, the new debugger is still Nightly-only. Does this reproduce on
> Aurora/DevEdition?

Just to get it on this bug: it's shipping in 52 (bug 1294139).
We'll be landing a new version the debugger soon, we were waiting on bug 1328679 and now that just needs to uplift to Aurora.  And in this quarter we will be getting into a regular cadence of debugger lands.
I am seeing this same behavior with 52.0a2 (2017-01-12) (64-bit), and I am using Gnome 3.0 on Ubuntu. I would like to use FF dev edition, but I need debugging to work without this bug. Thanks!
These fixes landed in the latest Nightly.  Please verify.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
I just pulled the latest build for the Dev Edition Aurora and I can still repro the issue with F10 and the debugger.

When I pull the latest nightly build 53.0a1, I do not see the error when debugging and hitting F10, but I never had the problem in Firefox, only in Firefox Dev Aurora. I am sorry if I did not clarify that.

I would like to be able to use the dev edition for my local dev work, because I think the dev edition provides some features that standard Firefox does not. I started using the dev edition and that is when I ran into the bug.

I pulled the latest builds from here, https://www.mozilla.org/en-US/firefox/channel/desktop/

I am not sure if this bug is being fixed for Firefox or for the Firefox Dev Edition, or maybe both. Let me know where I should be testing/verify the fix. Thank you and sorry for the confusion.
Thanks Alex, the fix will go into Aurora shortly.  Try Aurora next week when the update rolls out.
Status: RESOLVED → VERIFIED
Any updates on a backport patch for Beta52 here?
Flags: needinfo?(clarkbw)
The bug fix now works in Aurora 53.0a2 (2017-01-30). Thanks!
(In reply to Ryan VanderMeulen [:RyanVM] from comment #15)
> Any updates on a backport patch for Beta52 here?

I didn't have plans for an uplift as the debugger is still pref'd off for Beta.
Flags: needinfo?(clarkbw)
Thanks, sounds like we're good here then.
Flags: needinfo?(jlaster)
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.