Closed Bug 1300861 Opened 3 years ago Closed 3 years ago

Enable new debugger frontend in nightly builds

Categories

(DevTools :: Debugger, defect, P1)

defect

Tracking

(firefox51 fixed)

RESOLVED FIXED
Firefox 51
Tracking Status
firefox51 --- fixed

People

(Reporter: bgrins, Assigned: bgrins)

References

Details

(Keywords: dev-doc-needed)

Attachments

(2 files, 1 obsolete file)

We can flip on devtools.debugger.new-debugger-frontend when #if defined(NIGHTLY_BUILD)
Assignee: nobody → bgrinstead
Status: NEW → ASSIGNED
Current plan is to land this on Thursday
Comment on attachment 8788586 [details]
Bug 1300861 - Enable new debugger frontend in nightly builds;

https://reviewboard.mozilla.org/r/77024/#review75228

Thanks for doing this!
Attachment #8788586 - Flags: review?(jlong) → review+
Pushing a try for this. I'm sure there will be some breakage and we need to see how realistic this is landing today. https://treeherder.mozilla.org/#/jobs?repo=try&revision=49bd9adbe136
Here's a completed try pushed through mozreview: https://treeherder.mozilla.org/#/jobs?repo=try&revision=84ddaec8eb15.  You're right, there's breakage mostly in other test folders when they open the debugger.  We should look at each error and determine if it's an actual problem or if it's just that the test is digging into the old debugger JS / DOM.  If the latter we could pushPrefEnv to keep old debugger on for each test individually and file a follow up bug to adapt it to the new frontend
Depends on: 1301487
Depends on: 1301716
I made a try push as well. This is the attached patches as well a few more fixes in https://public.etherpad-mozilla.org/p/LSpcXe7hqC. All of the tests should be fixed except for a view source one, which is a legit failure that we need to fix on our end.
I meant to say the fixes from bug 1301716.
Oops, didn't paste the link. I think this is the right one: https://treeherder.mozilla.org/#/jobs?repo=try&revision=afd5f1b92dc1
We had some problem with tests since merging the CodeMirror PR, but I think we've fixed them. The run for bug 1301487 looks good so here's a new run with the updated debugger that has working tests. This run enables it by default. (has this patch and the one from bug 1301716)

https://treeherder.mozilla.org/#/jobs?repo=try&revision=9ea7ea537cb5
Depends on: 1302158
Steps for landing this:

* Land bug 1302158 to call our shutdown method
* Land bug 1301487 to update the new debugger (also lands some tests)
* Land bug 1301716 to get tests ready for the new debugger
* Land this bug to turn it on.
Just realized the above try run didn't have bug 1302158, so here's a new final run with all patches: https://treeherder.mozilla.org/#/jobs?repo=try&revision=0e03cf7a3e3c
Final patch for getting all tests passing.
Attachment #8790367 - Flags: review?(bgrinstead)
Enabled in nightly. I think it's the same as before but there a lot of patches going around and want to make sure I'm using exactly the same ones that I pushed to try.
Attachment #8788586 - Attachment is obsolete: true
Attachment #8790368 - Flags: review+
Priority: -- → P1
Duplicate of this bug: 1301716
I simplified things a bit. Now, just need to land bug 1301487 first and then land this one.
Comment on attachment 8790367 [details] [diff] [review]
1300861-tests.patch

Review of attachment 8790367 [details] [diff] [review]:
-----------------------------------------------------------------

Looks fine to me.  Just update the nit before landing

::: devtools/client/canvasdebugger/test/browser_canvas-frontend-call-stack-01.js
@@ +8,5 @@
> +// Force the old debugger UI since it's directly used (see Bug 1301705)
> +Services.prefs.setBoolPref("devtools.debugger.new-debugger-frontend", false);
> +registerCleanupFunction(function* () {
> +  Services.prefs.clearUserPref("devtools.debugger.new-debugger-frontend");
> +})

Nit on all of these changes: missing semicolon at the end of the block.  Please update all the tests that use it
Attachment #8790367 - Flags: review?(bgrinstead) → review+
Thanks bgrins.

Oops, I didn't have any try syntax in the last run. This should do it: https://treeherder.mozilla.org/#/jobs?repo=try&revision=fde44000cbc2
Pushed by jlong@mozilla.com:
https://hg.mozilla.org/integration/fx-team/rev/a71db5e5d89b
enable new debugger in nightly r=bgrins
https://hg.mozilla.org/mozilla-central/rev/a71db5e5d89b
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 51
This yet another "improvement" broke the following things:

1. Prettify button doesn't work
2. Code area doesn't resize when I resize toolbox
3. Width of each sidebar isn't preserved upon devtools restart
4. Error isn't displayed in debugger. It just shows "Error"
5. Bug 1258114 reintroduced for vertical splitters in debugger
6. No context menu in code area
7. Bug 1197506 now is TOO easy to reproduce: start text selection in tab title in debugger
8. There's no way to break on event
9. "..." button doesn't disappear when I resize sidebars to display all opened sources
10. Bug 1261970 now is TOO easy to encounter
11. No way to find string in current source or in all sources

I won't test this further.
(In reply to arni2033 from comment #23)
> This yet another "improvement" broke the following things:

https://imgflip.com/i/1ajis4 and things will break as we land new stuff.  Overall this is a huge improvement from the previous debugger and we'll investigate the issues you've raised.  Thanks for listing them all out.

I've added GitHub issues for items where we are currently tracking the problem.  For others I'll need to add issues so we can further investigate.  

> 1. Prettify button doesn't work

I haven't seen this before, we should file a new bug with steps to reproduce and errors from console etc.

> 2. Code area doesn't resize when I resize toolbox

https://github.com/devtools-html/debugger.html/issues/705

> 3. Width of each sidebar isn't preserved upon devtools restart

Likely an issue with the move away from XUL to HTML.  Need a bug for this.

> 4. Error isn't displayed in debugger. It just shows "Error"

Error in the Editor?  That's the sign of an error loading the source file.  Or is this about something else?

> 5. Bug 1258114 reintroduced for vertical splitters in debugger

https://github.com/devtools-html/debugger.html/issues/669

> 6. No context menu in code area

Context menus are not coming right away.  We should file issues for individual items in the context menus so we can evaluate them.

> 7. Bug 1197506 now is TOO easy to reproduce: start text selection in tab title in debugger

This looks like the boundary between codemirror and the gutter and the html that surrounds it.

> 8. There's no way to break on event

Coming, need a tracking issue on github for this.

> 9. "..." button doesn't disappear when I resize sidebars to display all opened sources

Interesting, haven't seen this.  Will need a github issue to track this.

> 10. Bug 1261970 now is TOO easy to encounter

Which buttons?  The pretty print button has been moved to the editor, is this still the case?

> 11. No way to find string in current source or in all sources

Search for files is now (cmd or ctrl + P)

Search in files is here:
https://github.com/devtools-html/debugger.html/issues/716
I just wanted to make sure that all obvious issues are known. I don't have time for all of them.
Thanks for github links anyway.

> 1. ... a new bug with steps to reproduce and errors from [browser] console etc.
Easy. It never works, nothing in console. Test https://www.mozilla.org/en-US/firefox/nightly/firstrun/

> 4. > Error in the Editor?  That's the sign of an error loading the source file.
Yes, when old debugger can't load source, it shows me number of error and stack trace.

> > 9. "..." button doesn't disappear when I resize sidebars to display all opened sources
> Interesting, haven't seen this.  Will need a github issue to track this.
Actually, change 9. to «"..." button and list don't update their state when source panel is resized»:
When I increase width of source while "..." list is opened, and all scripts become visible, list stays
visible. When I reduce width of source, and some opened script becomes invisible, "..." doesn't appear

> 10. > Which buttons?  The pretty print button has been moved to the editor, is this still the case?
Huh, so "It's possible to accidentally deform panels in Debugger" part doesn't sound bad enough...
Ok, the following buttons may become invisible (watch screencast [1]):
Ignore exceptions, Disable breakpoints, Step out, Step over, Step in, Click to pause, Prettify source

[1] https://dl.dropboxusercontent.com/s/1fpc23ypfzq6oc5/bug%201300861%20comment%2026.webm
Depends on: 1302647
Duplicate of this bug: 987685
I've managed this issue on this bug in Nightly 51.0a1 (2016-09-04) ; (Build ID: 20160904030201) from Ubuntu (16.04 Bit)

This Bug is now verified as fixed on Latest Firefox Nightly 52.0a1 (2016-09-21) (64-bit) 

Build ID: 20160921030221
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
OS: Linux 4.4.0-36-generic; Ubuntu 16.04.1 (64 Bit)
QA Whiteboard: [bugday-20160921]
I have reproduced this bug with Nightly 51.0a1 (2016-09-06) on WIndows 7 ,64 Bit !

This bug's fix is verified this latest Nightly

Build ID    : 20160921030221
User Agent  : Mozilla/5.0 (WindowsNT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0

[bugday-20160921]
Depends on: 1313196
Depends on: 1319398
Depends on: 1322062
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.