Summary gets truncated when it contains emoji like this

RESOLVED DUPLICATE of bug 1253535

Status

()

RESOLVED DUPLICATE of bug 1253535
2 years ago
2 years ago

People

(Reporter: alex.fdm, Unassigned)

Tracking

Production

Details

(Reporter)

Description

2 years ago
I can enter a summary containing an emoji, like this one, but if I edit it it gets truncated from the emoji to the end.

I found this issue when editing bug #1176020.
(Reporter)

Updated

2 years ago
Summary: Summary gets truncated when it contains emoji like this → Summary gets truncated when it contains emoji like this
(Reporter)

Comment 1

2 years ago
Notice the page title contains an emoji and extra text, which was truncated on the page body.
Summary: Summary gets truncated when it contains emoji like this → Summary gets truncated when it contains emoji like this
(Reporter)

Updated

2 years ago
Summary: Summary gets truncated when it contains emoji like this → Summary gets truncated when it contains emoji like this

Comment 2

2 years ago
See bug 405011 - already fixed in Bugzilla version 5.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Summary: Summary gets truncated when it contains emoji like this → Summary gets truncated when it contains emoji like this
Duplicate of bug: 405011
This is not fixed in bugzilla 5 -- bug 405011 only addresses comments.

Reporter: If you are using a very recent version of MySQL, I have a patch you can apply that will
allow bugzilla on mysql to use emoji.
Status: RESOLVED → REOPENED
Flags: needinfo?(alex.fdm)
Resolution: DUPLICATE → ---
(Reporter)

Comment 4

2 years ago
Thanks, but I don't have a Bugzilla server, my report is about https://bugzilla.mozilla.org/
(Reporter)

Comment 5

2 years ago
The problem is worse than I detected at first, the summary gets truncated on every edit on the bug, even if the summary itself is not edited.
Flags: needinfo?(alex.fdm)
Summary: Summary gets truncated when it contains emoji like this → Summary gets truncated when it contains emoji like this
(Reporter)

Updated

2 years ago
Summary: Summary gets truncated when it contains emoji like this → Summary gets truncated when it contains emoji like this
Bugs against bugzilla.mozilla.org specifically should be filed in that product.
Assignee: create-and-change → nobody
Component: Creating/Changing Bugs → Bug Creation/Editing
Product: Bugzilla → bugzilla.mozilla.org
QA Contact: default-qa
Summary: Summary gets truncated when it contains emoji like this → Summary gets truncated when it contains emoji like this
Version: unspecified → Production
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1253535
You need to log in before you can comment on or make changes to this bug.