Address book: Edit > Search Addressed doesn't work on current trunk

RESOLVED FIXED in Thunderbird 53.0

Status

Thunderbird
Address Book
RESOLVED FIXED
5 months ago
5 months ago

People

(Reporter: Jorg K (GMT+2), Assigned: Jorg K (GMT+2))

Tracking

Trunk
Thunderbird 53.0

Thunderbird Tracking Flags

(thunderbird52 fixed, thunderbird53 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 months ago
Address book: Edit > Search Addressed doesn't work on current trunk

Console says:
NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIStringBundle.GetStringFromName] XStringBundle:22
  getString XStringBundle:22:22
  gSearchAbViewListener.onCountChanged chrome://messenger/content/ABSearchDialog.js:39:22
  SetAbView chrome://messenger/content/addressbook/abResultsPane.js:76:26
  onSearch chrome://messenger/content/ABSearchDialog.js:294:5
  onSearchButton chrome://messenger/content/ABSearchDialog.js:301:9
  oncommand chrome://messenger/content/ABSearchDialog.xul:1:1

Lovely, ABSearchDialog.js:39 still has:
  .get(aTotal, gAddressBookBundle.getString("matchesFoundCount"))
That string was retired in bug 1313950.
(Assignee)

Comment 1

5 months ago
Created attachment 8816742 [details] [diff] [review]
1322026-found-count-string.patch
Assignee: nobody → jorgk
Status: NEW → ASSIGNED
Attachment #8816742 - Flags: review?(acelists)

Comment 2

5 months ago
No, bug 1313950 was fine, we forgot to change it in bug 1320570.
Blocks: 1320570
OS: Unspecified → All
Hardware: Unspecified → All

Comment 3

5 months ago
Comment on attachment 8816742 [details] [diff] [review]
1322026-found-count-string.patch

Review of attachment 8816742 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks.
Attachment #8816742 - Flags: review?(acelists) → review+
(Assignee)

Comment 4

5 months ago
https://hg.mozilla.org/comm-central/rev/59608977c7bd08fe89b336e382480f9285eff695
Landed with corrected commit message:
Bug 1322026 - Bug 1320570 follow-up: Fixed string name for plural form. r=aceman a=jorgk
Status: ASSIGNED → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 53.0
(Assignee)

Comment 5

5 months ago
Comment on attachment 8816742 [details] [diff] [review]
1322026-found-count-string.patch

[Approval Request Comment]
Regression caused by (bug #): Bug 1320570
Bug 1320570 is considered for uplift, so this one needs to go, too.
Attachment #8816742 - Flags: approval-comm-aurora?
(Assignee)

Comment 6

5 months ago
Comment on attachment 8816742 [details] [diff] [review]
1322026-found-count-string.patch

Aurora (TB 52):
https://hg.mozilla.org/releases/comm-aurora/rev/a463541c03479c64a0a29601a25553b8d89d561a
Attachment #8816742 - Flags: approval-comm-aurora? → approval-comm-aurora+
(Assignee)

Updated

5 months ago
status-thunderbird52: --- → fixed
status-thunderbird53: --- → fixed
You need to log in before you can comment on or make changes to this bug.