Closed Bug 1323389 Opened 4 years ago Closed 4 years ago

Thunderbird devtools: TypeError: this.gViewSourceUtils is undefined hudservice.js:446:5 when clicking on a source file

Categories

(Thunderbird :: General, defect)

52 Branch
Unspecified
All
defect
Not set
normal

Tracking

(thunderbird52+ fixed, thunderbird53 fixed)

RESOLVED FIXED
Thunderbird 53.0
Tracking Status
thunderbird52 + fixed
thunderbird53 --- fixed

People

(Reporter: jorgk-bmo, Assigned: Fallen)

References

Details

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1318737 +++

In the Error console, clicking on a source file doesn't open that source file. Instead you get:
TypeError: this.gViewSourceUtils is undefined hudservice.js:446:5
I cannot reproduce this on latest comm-central on mac. I guess this is on windows?
OS: Unspecified → Windows
Thanks for looking. Yep, still getting:
  TypeError: this.gViewSourceUtils is undefined[Learn More]  hudservice.js:446:5
with a Daily. MMD also mentioned this problem during a Tuesday meeting, I don't know which platform he's on.
I wasn't very clear: Yep, still getting this with a Daily on Windows.
Attached patch Fix - v1Splinter Review
Ok got it, the devtools part mislead me into testing in the toolbox instead of in the error console. This should fix it.

Try run that also fixes the blank console issue: https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=f93fbea3f9662624d734787032b11b33f4b27026
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #8827166 - Flags: review?(mkmelin+mozilla)
OS: Windows → All
Comment on attachment 8827166 [details] [diff] [review]
Fix - v1

Thanks, works for me. I downloaded the try build.
Attachment #8827166 - Flags: review+
Comment on attachment 8827166 [details] [diff] [review]
Fix - v1

Review of attachment 8827166 [details] [diff] [review]:
-----------------------------------------------------------------

Thx Philipp! r=mkmelin
Attachment #8827166 - Flags: review?(mkmelin+mozilla) → review+
Attachment #8827166 - Flags: approval-comm-aurora+
https://hg.mozilla.org/comm-central/rev/48df001608dfe4f64964c38fb2a8e314f582a723
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 53.0
You need to log in before you can comment on or make changes to this bug.