Closed Bug 1318737 Opened 5 years ago Closed 4 years ago

Blank devtools console (other problems moved to bug 1323389)

Categories

(Thunderbird :: General, defect)

52 Branch
defect
Not set
normal

Tracking

(thunderbird52+ fixed, thunderbird53 fixed)

RESOLVED FIXED
Thunderbird 53.0
Tracking Status
thunderbird52 + fixed
thunderbird53 --- fixed

People

(Reporter: aleth, Assigned: Fallen)

References

Details

Attachments

(3 files)

Opening the devtools toolbox from the menu just opens a blank window. No visible error message.

Once I did get an additional dialog asking to accept an incoming connection. Afte doing so, the console works fine after. This too is very confusing.

Moreover, quitting Daily leaves a second process around (visible in the dock) which has to be quit separately.
Can you post a screenshot? The second process prevailing happens for Firefox too. Best to file a bug there.
Attached image Screen Shot β€”
Not very exciting.
After flipping the devtools.debugger.log prefs, some race condition seems to change and I see the connection dialog, as mentioned in comment 0.

DBG-FRONTEND: Initializing the chrome toolbox server.
DBG-FRONTEND: Created a separate loader instance for the DebuggerServer.
DBG-FRONTEND: initialized and added the browser actors for the DebuggerServer.
DBG-FRONTEND: Finished initializing the chrome toolbox server.
DBG-FRONTEND: Started listening on port: 6080
DBG-FRONTEND: Initializing the chrome toolbox user profile.
DBG-FRONTEND: Initializing chrome debugging process.
DBG-FRONTEND: Running chrome debugging process.
DBG-FRONTEND: Chrome toolbox is now running...
DBG-SERVER: Socket listening on: 6080
Another fun fact: If you get the connection dialog in the second screenshot, click 'cancel'. The blank window now shows an connection_refused error message. Close this instance of Thunderbird (it doesn't go away on its own, as per comment 1). Now try to open the toolbox again: it works immediately (no need to confirm a connection).
Also blank on Windows.
Version: unspecified → 52 Branch
And also, in the Error console, clicking on a source file doesn't open that source file any more. Instead you get:
TypeError: this.gViewSourceUtils is undefined hudservice.js:446:5

Do you want a new bug for that or can you fix all known bugs with the Developer Tools here?

It would have been good to check-out all the menu items before landing this ;-)
(Can I say it any nicer?)
Summary: Blank devtools console → Blank devtools console and other problems
(In reply to Jorg K (GMT+1) from comment #6)
> It would have been good to check-out all the menu items before landing this
My apologies! Surely you checked it and surely it worked since it all works in my local build. So maybe it's a packaging problem.
(In reply to Jorg K (GMT+1) from comment #6)
> It would have been good to check-out all the menu items before landing this
> ;-)
> (Can I say it any nicer?)
Totally fine, thanks for caring! So the hudservice error appears on nightly but not on local builds?

I'd prefer to split out issues into separate bugs to better keep apart what symptoms belong to which issues.

If someone has time, it would be great to reproduce any of the above issues with Firefox and the Browser Toolbox, and if it is an issue then file a devtools bug. This way we can get some help fixing those issues and concentrate on those specific to Thunderbird.
(In reply to Philipp Kewisch [:Fallen] from comment #8)
> (In reply to Jorg K (GMT+1) from comment #6)
> > It would have been good to check-out all the menu items before landing this
> > ;-)
> > (Can I say it any nicer?)
If you are curious, you can: "Maybe for future patches you could double check the menu items before uploading, this way it will help save some time for others debugging" (less dwelling on things that can't be change and offer a prospect for the future. If person admits to self, then he/she will feel guilty for past actions just the same)
Blocks: 1323389
(In reply to Philipp Kewisch [:Fallen] from comment #8)
> So the hudservice error appears on nightly but not on local builds?
Exactly.

> I'd prefer to split out issues into separate bugs to better keep apart what
> symptoms belong to which issues.
I filed bug 1323389 for not being able to open the JS source any more.

> If someone has time, it would be great to reproduce any of the above issues
> with Firefox and the Browser Toolbox, and if it is an issue then file a
> devtools bug.
I downloaded a Nighy build. <ctrl><shift>I is mapped to "Toogle Tools" and that works. Equally, clicking on a source line in the Browser Console <ctrl><shift>J works. Should I try anything else?

(In reply to Philipp Kewisch [:Fallen] from comment #9)
> If you are curious, you can: "Maybe for future patches you could double
> check the menu items before uploading, this way it will help save some time
> for others debugging".
Not quite accurate, maybe ;-)
  Maybe for future patches you could double check that the function works
  in a Daily build after completing testing in a local build and landing the patch.
This is really a rare and unexpected case which I haven't seen before. I believe it's a packaging error, and this bug here and bug 1323389 will be fixed by the same patch.
Summary: Blank devtools console and other problems → Blank devtools console (other problems moved to bug 1323389)
Argh. Any hope for this soon?  If not, is there a way for an individual to locally enable the remote debugger?
Attached patch Fix - v1 β€” β€” Splinter Review
Here we go, it is just a packaging issue.

Try run that also fixes the error console issue: https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=f93fbea3f9662624d734787032b11b33f4b27026
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #8827168 - Flags: review?(aleth)
Comment on attachment 8827168 [details] [diff] [review]
Fix - v1

Thanks, works for me. I downloaded the try build. I suggested in comment #7 that it was just a packaging problem ;-)

A little annoying on Windows that you first get an "Open File - Security Warning" for thunderbird.exe and then the "Incoming Connection" panel is sometimes hidden behind the "Developer Tools" panel which stays blank until you click OK on the other panel.
Attachment #8827168 - Flags: review+
(In reply to Jorg K (GMT+1) from comment #14)
> A little annoying on Windows that you first get an "Open File - Security
> Warning" for thunderbird.exe and then the "Incoming Connection" panel is
> sometimes hidden behind the "Developer Tools" panel which stays blank until
> you click OK on the other panel.

I totally agree! This happens for Firefox too and I get aggravated each time.
(In reply to Philipp Kewisch [:Fallen] from comment #15)
> This happens for Firefox too and I get aggravated each time.
Excuse my ignorance, I don't know which function in Firefox would behave similarly.
If you enable remote debugging and debugging tools for browser chrome and add-ons, the "Web developer" menu will have an item "Browser Toolbox" which starts a similar tool (it's a Firefox instance with a new profile and only the devtools open and remotely connection into the other Firefox profile) and has the same issue with the prompt in the background.
Right, this is quite hidden:
  Tools > Web Developer > Web Console.
    Click other tools icon, the sprocket.
      Enable browser chrome and add-on debugging toolboxes
      Enable Remote Debugging.
Then you get the "Tools > Web Developer > Browser Toolbox".
I see. Never used it.
https://hg.mozilla.org/comm-central/rev/80e1fa44bed8534cd1d57ad95fdab6a20cc44214
Sorry about stealing the review, but we need to see this in a Daily soon (and uplift it, too).
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 53.0
Attachment #8827168 - Flags: review?(aleth) → approval-comm-aurora+
You need to log in before you can comment on or make changes to this bug.