Closed Bug 1323525 Opened 3 years ago Closed 3 years ago

Clicking "Change Search Settings" in searchbar doesn't work

Categories

(Firefox :: Search, defect)

53 Branch
All
Linux
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 54
Tracking Status
firefox50 --- unaffected
firefox51 --- unaffected
firefox52 --- unaffected
firefox53 + verified
firefox54 --- verified

People

(Reporter: evilpie, Assigned: adw)

References

Details

(Keywords: regression)

Attachments

(2 files)

Clicking that button just does nothing on Nightly. Works with the same profile on release.
It works fine here on OS X and 53.0a1 (2016-12-14). Does Nightly on a clean profile work?
WFM on Windows 10 as well.
Tested on Mac OS X 10.10 with FF Nighlty 53.0a1(2016-12-18) and I can't reproduce it.
I can reproduce on Linux. 

13:28.10 INFO: Last good revision: 55a41c5e8e88010ea8a539c009f27b7b14988700
13:28.10 INFO: First bad revision: 3e92691272d3139d0f428bf7499bc65f7318f540
13:28.10 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=55a41c5e8e88010ea8a539c009f27b7b14988700&tochange=3e92691272d3139d0f428bf7499bc65f7318f540

13:28.80 INFO: Looks like the following bug has the changes which introduced the regression:
https://bugzilla.mozilla.org/show_bug.cgi?id=1113747
Confirmed with others that they can reproduce on Linux as well, so I'm guessing this one is platform-specific.
OS: Unspecified → Linux
Hardware: Unspecified → All
Blocks: 1113747
Keywords: regression
Version: unspecified → 53 Branch
Same here on Linux with nightly builds. In addition, I am unable to add search engines.
See Also: → 1326826
Tracking 53+ for this issue - ni on Drew since it appears he fixed the bug that is being referenced as causing the regression.
Flags: needinfo?(adw)
Yes, I'm looking into this.
Assignee: nobody → adw
Status: NEW → ASSIGNED
Flags: needinfo?(adw)
Duplicate of this bug: 1332229
Bug 1113747 added the class check so that clicks on the menu button wouldn't get eaten.  Before that bug, all the mousedown handler did was the preventDefault().  The problem is the settings button and add-engine button don't have that class, so the handler returns early and skips the preventDefault(), which as the code comment indicates breaks clicks on Linux.

So instead, check specifically for the add-engine menu button.
(In reply to Drew Willcoxon :adw from comment #11)
> Bug 1113747 added the class check

... and the early return.
Comment on attachment 8831774 [details]
Bug 1323525 - Clicking "Change Search Settings" in searchbar doesn't work.

https://reviewboard.mozilla.org/r/108310/#review109908
Attachment #8831774 - Flags: review?(florian) → review+
Pushed by dwillcoxon@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8c752414c834
Clicking "Change Search Settings" in searchbar doesn't work. r=florian
https://hg.mozilla.org/mozilla-central/rev/8c752414c834
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 54
Attached patch Aurora 53 patchSplinter Review
Approval Request Comment
[Feature/Bug causing the regression]: Bug 1113747
[User impact if declined]: This bug
[Is this code covered by automated tests?]: Yes
[Has the fix been verified in Nightly?]: No
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: Tiny isolated patch
[String changes made/needed]: None
Attachment #8832707 - Flags: approval-mozilla-aurora?
Hi Andrei,
could you help verify if this issue is fixed as expected on a latest Nightly build? Thanks!
Flags: needinfo?(andrei.vaida)
As of 54.0a1 (2017-02-01) it is not fixed in the French version of Nightly. I will try again later today to see if 54.0a1 (2017-02-02) fixes it.
Forwarding this to Brindusa, who's taking care of Nightly requests.
Flags: needinfo?(andrei.vaida) → needinfo?(brindusa.tot)
It work fine with Nightly
Simona, could you help verify if this issue is fixed on a latest Nightly build?
Flags: needinfo?(brindusa.tot) → needinfo?(simona.marcu)
Mozilla/5.0 (X11; Linux x86_64; rv:54.0) Gecko/20100101 Firefox/54.0

Reproduced on Nightly 54.0a1 (Build ID: 20170201030207) on Ubuntu 16.04 x64.

Verified as fixed using the latest Nightly 54.0a1 (Build ID: 20170202110108) on Ubuntu 16.04 x64.
Flags: needinfo?(simona.marcu)
I can confirm it is working as per Nightly 54.0a1 (2017-02-02)
Status: RESOLVED → VERIFIED
Comment on attachment 8832707 [details] [diff] [review]
Aurora 53 patch

Fix for regression from 53, verified in nightly, let's take it.
Attachment #8832707 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Duplicate of this bug: 1326826
Duplicate of this bug: 1328104
I can confirm this issue is fixed, I verified using Fx 53.0a2, build ID: 20170206084021, on Ubuntu 14.04 LTS x64.
You need to log in before you can comment on or make changes to this bug.