Ensure that task graphs do not contain duplicate Treeherder symbols, also consider treeherder.collection.keys()

RESOLVED FIXED in mozilla53

Status

RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: hammad13060, Assigned: hammad13060, Mentored)

Tracking

unspecified
mozilla53
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_1) AppleWebKit/602.2.14 (KHTML, like Gecko) Version/10.0.1 Safari/602.2.14
(Assignee)

Comment 1

2 years ago
(In reply to HAMMAD AKHTAR from comment #0)
> User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_1)
> AppleWebKit/602.2.14 (KHTML, like Gecko) Version/10.0.1 Safari/602.2.14
Mentor: dustin
(Assignee)

Comment 2

2 years ago
Treeherder decides what symbol to print, and where, based on
  task.extra.treeherder.collection.keys()
  task.extra.treeherder.machine.platform
  task.extra.treeherder.groupSymbol
  task.extra.treeherder.symbol

We should never generate two tasks with the same symbol.  The decision task should verify this and fail if we do.

Thanks Philor for pointing this out :)

I'll take up this bug.
Mentor: philringnalda
(Assignee)

Updated

2 years ago
Blocks: 1302802
(Assignee)

Updated

2 years ago
No longer blocks: 1302802
Depends on: 1302802
Comment hidden (mozreview-request)
Duplicate of this bug: 1302802
(Assignee)

Comment 6

2 years ago
Comment on attachment 8818804 [details]
Bug 1323633 - Ensure that task graphs do not contain duplicate Treeherder symbols, also consider treeherder.collection.keys();

Hey Dustin, patch is ready for review. It is failing on try because I am still working on an older version of the repository.
Assignee: nobody → hammad13060

Comment 7

2 years ago
mozreview-review
Comment on attachment 8818804 [details]
Bug 1323633 - Ensure that task graphs do not contain duplicate Treeherder symbols, also consider treeherder.collection.keys();

https://reviewboard.mozilla.org/r/98748/#review99976

This looks good.  However, as you mention, it needs to be rebased.  It also seems to have "adopted" `verify_docs` which doesn't belong in this commit.  Can you rebase on top of the latest and push for review again, and I'll land it?

This kind of thing happens often.  It's always tricky working on a few bugs at the same time that touch the same files.
Attachment #8818804 - Flags: review?(dustin) → review+
Comment hidden (mozreview-request)
(Assignee)

Comment 9

2 years ago
(In reply to Dustin J. Mitchell [:dustin] from comment #7)
> Comment on attachment 8818804 [details]
> Bug 1323633 - Ensure that task graphs do not contain duplicate Treeherder
> symbols, also consider treeherder.collection.keys();
> 
> https://reviewboard.mozilla.org/r/98748/#review99976
> 
> This looks good.  However, as you mention, it needs to be rebased.  It also
> seems to have "adopted" `verify_docs` which doesn't belong in this commit. 
> Can you rebase on top of the latest and push for review again, and I'll land
> it?

When I rename the verifydoc.py to verify.py so as to have a common verification module, all the tracking history for verifydoc.py is lost. It is as if content of verify.py are created in this patch only.

If above is fine then commit is ready for review :)
Ah, I see.  If you use `hg mv` then hg will track the change as a rename.  Thanks, too, for running another try job.

Comment 11

2 years ago
Pushed by dmitchell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8e51ea2602c4
Ensure that task graphs do not contain duplicate Treeherder symbols, also consider treeherder.collection.keys(); r=dustin

Comment 12

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/8e51ea2602c4
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Blocks: 1325398
Blocks: 1326462

Updated

a year ago
Product: TaskCluster → Firefox Build System
You need to log in before you can comment on or make changes to this bug.