stylo: several tests fatally assert with "sheet->IsGecko() (GatherRuleProcessor must only be called for nsXBLPrototypeResources objects with Gecko-flavored style backends)"

RESOLVED DUPLICATE of bug 1292285

Status

()

P1
normal
RESOLVED DUPLICATE of bug 1292285
2 years ago
a year ago

People

(Reporter: heycam, Unassigned)

Tracking

(Blocks: 2 bugs)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
#0  0x00007fffe6860b65 in nsXBLPrototypeResources::GatherRuleProcessor (this=0x7fffb27f5ae0) at /z/stylo/hg-incubator/dom/xbl/nsXBLPrototypeResources.cpp:151
#1  0x00007fffe68567d7 in nsXBLPrototypeResources::FlushSkinSheets (this=0x7fffb27f5ae0) at /z/stylo/hg-incubator/dom/xbl/nsXBLPrototypeResources.cpp:110
#2  0x00007fffe684acc5 in nsXBLPrototypeBinding::FlushSkinSheets (this=0x7fffb63fd3d0) at /z/stylo/hg-incubator/dom/xbl/nsXBLPrototypeBinding.cpp:257
#3  0x00007fffe47eab03 in mozilla::dom::ShadowRoot::StyleSheetChanged (this=0x7fffb0977570) at /z/stylo/hg-incubator/dom/base/ShadowRoot.cpp:124
#4  0x00007fffe6d64e42 in mozilla::StyleSheet::SetComplete (this=0x7fffb5836120) at /z/stylo/hg-incubator/layout/style/StyleSheet.cpp:93
#5  0x00007fffe6d19560 in mozilla::css::Loader::DoSheetComplete (this=0x7fffb3620460, aLoadData=0x7fffb13a8bc0, aStatus=nsresult::NS_OK, aDatasToNotify=...) at /z/stylo/hg-incubator/layout/style/Loader.cpp:1901
#6  0x00007fffe6d1668c in mozilla::css::Loader::SheetComplete (this=0x7fffb3620460, aLoadData=0x7fffb13a8bc0, aStatus=nsresult::NS_OK) at /z/stylo/hg-incubator/layout/style/Loader.cpp:1826
#7  0x00007fffe6d16ee6 in mozilla::css::Loader::ParseSheet (this=0x7fffb3620460, aInput=..., aLoadData=0x7fffb13a8bc0, aCompleted=@0x7fffffff2337: true) at /z/stylo/hg-incubator/layout/style/Loader.cpp:1797
#8  0x00007fffe6d1a24b in mozilla::css::Loader::LoadInlineStyle (this=0x7fffb3620460, aElement=0x7fffb13a8b00, aBuffer=..., aLineNumber=1, aTitle=..., aMedia=..., aScopeElement=0x0, aObserver=0x0, aCompleted=0x7fffffff2337, 
    aIsAlternate=0x7fffffff2346) at /z/stylo/hg-incubator/layout/style/Loader.cpp:2045
#9  0x00007fffe499f9e2 in nsStyleLinkElement::DoUpdateStyleSheet (this=0x7fffb13a8b98, aOldDocument=0x0, aOldShadowRoot=0x0, aObserver=0x0, aWillNotify=0x7fffffff2616, aIsAlternate=0x7fffffff2615, aForceUpdate=false)
    at /z/stylo/hg-incubator/dom/base/nsStyleLinkElement.cpp:427
#10 0x00007fffe499ff33 in nsStyleLinkElement::UpdateStyleSheetInternal (this=0x7fffb13a8b98, aOldDocument=0x0, aOldShadowRoot=0x0, aForceUpdate=false) at /z/stylo/hg-incubator/dom/base/nsStyleLinkElement.cpp:232
#11 0x00007fffe5d3da23 in nsStyleLinkElement::UpdateStyleSheetInternal (this=0x7fffb13a8b98) at /z/stylo/hg-incubator/dom/base/nsStyleLinkElement.h:79
#12 0x00007fffe5da06da in mozilla::detail::RunnableMethodArguments<>::applyImpl<mozilla::dom::HTMLStyleElement, void (mozilla::dom::HTMLStyleElement::*)()>(mozilla::dom::HTMLStyleElement*, void (mozilla::dom::HTMLStyleElement::*)(), mozilla::Tuple<>&, mozilla::IndexSequence<>) (o=0x7fffb13a8b00, 
    m=(void (mozilla::dom::HTMLStyleElement::*)(mozilla::dom::HTMLStyleElement * const)) 0x7fffe5d3da00 <nsStyleLinkElement::UpdateStyleSheetInternal()>, this adjustment 152, args=...)
    at /z/stylo/hg-incubator/obj/dist/include/nsThreadUtils.h:791
#13 0x00007fffe5da0639 in mozilla::detail::RunnableMethodArguments<>::apply<mozilla::dom::HTMLStyleElement, void (mozilla::dom::HTMLStyleElement::*)()>(mozilla::dom::HTMLStyleElement*, void (mozilla::dom::HTMLStyleElement::*)())
    (this=0x7fffb1378780, o=0x7fffb13a8b00, m=(void (mozilla::dom::HTMLStyleElement::*)(mozilla::dom::HTMLStyleElement * const)) 0x7fffe5d3da00 <nsStyleLinkElement::UpdateStyleSheetInternal()>, this adjustment 152)
    at /z/stylo/hg-incubator/obj/dist/include/nsThreadUtils.h:797
#14 0x00007fffe5da0482 in mozilla::detail::RunnableMethodImpl<void (mozilla::dom::HTMLStyleElement::*)(), true, false>::Run (this=0x7fffb1378740) at /z/stylo/hg-incubator/obj/dist/include/nsThreadUtils.h:826
#15 0x00007fffe4649ab0 in nsContentUtils::RemoveScriptBlocker () at /z/stylo/hg-incubator/dom/base/nsContentUtils.cpp:5221
#16 0x00007fffe4660b17 in mozAutoDocUpdate::~mozAutoDocUpdate (this=0x7fffffff2950) at /z/stylo/hg-incubator/dom/base/mozAutoDocUpdate.h:43
#17 0x00007fffe493da4a in nsINode::ReplaceOrInsertBefore (this=0x7fffb0977570, aReplace=false, aNewChild=0x7fffb575ff70, aRefChild=0x0, aError=...) at /z/stylo/hg-incubator/dom/base/nsINode.cpp:2501
#18 0x00007fffe478d231 in nsINode::InsertBefore (this=0x7fffb0977570, aNode=..., aChild=0x0, aError=...) at /z/stylo/hg-incubator/dom/base/nsINode.h:1801
#19 0x00007fffe478d274 in nsINode::AppendChild (this=0x7fffb0977570, aNode=..., aError=...) at /z/stylo/hg-incubator/dom/base/nsINode.h:1805
#20 0x00007fffe4cfd68f in mozilla::dom::NodeBinding::appendChild (cx=0x7fffdbbb7000, obj=..., self=0x7fffb0977570, args=...) at /z/stylo/hg-incubator/obj/dom/bindings/NodeBinding.cpp:696
#21 0x00007fffe58aa6f2 in mozilla::dom::GenericBindingMethod (cx=0x7fffdbbb7000, argc=1, vp=0x7fffd353e1c8) at /z/stylo/hg-incubator/dom/bindings/BindingUtils.cpp:2886
#22 0x00007fffe96a761d in js::CallJSNative (cx=0x7fffdbbb7000, native=0x7fffe58aa490 <mozilla::dom::GenericBindingMethod(JSContext*, unsigned int, JS::Value*)>, args=...) at /z/stylo/hg-incubator/js/src/jscntxtinlines.h:239
#23 0x00007fffe968b470 in js::InternalCallOrConstruct (cx=0x7fffdbbb7000, args=..., construct=js::NO_CONSTRUCT) at /z/stylo/hg-incubator/js/src/vm/Interpreter.cpp:457
#24 0x00007fffe968b86f in InternalCall (cx=0x7fffdbbb7000, args=...) at /z/stylo/hg-incubator/js/src/vm/Interpreter.cpp:502
#25 0x00007fffe968b66d in js::CallFromStack (cx=0x7fffdbbb7000, args=...) at /z/stylo/hg-incubator/js/src/vm/Interpreter.cpp:508
#26 0x00007fffe967fe76 in Interpret (cx=0x7fffdbbb7000, state=...) at /z/stylo/hg-incubator/js/src/vm/Interpreter.cpp:2919
#27 0x00007fffe96752d0 in js::RunScript (cx=0x7fffdbbb7000, state=...) at /z/stylo/hg-incubator/js/src/vm/Interpreter.cpp:403
#28 0x00007fffe968b568 in js::InternalCallOrConstruct (cx=0x7fffdbbb7000, args=..., construct=js::NO_CONSTRUCT) at /z/stylo/hg-incubator/js/src/vm/Interpreter.cpp:475
#29 0x00007fffe968b86f in InternalCall (cx=0x7fffdbbb7000, args=...) at /z/stylo/hg-incubator/js/src/vm/Interpreter.cpp:502
#30 0x00007fffe968b8e6 in js::Call (cx=0x7fffdbbb7000, fval=..., thisv=..., args=..., rval=...) at /z/stylo/hg-incubator/js/src/vm/Interpreter.cpp:521
#31 0x00007fffe937d1b0 in JS::Call (cx=0x7fffdbbb7000, thisv=..., fval=..., args=..., rval=...) at /z/stylo/hg-incubator/js/src/jsapi.cpp:2830
#32 0x00007fffe52cc21e in mozilla::dom::LifecycleCreatedCallback::Call (this=0x7fffb5a396c0, cx=0x7fffdbbb7000, aThisVal=..., aRv=...) at /z/stylo/hg-incubator/obj/dom/bindings/WebComponentsBinding.cpp:451
#33 0x00007fffe4747877 in mozilla::dom::LifecycleCreatedCallback::Call<RefPtr<mozilla::dom::Element> > (this=0x7fffb5a396c0, thisVal=..., aRv=..., aExecutionReason=0x7fffeabbe7a1 "LifecycleCreatedCallback", 
    aExceptionHandling=mozilla::dom::CallbackObject::eReportExceptions, aCompartment=0x0) at /z/stylo/hg-incubator/obj/dist/include/mozilla/dom/WebComponentsBinding.h:162
#34 0x00007fffe4736f19 in mozilla::dom::CustomElementCallback::Call (this=0x7fffb135f2e0) at /z/stylo/hg-incubator/dom/base/CustomElementRegistry.cpp:42
#35 0x00007fffe473723a in mozilla::dom::CustomElementData::RunCallbackQueue (this=0x7fffb5a39740) at /z/stylo/hg-incubator/dom/base/CustomElementRegistry.cpp:94
#36 0x00007fffe4737f2f in mozilla::dom::CustomElementRegistry::ProcessTopElementQueue () at /z/stylo/hg-incubator/dom/base/CustomElementRegistry.cpp:209
#37 0x00007fffe4755d93 in mozilla::detail::RunnableFunction<void (*)()>::Run (this=0x7fffb0fa6400) at /z/stylo/hg-incubator/obj/dist/include/nsThreadUtils.h:330
#38 0x00007fffe4649e1e in nsContentUtils::AddScriptRunner (aRunnable=...) at /z/stylo/hg-incubator/dom/base/nsContentUtils.cpp:5292
#39 0x00007fffe4648eb2 in nsContentUtils::AddScriptRunner (aRunnable=0x7fffb0fa6400) at /z/stylo/hg-incubator/dom/base/nsContentUtils.cpp:5299
#40 0x00007fffe4738b9f in mozilla::dom::CustomElementRegistry::EnqueueLifecycleCallback (this=0x7fffb3621d90, aType=nsIDocument::eCreated, aCustomElement=0x7fffb575e230, aArgs=0x0, aDefinition=0x7fffb0fa6040)
    at /z/stylo/hg-incubator/dom/base/CustomElementRegistry.cpp:447
#41 0x00007fffe473857e in mozilla::dom::CustomElementRegistry::SetupCustomElement (this=0x7fffb3621d90, aElement=0x7fffb575e230, aTypeExtension=0x0) at /z/stylo/hg-incubator/dom/base/CustomElementRegistry.cpp:325
#42 0x00007fffe46590c8 in nsContentUtils::SetupCustomElement (aElement=0x7fffb575e230, aTypeExtension=0x0) at /z/stylo/hg-incubator/dom/base/nsContentUtils.cpp:9602
#43 0x00007fffe5dd39e2 in NS_NewHTMLElement(mozilla::dom::Element**, already_AddRefed<mozilla::dom::NodeInfo>&&, mozilla::dom::FromParser, nsAString_internal const*) (aResult=0x7fffffff6fa0, 
    aNodeInfo=<unknown type in /z/stylo/hg-incubator/obj/dist/bin/libxul.so, CU 0x721bcdd, DIE 0x729dcef>, aFromParser=mozilla::dom::NOT_FROM_PARSER, aIs=0x0) at /z/stylo/hg-incubator/dom/html/nsHTMLContentSink.cpp:265
#44 0x00007fffe4958377 in NS_NewElement(mozilla::dom::Element**, already_AddRefed<mozilla::dom::NodeInfo>&&, mozilla::dom::FromParser, nsAString_internal const*) (aResult=0x7fffffff6fa0, 
    aNodeInfo=<unknown type in /z/stylo/hg-incubator/obj/dist/bin/libxul.so, CU 0x4d73be0, DIE 0x4e33bc5>, aFromParser=mozilla::dom::NOT_FROM_PARSER, aIs=0x0) at /z/stylo/hg-incubator/dom/base/nsNameSpaceManager.cpp:177
#45 0x00007fffe48a8178 in nsDocument::CreateElem (this=0x7fffb5fcd000, aName=..., aPrefix=0x0, aNamespaceID=3, aIs=0x0) at /z/stylo/hg-incubator/dom/base/nsDocument.cpp:8168
#46 0x00007fffe489e764 in nsDocument::CustomElementConstructor (aCx=0x7fffdbbb7000, aArgc=0, aVp=0x7fffd353e120) at /z/stylo/hg-incubator/dom/base/nsDocument.cpp:5709
#47 0x00007fffe96a761d in js::CallJSNative (cx=0x7fffdbbb7000, native=0x7fffe489e4a0 <nsDocument::CustomElementConstructor(JSContext*, unsigned int, JS::Value*)>, args=...) at /z/stylo/hg-incubator/js/src/jscntxtinlines.h:239
#48 0x00007fffe96b7803 in js::CallJSNativeConstructor (cx=0x7fffdbbb7000, native=0x7fffe489e4a0 <nsDocument::CustomElementConstructor(JSContext*, unsigned int, JS::Value*)>, args=...)
    at /z/stylo/hg-incubator/js/src/jscntxtinlines.h:272
#49 0x00007fffe968be34 in InternalConstruct (cx=0x7fffdbbb7000, args=...) at /z/stylo/hg-incubator/js/src/vm/Interpreter.cpp:548
#50 0x00007fffe968b9ae in js::ConstructFromStack (cx=0x7fffdbbb7000, args=...) at /z/stylo/hg-incubator/js/src/vm/Interpreter.cpp:586
#51 0x00007fffe967fd12 in Interpret (cx=0x7fffdbbb7000, state=...) at /z/stylo/hg-incubator/js/src/vm/Interpreter.cpp:2911
#52 0x00007fffe96752d0 in js::RunScript (cx=0x7fffdbbb7000, state=...) at /z/stylo/hg-incubator/js/src/vm/Interpreter.cpp:403
#53 0x00007fffe968c7a2 in js::ExecuteKernel (cx=0x7fffdbbb7000, script=..., envChainArg=..., newTargetValue=..., evalInFrame=..., result=0x0) at /z/stylo/hg-incubator/js/src/vm/Interpreter.cpp:684
#54 0x00007fffe968caf7 in js::Execute (cx=0x7fffdbbb7000, script=..., envChainArg=..., rval=0x0) at /z/stylo/hg-incubator/js/src/vm/Interpreter.cpp:716
#55 0x00007fffe93859ec in Evaluate (cx=0x7fffdbbb7000, scopeKind=js::ScopeKind::Global, env=..., optionsArg=..., srcBuf=..., rval=...) at /z/stylo/hg-incubator/js/src/jsapi.cpp:4480
#56 0x00007fffe9385ced in Evaluate (cx=0x7fffdbbb7000, envChain=..., optionsArg=..., srcBuf=..., rval=...) at /z/stylo/hg-incubator/js/src/jsapi.cpp:4507
#57 0x00007fffe9385bcd in JS::Evaluate (cx=0x7fffdbbb7000, envChain=..., optionsArg=..., srcBuf=..., rval=...) at /z/stylo/hg-incubator/js/src/jsapi.cpp:4565
#58 0x00007fffe49517ee in nsJSUtils::EvaluateString (aCx=0x7fffdbbb7000, aSrcBuf=..., aEvaluationGlobal=..., aCompileOptions=..., aEvaluateOptions=..., aRetValue=..., aOffThreadToken=0x0)
    at /z/stylo/hg-incubator/dom/base/nsJSUtils.cpp:207
#59 0x00007fffe4951c5d in nsJSUtils::EvaluateString (aCx=0x7fffdbbb7000, aSrcBuf=..., aEvaluationGlobal=..., aCompileOptions=..., aOffThreadToken=0x0) at /z/stylo/hg-incubator/dom/base/nsJSUtils.cpp:274
#60 0x00007fffe4997a6b in nsScriptLoader::EvaluateScript (this=0x7fffb0be5f40, aRequest=0x7fffb5cbdc70) at /z/stylo/hg-incubator/dom/base/nsScriptLoader.cpp:2212
#61 0x00007fffe49960bf in nsScriptLoader::ProcessRequest (this=0x7fffb0be5f40, aRequest=0x7fffb5cbdc70) at /z/stylo/hg-incubator/dom/base/nsScriptLoader.cpp:1994
#62 0x00007fffe498d907 in nsScriptLoader::ProcessScriptElement (this=0x7fffb0be5f40, aElement=0x7fffb3620358) at /z/stylo/hg-incubator/dom/base/nsScriptLoader.cpp:1715
#63 0x00007fffe498c22d in nsScriptElement::MaybeProcessScript (this=0x7fffb3620358) at /z/stylo/hg-incubator/dom/base/nsScriptElement.cpp:149
#64 0x00007fffe402c77e in nsIScriptElement::AttemptToExecute (this=0x7fffb3620358) at /z/stylo/hg-incubator/dom/base/nsIScriptElement.h:222
#65 0x00007fffe40160db in nsHtml5TreeOpExecutor::RunScript (this=0x7fffb32afc00, aScriptElement=0x7fffb36202c0) at /z/stylo/hg-incubator/parser/html/nsHtml5TreeOpExecutor.cpp:668
#66 0x00007fffe40159a5 in nsHtml5TreeOpExecutor::RunFlushLoop (this=0x7fffb32afc00) at /z/stylo/hg-incubator/parser/html/nsHtml5TreeOpExecutor.cpp:491
#67 0x00007fffe402d2f1 in nsHtml5ExecutorFlusher::Run (this=0x7fffb5507ca0) at /z/stylo/hg-incubator/parser/html/nsHtml5StreamParser.cpp:128
#68 0x00007fffe2ad0ca8 in nsThread::ProcessNextEvent (this=0x7fffdfe3d300, aMayWait=false, aResult=0x7fffffffbd4e) at /z/stylo/hg-incubator/xpcom/threads/nsThread.cpp:1213
#69 0x00007fffe2b505fc in NS_ProcessNextEvent (aThread=0x7fffdfe3d300, aMayWait=false) at /z/stylo/hg-incubator/xpcom/glue/nsThreadUtils.cpp:381
#70 0x00007fffe33cb0e9 in mozilla::ipc::MessagePump::Run (this=0x7fffdfe98a80, aDelegate=0x7ffff6bb2410) at /z/stylo/hg-incubator/ipc/glue/MessagePump.cpp:96
#71 0x00007fffe33296c5 in MessageLoop::RunInternal (this=0x7ffff6bb2410) at /z/stylo/hg-incubator/ipc/chromium/src/base/message_loop.cc:232
#72 0x00007fffe3329645 in MessageLoop::RunHandler (this=0x7ffff6bb2410) at /z/stylo/hg-incubator/ipc/chromium/src/base/message_loop.cc:225
#73 0x00007fffe332961d in MessageLoop::Run (this=0x7ffff6bb2410) at /z/stylo/hg-incubator/ipc/chromium/src/base/message_loop.cc:205
#74 0x00007fffe6ad4003 in nsBaseAppShell::Run (this=0x7fffd35e7970) at /z/stylo/hg-incubator/widget/nsBaseAppShell.cpp:156
#75 0x00007fffe7cab192 in nsAppStartup::Run (this=0x7fffd35ef880) at /z/stylo/hg-incubator/toolkit/components/startup/nsAppStartup.cpp:283
#76 0x00007fffe7da48ac in XREMain::XRE_mainRun (this=0x7fffffffc728) at /z/stylo/hg-incubator/toolkit/xre/nsAppRunner.cpp:4485
#77 0x00007fffe7da5396 in XREMain::XRE_main (this=0x7fffffffc728, argc=4, argv=0x7fffffffdc08, aAppData=0x7fffffffc9e8) at /z/stylo/hg-incubator/toolkit/xre/nsAppRunner.cpp:4618
#78 0x00007fffe7da5b6f in XRE_main (argc=4, argv=0x7fffffffdc08, aAppData=0x7fffffffc9e8, aFlags=0) at /z/stylo/hg-incubator/toolkit/xre/nsAppRunner.cpp:4709
#79 0x000000000040633f in do_main (argc=4, argv=0x7fffffffdc08, envp=0x7fffffffdc30, xreDirectory=0x7ffff6b5eb40) at /z/stylo/hg-incubator/browser/app/nsBrowserApp.cpp:328
#80 0x0000000000405a62 in main (argc=4, argv=0x7fffffffdc08, envp=0x7fffffffdc30) at /z/stylo/hg-incubator/browser/app/nsBrowserApp.cpp:461
(Reporter)

Comment 1

2 years ago
layout/base/crashtests/1261351.html
layout/style/crashtests/1017798-1.html
Summary: stylo: layout/base/crashtests/1261351.html fatally asserts with "sheet->IsGecko() (GatherRuleProcessor must only be called for nsXBLPrototypeResources objects with Gecko-flavored style backends)" → stylo: several tests fatally assert with "sheet->IsGecko() (GatherRuleProcessor must only be called for nsXBLPrototypeResources objects with Gecko-flavored style backends)"
Priority: -- → P3
Marking as P1 because they are the remaining crashes in crashtests.
Priority: P3 → P1
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1292285
You need to log in before you can comment on or make changes to this bug.