Build failure on 2016-12-16: ERROR: Cannot find rustc - need to back out temporary fix

RESOLVED FIXED in Thunderbird 53.0

Status

defect
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: jorgk, Assigned: aleth)

Tracking

53 Branch
Thunderbird 53.0
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Linux and Mac: ERROR: Cannot find rustc.
Windows seems OK.

This is related to bug 1283898.
Easy fix:

add --disable-rust to the mozconfig.

Harder fix (but better):

Add rust to the tooltool manifests and make sure the mozconfigs TB uses invokes it:

e.g. https://dxr.mozilla.org/mozilla-central/source/browser/config/mozconfigs/linux32/debug#22

The latter piece may need us to add it to comm-centrals directories as well though

https://dxr.mozilla.org/mozilla-central/source/build/mozconfig.rust?q=path%3Amozconfig.rust&redirect_type=single
(In reply to Justin Wood (:Callek) from comment #1)
> Easy fix:
> add --disable-rust to the mozconfig.

Can we do this for now? Which "mozconfig" are we talking about on C-C?
mail/config/mozconfigs/win64/nightly
and its brothers in linux32, linux64, macosx64 and win32? What about macosx-universal?
Flags: needinfo?(aleth)
Windows is also affected.
Summary: Build failure on 2016-12-16 on Linux and Mac: ERROR: Cannot find rustc → Build failure on 2016-12-16: ERROR: Cannot find rustc
(In reply to Jorg K (GMT+1) from comment #2)
> (In reply to Justin Wood (:Callek) from comment #1)
> > Easy fix:
> > add --disable-rust to the mozconfig.
> 
> Can we do this for now? Which "mozconfig" are we talking about on C-C?
> mail/config/mozconfigs/win64/nightly
> and its brothers in linux32, linux64, macosx64 and win32? What about
> macosx-universal?

Probably the ones in https://dxr.mozilla.org/comm-central/search?q=path%3Amozconfig+path%3Amail&redirect=false

But I should note, there is no tier1 guarantee that disable-rust will always work (though at least for short term, its intended to), so the slightly harder option I cited is probably better.
(In reply to Jorg K (GMT+1) from comment #5)
> Aleth asked for a try, so here it is:
> https://treeherder.mozilla.org/#/jobs?repo=try-comm-
> central&revision=4f095af78609c908786bb167c150781e3eaabc60

Looks like adding --disable-rust failed to stop configure from trying to find rustc. Are we sure disable-rust works for Firefox builds and this is not a regression?
Flags: needinfo?(bugspam.Callek)
Depends on: 1324120
This should be fixed by bug 1324120.
https://hg.mozilla.org/comm-central/rev/5a163ed948ceb5e930d754a6491599d12471d94a
Bug 1324027 - Add build/mozconfig.rust to the synced dir in c-c. rs=bustage-fix DONTBUILD CLOSED TREE
https://hg.mozilla.org/comm-central/rev/615bdf95952f15f6fa7020ba8b48e9863f5eabe5
Bug 1324027 - Temporarily disable rust to keep automation builds from failing. rs=bustage-fix CLOSED TREE
This temporary fix should work, at least for some platforms, until the m-c patch lands.
Assignee: nobody → aleth
Status: NEW → ASSIGNED
Attachment #8819343 - Attachment is obsolete: true
https://hg.mozilla.org/comm-central/rev/d322c6607dcd25486c9578c55e1eec09c9883b2f
Bug 1324027 - Temporarily disable rust - Instantbird part. rs=bustage-fix
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 53.0
Version: 52 Branch → 53 Branch
Why was this closed? Aren't we going to remove the "disable rust" when bug 1324120 lands? Or is there a new bug for that? What am I missing?
Flags: needinfo?(aleth)
(In reply to Jorg K (GMT+1) from comment #13)
> Why was this closed? Aren't we going to remove the "disable rust" when bug
> 1324120 lands? Or is there a new bug for that? What am I missing?

The build failure is fixed and a long-term solution exists, so this bug is resolved as no further work needs to be done here. When m-c has the changes needed the disabling patch can be backed out again. If you prefer you can reopen this bug until that happens.
Flags: needinfo?(aleth)
Well, I get told that we always need an open bug in order not to forget things ;-)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Summary: Build failure on 2016-12-16: ERROR: Cannot find rustc → Build failure on 2016-12-16: ERROR: Cannot find rustc - need to back out temporary fix
(In reply to Jorg K (GMT+1) from comment #15)
> Well, I get told that we always need an open bug in order not to forget
> things ;-)

Indeed. The open bug is bug 1324120 ;)
They say I'm pedantic, but the other bug doesn't mention any backout ;-)
Flags: needinfo?(bugspam.Callek)
Comment on attachment 8819532 [details] [diff] [review]
Temporarily disable rust to keep automation builds from failing. rs=bustage-fix CLOSED TREE

Review of attachment 8819532 [details] [diff] [review]:
-----------------------------------------------------------------

::: mail/config/mozconfigs/macosx-universal/l10n-mozconfig
@@ +5,5 @@
>  ac_add_options --disable-compile-environment
>  
> +ac_add_options --disable-rust
> +unset RUSTC
> +unset CARGO

We're combining --disable-compile-environment with --disable-rust, which is not a supported option, see bug 1324777 comment 1.

While I don't necessarily agree with that, can we remove the --disable-rust here and in other mac l10n nightly confs?
(In reply to Axel Hecht [:Pike] from comment #18)
> We're combining --disable-compile-environment with --disable-rust, which is
> not a supported option, see bug 1324777 comment 1.
> 
> While I don't necessarily agree with that, can we remove the --disable-rust
> here and in other mac l10n nightly confs?

Yes, since from the discussion in that bug it seems disable-compile-environment supersedes it anyway.

Note disabling rust is a temporary measure.
Blocks: 1324777
https://hg.mozilla.org/comm-central/rev/84c6ff29b0d4f29c8f017ce27ceb80c674913678
Bug 1324777 - --disable-rust not needed when specifying --disable-compile-environment. rs=bustage-fix
Depends on: 1324607
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.