Closed Bug 1324170 Opened 3 years ago Closed 3 years ago

Learn More links should always appear after the text in the same line, not right-aligned in their own column

Categories

(Firefox :: Preferences, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 53
Tracking Status
firefox53 --- fixed

People

(Reporter: jaws, Assigned: beachjar)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Assignee: nobody → beachjar
Status: NEW → ASSIGNED
Comment on attachment 8821203 [details]
Bug 1324170 - Change "Learn More" links to always align after text in about:preferences

https://reviewboard.mozilla.org/r/100534/#review101092

Thanks, this is close but the Advanced > Data Choices still has the Learn More on the right column.

::: browser/themes/shared/incontentprefs/preferences.inc.css:176
(Diff revision 1)
>  /* Content pane */
>  #playDRMContentLink {
> -  /* Line up with the buttons in the other grid bits: */
> -  margin-left: 4px !important;
> +  /* Line up after text */
> +  margin-inline-start: 1.5em !important;
> -  margin-right: 4px !important;
>  }
>  
>  #notificationsPolicyLearnMore {
>    margin-inline-start: 1.5em !important;
>  }

Please merge these and the rules for: #trackingProtectionPBMLearnMore,
#trackingProtectionLearnMore,
#browserContainersLearnMore

since these rules are the same.
Attachment #8821203 - Flags: review?(jaws) → review-
Hey Jared, have you been able to make any progress on this?
Flags: needinfo?(beachjar)
Comment on attachment 8821203 [details]
Bug 1324170 - Change "Learn More" links to always align after text in about:preferences

https://reviewboard.mozilla.org/r/100534/#review103982

::: browser/components/preferences/in-content/advanced.xul:205
(Diff revision 2)
>        </groupbox>
>      </tabpanel>
>  #ifdef MOZ_DATA_REPORTING
>      <!-- Data Choices -->
>      <tabpanel id="dataChoicesPanel" orient="vertical">
> -#ifdef MOZ_TELEMETRY_REPORTING
> +<!--#ifdef MOZ_TELEMETRY_REPORTING-->

This change should be reverted.

::: browser/components/preferences/in-content/advanced.xul:233
(Diff revision 2)
>                </hbox>
>              </groupbox>
>            </hbox>
>          </vbox>
>        </groupbox>
> -#endif
> +<!--#endif-->

Ditto.

::: browser/components/preferences/in-content/content.xul:74
(Diff revision 2)
>      <rows>
>        <row id="notificationsPolicyRow" align="center">
>          <hbox align="start">
>            <label id="notificationsPolicy">&notificationsPolicyDesc3.label;</label>
>            <label id="notificationsPolicyLearnMore"
> -                 class="text-link"
> +                 class="learnMore text-link"

Can you please add this 'learnMore' class to the other learn more links, and then update the CSS in preferences.inc.css to refer to .learnMore instead of their IDs?
Attachment #8821203 - Flags: review?(jaws) → review-
Comment on attachment 8821203 [details]
Bug 1324170 - Change "Learn More" links to always align after text in about:preferences

https://reviewboard.mozilla.org/r/100534/#review104004

::: browser/themes/shared/incontentprefs/preferences.inc.css:48
(Diff revision 3)
>    min-width: 26px;
>  }
>  
> +/* For the "learn more" links, line up after text */
> +.learnMore {
> +  margin-inline-start: 1.5em !important;

With the change to common.css we won't need the !important anymore.

::: browser/themes/shared/incontentprefs/preferences.inc.css:49
(Diff revision 3)
>  }
>  
> +/* For the "learn more" links, line up after text */
> +.learnMore {
> +  margin-inline-start: 1.5em !important;
> +  margin-top: 0;

This margin-top change looks like it's pulling the text vertically up and we shouldn't be doing that. This line can be removed.
Attachment #8821203 - Flags: review?(jaws) → review-
Comment on attachment 8821203 [details]
Bug 1324170 - Change "Learn More" links to always align after text in about:preferences

https://reviewboard.mozilla.org/r/100534/#review104148
Attachment #8821203 - Flags: review?(jaws) → review+
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/95fabc8be849
Change "Learn More" links to always align after text in about:preferences r=jaws
https://hg.mozilla.org/mozilla-central/rev/95fabc8be849
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 53
I have reproduced this bug with Nightly 53.0a1 (2016-12-16) (64-bit) on Windows 8 , 64 Bit !

This bug's fix is verified with latest Nightly

Build   ID     20170111030235
User Agent     Mozilla/5.0 (Windows NT 6.3; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0
[bugday-20170111]
Status: RESOLVED → VERIFIED
QA Whiteboard: [bugday-2017-01-11]
Depends on: 1330977
You need to log in before you can comment on or make changes to this bug.