Closed Bug 1324262 Opened 3 years ago Closed 3 years ago

-moz-field is transparent on Ubuntu 16.10

Categories

(Core :: Widget: Gtk, defect, major)

Unspecified
Linux
defect
Not set
major

Tracking

()

RESOLVED FIXED
mozilla53
Tracking Status
firefox52 --- unaffected
firefox53 --- fixed

People

(Reporter: dao, Unassigned)

References

Details

(Keywords: regression)

Attachments

(3 files)

[Tracking Requested - why for this release]:
All arrow panels are affected as well, and a closer look reveals that the location bar and search bar themselves (not just their autocomplete popups) don't have a white background anymore either. Basically, it looks like -moz-field is now transparent.
Summary: Autocomplete popups are transparent → -moz-field is transparent on Ubuntu 16.10
Fixed by backout:

https://hg.mozilla.org/integration/mozilla-inbound/rev/12f4a1387fbc20a4696cd0cc9ea1ae7cddeb213c
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Thank you for the patch :)
Prior to GTK 3.20, or more specifically
https://git.gnome.org/browse/gtk+/commit/?id=580ea227a6bb19ad6c6d4766b3a36dbad24583f3
the background of each window, even non-native windows, would be cleared
before each paint with operator source.
https://git.gnome.org/browse/gtk+/tree/gtk/gtkwidget.c?id=402cecf9a2aecf95ac8efca84179adcb1ce8e956#n7102
Windows are created with a transparent background pattern by default
https://git.gnome.org/browse/gtk+/tree/gdk/gdkwindow.c?id=402cecf9a2aecf95ac8efca84179adcb1ce8e956#n1401

That meant that windows would occlude any content behind them, and themes
needed to set backgrounds for the windows so that they were not black.

Since the change, the background is no longer cleared and so content behind
the windows is visible.

Ambiance for 3.20 does not set a background on the text node of the textview,
but only on the root node of the textview.  Gecko can no longer depend on the
text node having a background, but needs to also consider the root node
background.

Prior to changes that landed for bug 1320860 and bug 1322120, and now, with
those reverted, Gecko happens to pick up Ambiance's style rule for the textview
root node because the style context used has not yet been adjusted to conform to
GTK 3.20's text node.
You need to log in before you can comment on or make changes to this bug.