Closed Bug 1326414 Opened 8 years ago Closed 8 years ago

Metric FX_PREFERENCES_CATEGORY_OPENED returns 504 Error From Aggregates Service

Categories

(Cloud Services Graveyard :: Metrics: Pipeline, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jaws, Unassigned)

References

Details

Loading this URL:
https://telemetry.mozilla.org/new-pipeline/dist.html#!cumulative=0&end_date=2016-12-28&keys=__none__!__none__!__none__&max_channel_version=nightly%252F53&measure=FX_PREFERENCES_CATEGORY_OPENED&min_channel_version=null&product=Firefox&sanitize=1&sort_keys=submissions&start_date=2016-11-14&table=0&trim=1&use_submission_date=0

Shows these errors in the Web Console:
Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://aggregates.telemetry.mozilla.org/aggregates_by/build_id/channels/nightly/?version=53&dates=20161229%2C20161228%2C20161227%2C20161226%2C20161225%2C20161224%2C20161223%2C20161222%2C20161221%2C20161220%2C20161219%2C20161218%2C20161217%2C20161216%2C20161215%2C20161214%2C20161213%2C20161212%2C20161211%2C20161210%2C20161209%2C20161208%2C20161207%2C20161206%2C20161205%2C20161204%2C20161203%2C20161202%2C20161201%2C20161130%2C20161129%2C20161128%2C20161127%2C20161126%2C20161125%2C20161124%2C20161123%2C20161122%2C20161121%2C20161120%2C20161119%2C20161118%2C20161117%2C20161116%2C20161115%2C20161114&metric=FX_PREFERENCES_CATEGORY_OPENED&application=Firefox. (Reason: CORS header ‘Access-Control-Allow-Origin’ missing).uncaught exception: Could not obtain evolution: status 0 (https://aggregates.telemetry.mozilla.org/aggregates_by/build_id/channels/nightly/?version=53&dates=20161229%2C20161228%2C20161227%2C20161226%2C20161225%2C20161224%2C20161223%2C20161222%2C20161221%2C20161220%2C20161219%2C20161218%2C20161217%2C20161216%2C20161215%2C20161214%2C20161213%2C20161212%2C20161211%2C20161210%2C20161209%2C20161208%2C20161207%2C20161206%2C20161205%2C20161204%2C20161203%2C20161202%2C20161201%2C20161130%2C20161129%2C20161128%2C20161127%2C20161126%2C20161125%2C20161124%2C20161123%2C20161122%2C20161121%2C20161120%2C20161119%2C20161118%2C20161117%2C20161116%2C20161115%2C20161114&metric=FX_PREFERENCES_CATEGORY_OPENED&application=Firefox)
Blocks: 1255755
Component: Telemetry Dashboard → Metrics: Pipeline
Product: Webtools → Cloud Services
Summary: Viewing FX_PREFERENCES_CATEGORY_OPENED on the Telemetry Histograms page causes CORS issue → Metric FX_PREFERENCES_CATEGORY_OPENED returns 504 Error From Aggregates Service
Version: Trunk → unspecified
This probe was introduced in version 53. Could this issue be happening because the probe is new? Did something change with t.m.o recently?
Flags: needinfo?(chutten)
Flags: needinfo?(alessio.placitelli)
I've tried reproducing this locally, but the issue doesn't arise. Error logs on the server aren't reporting anything (other than the plethora of "BaseException: don't know how to handle a histogram of kind categorical"). Restarting the service doesn't change anything.

I do know that it's using mozaggregator-0.2.4.9, which is one sub-minor version behind current. This is what I tested locally, though, so I'm not sure if upgrading will make a difference.
Jared - just realized this is a categorical histogram, which is probably the problem. The more interesting question now is why I can't repro this.
Alright, issue was that the version of python_moztelemetry lagged on the server. We have a bit more work to do to keep that environment up-to-date, but part of the problem is that I didn't require an update on python_mozaggregator when I made changes to python_moztelemetry. 

While this issue has been fixed, the dashboard still hasn't been updated to show categorical histograms, so it still won't work - BUT, the aggregator service isn't erroring out, so this is considered fixed.
Status: NEW → RESOLVED
Closed: 8 years ago
Flags: needinfo?(chutten)
Flags: needinfo?(alessio.placitelli)
Resolution: --- → FIXED
Thanks for the quick resolution. Is there a bug tracking updating the server to use the new libraries? We will be looking to use this probe and adding other similar ones as part of a preference reorganization project (bug 1324168).
Flags: needinfo?(fbertsch)
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #5)
> Thanks for the quick resolution. Is there a bug tracking updating the server
> to use the new libraries? We will be looking to use this probe and adding
> other similar ones as part of a preference reorganization project (bug
> 1324168).

Here's the bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1316031

Hopefully we can get it resolved soon enough, especially now that there's interest in using categorical histograms. I have some cycles available so I may knock it out.
Flags: needinfo?(fbertsch)
Product: Cloud Services → Cloud Services Graveyard
You need to log in before you can comment on or make changes to this bug.