Update in-tree libpng to version 1.6.28

RESOLVED FIXED in Firefox 53

Status

()

defect
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: glennrp+bmo, Assigned: glennrp+bmo)

Tracking

Trunk
mozilla53
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox53 fixed)

Details

()

Attachments

(2 attachments, 1 obsolete attachment)

libpng-1.6.28 is planned for release on January 5, 2017, to fix
a (harmless) bug exposed by attempting to build with zlib-1.2.9/zlib-1.2.10.
Assignee: nobody → glennrp+bmo
Status: NEW → ASSIGNED
Depends on: 1326234
libpng-1.6.28 is out.
Blocks: 1328099
Please submit to try
Flags: needinfo?(ryanvm)
Attachment #8824584 - Attachment is obsolete: true
Does this depend on a zlib update too?
No, they are independent.
Comment on attachment 8824585 [details] [diff] [review]
v00-1328354-part02-libpng-1.6.28

Try is looking good.
Attachment #8824585 - Flags: review?(jmuizelaar)
Attachment #8824700 - Flags: review?(jmuizelaar)
Attachment #8824585 - Flags: review?(jmuizelaar) → review+
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/7b2836951988
Update in-tree libpng to version 1.6.28. r=jrmuizel
https://hg.mozilla.org/integration/mozilla-inbound/rev/685121de3c2c
Update old-configure.in to require libpng 1.6.28. r=jrmuizel
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/7b2836951988
https://hg.mozilla.org/mozilla-central/rev/685121de3c2c
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Attachment #8824700 - Flags: review?(jmuizelaar) → review-
Attachment #8824700 - Flags: review-
Blocks: 1348356
You need to log in before you can comment on or make changes to this bug.