Shockwave and WMP won't load

VERIFIED DUPLICATE of bug 132673

Status

()

Core
Plug-ins
--
major
VERIFIED DUPLICATE of bug 132673
16 years ago
16 years ago

People

(Reporter: R.K.Aa., Assigned: rubydoo123)

Tracking

({regression})

Trunk
x86
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Shockwave and Windows Media Player (6.4) are now broken again on Linux.
Shockwave is also broken on Windows XP (can't test WMP 6.4 there)

The regression happened between build 2002031908 (which was AOK)
and build 2002032008, where things were broken.

Sympthoms:
-WMP doesn't "initiate" - never gets content to play.
-Shockwave doesn't only "not play" - there is no space left for it to render in
at all. No alerts appear.

For a sample of the latter, install Shockwave on linux or windows,
then:

go to http://www.shockwave.com/sw/home/
Click link "JIGSAW PUZZLES"
Click link "Daily Jigsaw"
Then click "play game"
Result: A window without a placeholder for the plugin displays.
Reload has no effect.


I wonder if two different checkins may have contributed to this.
Since the Shockwave plugin now seemingly has neighter width nor height,
one possible candidate may be the fix for bug 40185:
"Cleaning up nsPluginInstanceOwner::GetHeight and ::GetWidth"
(Reporter)

Updated

16 years ago
Keywords: regression
(Reporter)

Comment 1

16 years ago
pinpointing timestamps:

Both plugins still worked in trunk build 2002031921.
Which means that the fix for bug 40185 has nothing to do with this
(it was checked in severeal hours earlyer)

Comment 2

16 years ago
Is the document.write problem in bug 132673?

Comment 3

16 years ago
Note: Shockwave is working fine for me in today's build on W2K on simplified
testcases:
http://www.macromedia.com/shockwave/welcome/

Can we get a simplified testcase here?

Depends on: 132673
*** Bug 132868 has been marked as a duplicate of this bug. ***

Comment 5

16 years ago
this is a dup of bug 132673
regression from fix for bug 123899, whiteout the patch
attachment 74520 [details] [diff] [review] every thing work just fine.

*** This bug has been marked as a duplicate of 132673 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 6

16 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.