last thing in a script created with document.write does not show

VERIFIED FIXED in mozilla1.0

Status

()

P2
major
VERIFIED FIXED
17 years ago
16 years ago

People

(Reporter: chrispetersen, Assigned: peterv)

Tracking

(4 keywords)

Trunk
mozilla1.0
regression, testcase, top100, topembed
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Build: 2002-03-21-03
Platform: All
Expected Results: Images of pixar characters should be displayed below the
site's navigator bar.

What I got: These specific images are not displayed.

This is a regression since it worked on the OS X 2002-03-20-03 build. It started
on the next build OS X 2002-03-20-08

Steps to reproduce:

1) Go to url
2) Navigator bar appears (home, feature films, the theater..) but the pixar
character images are missing.
(Reporter)

Comment 1

17 years ago
Only the site's default home page is affected. If you go to other pixar site
areas, all images are displayed on those pages. 
Severity: normal → major
(Reporter)

Comment 2

17 years ago
Found what's causing it. The page uses document.write method to create the images.

<script>
document.write('<img src="images/home0/home_tl.jpg" width="235" height="156"
alt="Monsters, Inc." border="0">')
</script>

This image doesn't appear in the latest build (2002-03-21-03) but does in March
20 th build (2002-03-20-03)

See my reduced test case.
(Reporter)

Comment 3

17 years ago
Created attachment 75490 [details]
Reduced test of problem

Image not appearing when used with document.write
(Reporter)

Updated

17 years ago
Keywords: regression
(Reporter)

Updated

17 years ago
Priority: -- → P2
*** Bug 132593 has been marked as a duplicate of this bug. ***
You can see this also on Ebay.de/Ebay.com
Keywords: mozilla1.0, nsbeta1, top100
The <img> appears in the content model but not the frame model.
nsbeta1+
Keywords: nsbeta1 → nsbeta1+
To peterv.  This was broken by the fix for bug 123899.
Assignee: attinasi → peterv
(Assignee)

Comment 8

17 years ago
So bz found that either document.write is broken (with my patch) or .innerHTML
is broken (without my patch). I think I'm starting to like Boris' proposal to
back both out ;-).
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0
*** Bug 132651 has been marked as a duplicate of this bug. ***
*** Bug 132771 has been marked as a duplicate of this bug. ***
resummarizing
Summary: Images on pixar's site don't appear → last thing in a script created with document.write does not show
*** Bug 132802 has been marked as a duplicate of this bug. ***
*** Bug 132799 has been marked as a duplicate of this bug. ***

Comment 14

17 years ago
Created attachment 75625 [details]
another simple testcase

This testcase has two parts.  Both parts are comming from five trained
document.write.  
Upper: all objects for document.write include TAG (br).  
       last thing is not appeared. 
Lower: only an object for last document.write does not include TAG. 
       last thing is appeared fine.

Updated

17 years ago
Blocks: 132640
*** Bug 132865 has been marked as a duplicate of this bug. ***
*** Bug 132868 has been marked as a duplicate of this bug. ***
*** Bug 132872 has been marked as a duplicate of this bug. ***

Comment 18

17 years ago
*** Bug 132867 has been marked as a duplicate of this bug. ***

Comment 19

17 years ago
I noticed some behavior at ureach.com site which I believe is related to this
bug, but I'm not sure. Try going to www.ureach.com, login as bugzilla, password
mozilla (this test account was created to solve an earlier bug). You'll see that
the sidebar with images missing, and the interface just looks weird. For the
"normal" expected look, login to the same account using Netscape, IE, etc. If
this bug is related, then I won't create a new bug report for the said problem.

Comment 20

17 years ago
looks related to me
*** Bug 132922 has been marked as a duplicate of this bug. ***
Lawrence, this bug is what you're seeing (my build with bug 123899 backed out
shows the site fine, a nightly does not).
*** Bug 132934 has been marked as a duplicate of this bug. ***
*** Bug 132962 has been marked as a duplicate of this bug. ***

Comment 25

17 years ago
There is a nice testcase at:
http://www.world-direct.com/mozilla-testcases/dynamic-tables/dynamic-
tables.html
Keywords: testcase

Comment 26

17 years ago
*** Bug 133032 has been marked as a duplicate of this bug. ***

Comment 27

17 years ago
*** Bug 133058 has been marked as a duplicate of this bug. ***
*** Bug 133065 has been marked as a duplicate of this bug. ***

Comment 29

17 years ago
*** Bug 133075 has been marked as a duplicate of this bug. ***

Comment 30

17 years ago
This is a very short and easy test:

<html>
a
<script>
  document.writeln('<br>');
</script>
b
</html>

Updated

17 years ago
Keywords: mozilla1.0 → mozilla1.0+

Comment 31

17 years ago
http://www.ricardo.de missing input fields, top middle "Suche nach [input] in ".
Same problem ?

Comment 32

17 years ago
*** Bug 133160 has been marked as a duplicate of this bug. ***

Comment 33

17 years ago
cc'ing jst on this important bug!!!

Comment 34

17 years ago
*** Bug 133139 has been marked as a duplicate of this bug. ***

Comment 35

17 years ago
*** Bug 133180 has been marked as a duplicate of this bug. ***

Comment 36

17 years ago
Needless to say, this is topembed.
Keywords: topembed
(Assignee)

Comment 37

17 years ago
Backing out patch for bug 123899. Bah.

Comment 38

17 years ago
*** Bug 133293 has been marked as a duplicate of this bug. ***

Comment 39

17 years ago
*** Bug 133302 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 40

17 years ago
*** Bug 133329 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 41

17 years ago
*** Bug 133278 has been marked as a duplicate of this bug. ***

Comment 42

17 years ago
*** Bug 133176 has been marked as a duplicate of this bug. ***

Comment 43

17 years ago
*** Bug 133341 has been marked as a duplicate of this bug. ***

Comment 44

17 years ago
*** Bug 133360 has been marked as a duplicate of this bug. ***
*** Bug 133378 has been marked as a duplicate of this bug. ***

Comment 46

17 years ago
Re. comment 37: Patch for bug 123899 isn't actually backed out yet, is it?
(Assignee)

Comment 47

17 years ago
Patch for bug 123899 backed out.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 48

17 years ago
*** Bug 133501 has been marked as a duplicate of this bug. ***

Comment 49

17 years ago
Was it really backed out? I'm still seeing the problem in the 2002 03 26 05
trunk.zip on win2K, which I think was built after the back out time. Do I just
need to wait a build?

Comment 50

17 years ago
Build: 2002032603
Result: Not Fixed

Comment 51

17 years ago
*** Bug 133492 has been marked as a duplicate of this bug. ***

Comment 52

17 years ago
Linux build 2002032606
Result: Fixed

Both of the attached test cases work for me on todays 6 am linux build, as well
as the page I originally noticed the problem on.
I'm sorry to have to say this, but please learn to read.  If Peter comments at 
4:34 on March 26 that the patch is backed out, then testing with a build that 
was on the FTP site at 3:00 is pretty pointless.

Comment 54

17 years ago
This is the dir of build 2002032603:
http://ftp.mozilla.org/pub/mozilla/nightly/2002-03-26-05-trunk/

As you can see it was on the FTP site at 07.38.
(Every build seems to have xxxxxx03 at the end. At least the 2 windows builds
from yesterday)

Comment 55

17 years ago
I believe the last 2 digits of the build id are the hour that the build was
performed.
(Reporter)

Comment 56

17 years ago
*** Bug 133512 has been marked as a duplicate of this bug. ***

Comment 57

17 years ago
Verified fixed in 2002-03-26-10 build on Win2K. Thanks!
Status: RESOLVED → VERIFIED
(Reporter)

Comment 58

17 years ago
Verified in the Mac OS 9 (2002-03-26-08) and Mac OS X (2002-03-26-08) builds.
(Reporter)

Comment 59

17 years ago
Verified on the Linux March 26th build (2002-03-26-08)

Comment 60

17 years ago
Before I submitting a dupe, does this bug relate to the problem that on
http://www.us.buy.com/ the search text field does not show from this Javascript
output:

		<script language="javascript">
           <!--
           if (navigator.appName == "Netscape" &&
parseFloat(navigator.appVersion) < 5.00 && !mac) {
            document.write("<input type=\"text\" size=\"16\" name=\"qu\"
value=\"\">")
           } else if (navigator.appName == "Netscape" &&
parseFloat(navigator.appVersion) >= 5.00) {
            document.write("<input type=\"text\" size=\"32\"
style=\"font-size:10px;height:19px\" name=\"qu\" value=\"\">")
           } else {
            document.write("<input type=\"text\" size=\"32\"
style=\"font-size:10px;height:19px\" name=\"qu\" value=\"\">")
           }
           //-->
		</script>


Running 2002032603 on W2K

Comment 61

17 years ago
Yes. It probably is.
I'm running a build with the fix and the search shows up fine.

Comment 62

17 years ago
*** Bug 133511 has been marked as a duplicate of this bug. ***

Comment 63

17 years ago
*** Bug 133607 has been marked as a duplicate of this bug. ***

Comment 64

17 years ago
*** Bug 132471 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Blocks: 133544
You need to log in before you can comment on or make changes to this bug.