No scrollbars if headers expanded

VERIFIED DUPLICATE of bug 91662

Status

--
major
VERIFIED DUPLICATE of bug 91662
17 years ago
10 years ago

People

(Reporter: mozilla, Assigned: sspitzer)

Tracking

Trunk
All
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031104 (0.9.9)

If the headers are set to "All" and the header field is expanded, the scrollbars
never appear in BOTH the message list window and the message display window.

Reproducible: Always
Steps to Reproduce:
1. Open Mail & News; set header view to "All".
2. Expand header display.
3. Watch scrollbars disappear on both the message list and message body.
4. Restarting Mozilla does not help.
(Reporter)

Comment 1

17 years ago
Created attachment 75670 [details]
Screenshot of described behavior

Updated

17 years ago
QA Contact: olgam → laurel

Comment 2

17 years ago

*** This bug has been marked as a duplicate of 9942 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
marking verified as a duplicate
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

17 years ago
This bug has nothing to do with bug 9942. 9942 is a bug about not being able to 
scroll the headers in a mail message. This bug is that the scrollbars in a 
message disappear.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 5

17 years ago
And scrollbars in the message list also.

Comment 6

17 years ago
From what I see (mar26 trunk), this doesn't happen unless the All header
envelope is large enough on a given message to expand over the majority of the
message pane.  I believe it is indeed a duplicate of bug 9942 because the way to
resolve the problem would be to scroll the headers with the message. 

Comment 7

17 years ago
Seeing this on Linux, too (2002-03-21-21). Could we please change plaform to ALL?
(Reporter)

Comment 8

17 years ago
Platform all done.

The reason I hesitate to have it dubbed as a dup of bug 9942 is because I'm 
afraid it will get relegated to the "we'll do it sometime" pile. This is a 
usability issue that I don't believe should be left to be fixed in some nebulous 
future time frame. If you disagree, go ahead and change it back...I won't fight 
it. And believe me, I have whined about headers scrolling for a long time, so 
I'm on your side about that getting fixed. It is still the main reason I have 
not adopted Mozilla (after all these years of using 4.X).
Hardware: PC → All

Comment 9

17 years ago
*** Bug 140336 has been marked as a duplicate of this bug. ***

Comment 10

17 years ago
*** Bug 140546 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 11

17 years ago
Taking a look at the duplicates of this bug, I am afraid that this bug I filed 
is being misunderstood. I want to be clear that this bug is NOT about having a 
long list of headers and this causing the message body to disappear. This bug is 
about View -> Headers -> All making it impossible to scroll messages even when 
the headers are small enough not to obscure the message.

Comment 12

17 years ago
Created attachment 84023 [details]
Screenshot. OS/2. OS should be all. Dunno about platform.
(Reporter)

Comment 13

17 years ago
That attachment is a case of the headers being too large to fit, and having no 
scrollbars appear. This bug is about having headers that are shorter than the 
message window and not being able to scroll the message.

Comment 14

17 years ago
Created attachment 84052 [details]
OS/2 screenshot. Platform PC. OS all. Not platform all, OS windoze.
(Reporter)

Comment 15

17 years ago
Mass removing self from CC list.
(Reporter)

Comment 16

17 years ago
Now I feel sumb because I have to add back. Sorry for the spam.

Comment 17

17 years ago
Platform: OpenVMS 7.3, Build ID: 2002051122

I noticed something else too. Not only are the scrollbars removed, but the
header line in the message list display (Subject, Sender, Date etc.) can also
change when you expand the header display of the message.

Very odd, it seems that expanding the message header will cause a complete
redraw/recalculation of the message list window. 

Comment 18

17 years ago
Jerry, do I understand you right and attachment 80749 [details] shows what you mean?
Then this might be a duplicate of bug 91662.
Observe your header data when you view all headers: there might be a long entry
(subject, adress,...) that cannot be wrapped - in your (first) screenshot this
seems to be the "Path" of the message. 
If the window is wide enough to fully show the Path, the scrollbars are there.
But when making the window smaller, the scroolbars are "pushed out" of the
window as soon as this long un-wrappable entry is getting too wide.
(Reporter)

Comment 19

17 years ago

*** This bug has been marked as a duplicate of 91662 ***
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 20

17 years ago
marking verified as a duplicate
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.