Bug 133054 (hand)

Implement Acrobat-like "Grab and drag" with hand-cursor aka grabber

NEW

Status

SeaMonkey
UI Design
--
enhancement
15 years ago
12 years ago

People

(Reporter: Chibi15, Assigned: jag (Peter Annema))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

15 years ago
A "hand" tool would be very... handy and comformtable for scrolling webpages!
Its one of these "little things" i miss in Mozilla.

I will attach two screenshots showing this tool
(Reporter)

Comment 1

15 years ago
Created attachment 75791 [details]
before scrolling
(Reporter)

Comment 2

15 years ago
Created attachment 75792 [details]
page scrolling with the hand!

Comment 3

15 years ago
Duplicate of bug 22775?
(Reporter)

Comment 4

15 years ago
No the hand is not the same as autoscrolling.
With the Hand-tool it is possible to "grab" the page and drag it around.
See my attachments for an expanation!

Comment 5

15 years ago
your pictures are *NOT* good explanations.

*** This bug has been marked as a duplicate of 63712 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 6

15 years ago
I've added a new attachment about how the hand should work.
(Reporter)

Comment 7

15 years ago
Created attachment 75843 [details]
Hand explained

This should explain how the hand should work
If you want to see an example of what he's talking about - see the hand on adobe
acrobat.
BTW - the behavior he is asking for is different than autoscroll/panning.

Comment 10

15 years ago
Brian: I'm sorry, but could you explain how the "hand" in acrobat is different
from the panning portion of your autoscroll work you were working on
implementing?  I've been following these bugs for a while, and I was under the
impression that the behavior was the same.  I thought that with your plan,
holding down the middle button would result in panning behavior much like the
hand in acrobat, while clicking the button would result in placement of the
artifact thingy for autoscroll...
Holding down the middle mouse button will allow you to scroll the page without 
using the scrollbar directly. It will act much like you are actually in the 
scrollbar, but will allow vertical and horizontal scrolling much like you are 
in a 2d scrollbar:

+---------------+
|               |
|               |
|       X       |
|               |
|               |
+---------------+

The 2d "scrollbar" would be the visual containing box.

Therefore, the hand could be implemented with a middle click and modifier key 
(or prefs), but it isn't the same behavior. The hand allows you in Adobe to 
only drag the page a short distance, while this behavior would allow you to 
scroll anywhere in the page rather quickly.

Comment 12

15 years ago
*** Bug 144910 has been marked as a duplicate of this bug. ***
This is not a dupe, and as such... I had trouble finding it when I needed to 
find it.

I am going to also cover this with http://mozscroll.mozdev.org/ along with bug 
22775 and bug 63712.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
I'm taking this as I don't believe mpt is going to implement it and I'm 
putting it into mozscroll.mozdev.org.
Assignee: mpt → netdemonz
Status: UNCONFIRMED → NEW
Ever confirmed: true
This bug blocks 154779, which is about hand tool needed for Print Preview.
Blocks: 154779
Sorry, I meant bug 154479.
Blocks: 154479
No longer blocks: 154779
Bug 174499 - How to Activate "grab and drag" is about how to activate this 
feature.
Also changed the summary, added an alias, and added the URL: 
http://mozscroll.mozdev.org/
Alias: hand
Component: User Interface Design → XP Apps
Depends on: 174499
OS: MacOS X → All
Hardware: Macintosh → All
Summary: Mozilla should feature a "hand"-tool for scrolling webpages → [RFE] Implement Acrobat-like "Grab and drag" with hand-cursor
Summary: [RFE] Implement Acrobat-like "Grab and drag" with hand-cursor → Implement Acrobat-like "Grab and drag" with hand-cursor
Product: Core → Mozilla Application Suite
I'm in favor of WONTFIX.  Given the scrolling methods autoscroll makes
available, this becomes almost-redundant.
removing dependencies
Assignee: netdragon → jag
No longer blocks: 154479
No longer depends on: 174499
QA Contact: zach
Summary: Implement Acrobat-like "Grab and drag" with hand-cursor → Implement Acrobat-like "Grab and drag" with hand-cursor aka grabber
*** Bug 174499 has been marked as a duplicate of this bug. ***
*** Bug 60978 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.