[e10s APZ] flickering black overflow while scrolling

RESOLVED FIXED

Status

()

Core
Graphics: Layers
RESOLVED FIXED
4 months ago
25 days ago

People

(Reporter: Bram Speeckaert, Assigned: sinker)

Tracking

(Blocks: 1 bug, {regression, testcase})

50 Branch
Unspecified
All
regression, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox50 wontfix, firefox51 wontfix, firefox52 wontfix, firefox53 wontfix, firefox54 wontfix, firefox55 fixed, firefox-esr45 disabled, firefox-esr52 wontfix)

Details

(Whiteboard: gfx-noted)

Attachments

(2 attachments)

(Reporter)

Description

4 months ago
Created attachment 8826363 [details]
Reduced testcase

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170112030301

Steps to reproduce:

1. Ensure e10s is active.
2. Open testcase in large/maximized window.
3. Scroll down.


Actual results:

With e10s enabled, the hidden overflow appears as a flickering black rectangle while scrolling. This does not happen with e10s disabled.


Expected results:

No flickering black rectangle should appear.
(Reporter)

Comment 1

4 months ago
Created attachment 8826367 [details]
Screenshot
(Reporter)

Updated

4 months ago
Keywords: testcase
(Reporter)

Comment 2

4 months ago
Bug is reproducible on latest Nightly x64 on Windows 10, and Firefox 50.1.0 on macOS 10.12.2.
OS: Unspecified → All
Version: 53 Branch → 50 Branch

Comment 3

4 months ago
disabled apz seems to fix the problem
Blocks: 1013364
Status: UNCONFIRMED → NEW
status-firefox50: --- → wontfix
status-firefox51: --- → affected
status-firefox52: --- → affected
status-firefox53: --- → affected
status-firefox-esr45: --- → disabled
Ever confirmed: true
Summary: [e10s] flickering black overflow while scrolling → [e10s APZ] flickering black overflow while scrolling

Updated

4 months ago
Whiteboard: gfx-noted
I can repro this (on Windows), looks pretty bad. Happens even when keyboard scrolling. There's a bunch of 3D stuff here which I'm not too familiar with. CC'ing botond and matt who might have more knowledge/time to look into this.
Component: Graphics: Layers → Panning and Zooming

Comment 5

4 months ago
Regression range:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=f44d3d568c2dd57365c85e70f9fd96db62ad5749&tochange=4d4dd7869c4fc912a2f9f8fb9ce37db76051d1c5

Regressed by: bug 1244943
Thanks for tracking that down! Thinker, can you look into this?
Blocks: 1244943
status-firefox51: affected → wontfix
Component: Panning and Zooming → Graphics: Layers
Flags: needinfo?(tlee)
Keywords: regression
(Assignee)

Comment 7

4 months ago
I will look into this bug in following days.
Flags: needinfo?(tlee)
Thanks.
Assignee: nobody → tlee
(Reporter)

Updated

4 months ago
Has Regression Range: --- → yes
Has STR: --- → yes
Any updates on this, Thinker?
status-firefox54: --- → affected
Flags: needinfo?(tlee)
(Assignee)

Comment 10

4 months ago
Sorry! I am busy on some other tasks.  I will try to fix this bug in next week.
Flags: needinfo?(tlee)
Too late for firefox 52, mass-wontfix.
status-firefox52: affected → wontfix
Kats, Milan, any thoughts here? Should this be a priority to fix for 55 or do we want to treat it as backlog that would be nice to have fixed someday? We don't have duplicate reports, so I'm not sure how common this issue might be.
status-firefox53: affected → wontfix
status-firefox54: affected → fix-optional
status-firefox55: --- → fix-optional
Flags: needinfo?(milan)
Flags: needinfo?(bugmail)
Yeah I haven't seen any other reports of this either. Thinker, will you have any time to look into this in the next month or so?
Flags: needinfo?(bugmail) → needinfo?(tlee)
Flags: needinfo?(milan)

Comment 14

a month ago
I can no longer reproduce the problem on Nightly55.0a1.
This seems to be fixed.

Fixed range:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=00a166a8640dffa2e0f48650f966d75ca3c1836e&tochange=0d6ffde320ec3a3b44dc4c27f7c11cc9a9bf341c
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=f0d0fa45265951efd27c283784a94ebfee2f957d&tochange=58181c34aa51b2aa8e129c0ec5c831d0a877e00f

Fixed by: Bug 1352442
status-firefox55: fix-optional → fixed
Thanks Alice! Marking as fixed via bug 1352442.
Status: NEW → RESOLVED
Last Resolved: a month ago
Depends on: 1352442
Flags: needinfo?(tlee)
Resolution: --- → FIXED
status-firefox-esr52: --- → wontfix
Probably better to let bug 1352442 ride the trains so any fallout from that change has time to be found, given that this is a pretty low-impact bug.
status-firefox54: fix-optional → wontfix
(Reporter)

Comment 17

25 days ago
I believe this bug has been fixed only partially. Since the STR are different, I have filed a new bug for this: bug 1360952.
You need to log in before you can comment on or make changes to this bug.