[e10s APZ] black overflow after window resize

RESOLVED DUPLICATE of bug 1361970

Status

()

Core
Graphics: Layers
RESOLVED DUPLICATE of bug 1361970
a year ago
a year ago

People

(Reporter: Bram Speeckaert, Assigned: pchang)

Tracking

({regression})

53 Branch
Unspecified
All
regression
Points:
---

Firefox Tracking Flags

(firefox53 wontfix, firefox54 fix-optional, firefox55 fix-optional)

Details

(Whiteboard: [gfx-noted], URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

a year ago
Created attachment 8863279 [details]
black-overflow.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170430030208

Steps to reproduce:

1. Open bug 1330814 testcase.
2. Make sure the browser window is not maximized.
3. Scroll down until green portion is no longer visible.
4. Maximize the window.


Actual results:

1. The green portion remains visible longer than you'd expect (scrolling upwards makes it disappear again).
2. After maximizing, black overflow is visible.


Expected results:

1. Green portion shouldn't remain on screen.
2. Black overflow shouldn't be visible.
I can reproduce this on windows as well. I did some quick checks with mozregression and I'm going to call this a regression from bug 1244943 as well. As Bram said, the regression was really bug 1330814 which was partially fixed by bug 1352442, and this bug tracks the part that wasn't fixed.

Thinker, please take a look when you get a chance.
Blocks: 1244943
Status: UNCONFIRMED → NEW
status-firefox53: --- → wontfix
status-firefox54: --- → fix-optional
status-firefox55: --- → fix-optional
Ever confirmed: true
Flags: needinfo?(tlee)
Keywords: regression
OS: Unspecified → All
Whiteboard: [gfx-noted]
Assignee: nobody → tlee
Flags: needinfo?(tlee)
Peter, I am on a vocation.  Could you find some one to look into this bug?
Flags: needinfo?(howareyou322)
(Assignee)

Comment 3

a year ago
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #1)
> I can reproduce this on windows as well. I did some quick checks with
> mozregression and I'm going to call this a regression from bug 1244943 as
> well. As Bram said, the regression was really bug 1330814 which was
> partially fixed by bug 1352442, and this bug tracks the part that wasn't
> fixed.
> 
> Thinker, please take a look when you get a chance.

I couldn't reproduce this on windows with FF 55.0a1 (2017-05-11) (64-bit).
Kats, are you still able to reproduce this issue?
Flags: needinfo?(howareyou322)
I'm in the process of moving and my windows machine is in a box right now.. I'll try reproducing early next week and let you know.
(Reporter)

Comment 5

a year ago
I can still reproduce this in 55.0a1 (2017-05-11) (64-bit).

I should add that the scrolling should be done with a mouse (using the scroll wheel or autoscrolling) or the keyboard arrow keys. I have not been able to reproduce this with my laptop's touchpad or by dragging the vertical scrollbar using the mouse cursor. Also having the web developer tools open seems to inhibit the bug.
(Assignee)

Comment 6

a year ago
(In reply to Bram Speeckaert from comment #5)
> I can still reproduce this in 55.0a1 (2017-05-11) (64-bit).
> 
> I should add that the scrolling should be done with a mouse (using the
> scroll wheel or autoscrolling) or the keyboard arrow keys. I have not been
> able to reproduce this with my laptop's touchpad or by dragging the vertical
> scrollbar using the mouse cursor. Also having the web developer tools open
> seems to inhibit the bug.

Ok, now I can reproduce this issue with keyboard arrow keys.
Going to check the root cause.
(Assignee)

Comment 7

a year ago
I can reproduce on OS X as well, debugging.
Assignee: tlee → howareyou322
(Assignee)

Comment 8

a year ago
When I reproduced this issue on Linux, I found the page with 3D content didn't update if I switched tab back to the page with 3D content. Checking the invalidation area under this condition.
(Assignee)

Comment 9

a year ago
I found the layer(paintedlayer) under the 3D context had an opaque region which was the same as 3D context layer when 3D context layer was not visible. That's why we saw a black box after resizing. Now I'm using rr to debug how this opaque region generates on ubuntu.


P.S. black box was gone if you comment the code in [1].
[1]http://searchfox.org/mozilla-central/source/gfx/layers/composite/LayerManagerComposite.cpp#367
Comment hidden (mozreview-request)
Does the patch in Bug 1361970 fix this?

If not, can you rebase on top of that please?
(Assignee)

Comment 12

a year ago
(In reply to Matt Woodrow (:mattwoodrow) from comment #11)
> Does the patch in Bug 1361970 fix this?
> 
> If not, can you rebase on top of that please?

I just verified your patch in bug 1361970 and couldn't reproduce the black box.
Then I will duplicate this issue to bug 1361970.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1361970
(Assignee)

Updated

a year ago
Attachment #8870349 - Attachment is obsolete: true
Attachment #8870349 - Flags: review?(matt.woodrow)
You need to log in before you can comment on or make changes to this bug.