Crash [@InvalidArrayIndex_CRASH nsTArray_Impl<mozilla::gfx::Point4DTyped<mozilla::gfx::UnknownUnits, float>, nsTArrayInfallibleAllocator>::ElementAt mozilla::layers::BuildPathFromPolygon]

RESOLVED DUPLICATE of bug 1331894

Status

()

Core
Graphics
P3
normal
RESOLVED DUPLICATE of bug 1331894
9 months ago
9 months ago

People

(Reporter: Tomcat, Unassigned)

Tracking

(Blocks: 1 bug, {crash})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted], URL)

Attachments

(1 attachment)

(Reporter)

Description

9 months ago
Created attachment 8827351 [details]
stack

Found by bughunter and reproduced on latest m-c tinderbox debug build on windows.

Steps to reproduce:
-> Load http://www.simulationcurriculum.com
--> Crash

debug trunk windows only it seems so far.

xidorn could you take a look or do you know who could take a look ?
(Reporter)

Updated

9 months ago
Flags: needinfo?(xidorn+moz)
This seems to be in gfx code, no? I'm not familiar with that part. Probably as milan?
Flags: needinfo?(xidorn+moz)
(Reporter)

Comment 2

9 months ago
https://crash-stats.mozilla.com/report/index/84c7781a-6a37-43b5-9b9c-b08c22170117 seems to crash opt builds too
(Reporter)

Updated

9 months ago
Component: Layout → Graphics
Priority: -- → P3
Whiteboard: [gfx-noted]
I tried in my windows machine and I cannot reproduce this issue. :Tomcat, could you post your about:support information? Thanks.
Flags: needinfo?(cbook)
This crash was caused by BasicCompositor change introduced in Bug 1323797. Reproducing it requires that layers hardware acceleration is turned off: layers.acceleration.disabled=true.

I have a fix for this crash in a duplicate Bug 1331894.
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Flags: needinfo?(cbook)
Resolution: --- → DUPLICATE
Duplicate of bug: 1331894
You need to log in before you can comment on or make changes to this bug.