[a11y] [Meta] Identity panel a11y issues

RESOLVED FIXED

Status

()

Firefox
Site Identity and Permission Panels
P2
normal
RESOLVED FIXED
4 months ago
a month ago

People

(Reporter: MarcoZ, Unassigned)

Tracking

({access, meta, regression})

Trunk
access, meta, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox51 wontfix, firefox52 fixed, firefox53 fixed, firefox54 fixed, firefox-esr52 fixed)

Details

(Whiteboard: [fxprivacy])

(Reporter)

Description

4 months ago
+++ This bug was initially created as a clone of Bug #1327946 +++

The panel that opens when hitting the site identity button doesn't read well with screen readers. The following problems are found:

1. The focus lands nowhere specific.
2. Buttons such as the one to expand on the identity has no label, but can be tabbed to. It needs alternative text if it is a graphical button.
3. This panel, before the rewrite, used to read automatically, but now doesn't.
4. All the text snippets are just plain text snippets which are hard to review. Suggestion: Make these tabable by putting the relevant information into a textarea and giving them a label. That way, info can also be easily copied and pasted.
Thanks for reporting this. We should improve on that. A couple of questions:
 
> 1. The focus lands nowhere specific.

I thought that's always the case when popup panels are autofocused. Is this a big issue considering you can continue tabbing to a relevant element?

> 3. This panel, before the rewrite, used to read automatically, but now
> doesn't.

Do you have any pointers to attributes/elements that are required for that to happen?

> 4. All the text snippets are just plain text snippets which are hard to
> review. Suggestion: Make these tabable by putting the relevant information
> into a textarea and giving them a label. That way, info can also be easily
> copied and pasted.

Pardon my ignorance, but I was under the impression that making too many non-actionable elements tabable isn't great either. Would this be improved by fixing problem 3?
No longer blocks: 1267617
Whiteboard: [fxprivacy] → [fxprivacy] [triage]

Comment 2

4 months ago
(In reply to Johann Hofmann [:johannh] from comment #1)
> > 3. This panel, before the rewrite, used to read automatically, but now
> > doesn't.
> 
> Do you have any pointers to attributes/elements that are required for that
> to happen?

probably role=alert if you're not using that already.
status-firefox51: --- → affected
status-firefox52: --- → affected
status-firefox53: --- → affected
We should consider splitting this bug up into actionable and more easily upliftable pieces.
(Reporter)

Comment 4

4 months ago
(In reply to Johann Hofmann [:johannh] from comment #3)
> We should consider splitting this bug up into actionable and more easily
> upliftable pieces.

Agreed, turning this one into a meta bug.
Keywords: meta
(Reporter)

Updated

4 months ago
Depends on: 1335016
(Reporter)

Updated

4 months ago
Depends on: 1335018
(Reporter)

Updated

4 months ago
Depends on: 1335019
(Reporter)

Comment 5

4 months ago
I've now filed bugs for the first three issues. Issue 4 from my original description might be solved by issue 3, or we might need some additional work. I am especially worried about the stuff that gets shown and hidden by the site-security-info-expander button. As far as I can see, it gets added to the end of the DOM, but not really sure.
Thanks, we'll hopefully get around to discussing these at triage today!

Updated

4 months ago
Priority: -- → P2
Summary: [a11y] The identity panel doesn't read well with screen readers, has unlabeled buttons for screen readers. → [a11y] [Meta] The identity panel doesn't read well with screen readers, has unlabeled buttons for screen readers.
Whiteboard: [fxprivacy] [triage] → [fxprivacy]
status-firefox51: affected → wontfix
Depends on: 1335737
Summary: [a11y] [Meta] The identity panel doesn't read well with screen readers, has unlabeled buttons for screen readers. → [a11y] [Meta] Identity panel a11y issues
Depends on: 1334496
What's the status of this bug with respect to Fx52? We've only got a couple weeks left of real development time for it in this cycle.
Flags: needinfo?(jhofmann)
TBH it's unlikely that we will get any of this into 52. Bug 1335018 maybe, I'll look into that in the next days. Bug 1334496 only needs to get to 53. Bug 1335016 will need a label. The rest are not recent regressions, but we would still like to solve them in a timely manner (hence the P2). 53 sounds like a more likely target for those.
status-firefox52: affected → fix-optional
status-firefox53: affected → fix-optional
Flags: needinfo?(jhofmann)
To clarify the ESR status of dependencies: I found that we should indeed track bug 1335737 for 52. I'll put that one on P1 and try to resolve it ASAP. The other bugs are either not affecting 52 or have already been in 45. It would be nice to fix some of them but we're not breaking ESR by not solving those.
Marking this as fixed for 52 since we solved bug 1335737 by fixing and uplifting bug 1335018 (yes, it's a bit complicated, sorry).
status-firefox52: fix-optional → fixed
Depends on: 1354551
No longer depends on: 1354551
All dependencies are resolved so I'm marking this fixed.
Status: NEW → RESOLVED
Last Resolved: 2 months ago
status-firefox54: affected → fixed
Resolution: --- → FIXED
status-firefox53: fix-optional → fixed
status-firefox-esr52: --- → fixed
You need to log in before you can comment on or make changes to this bug.