Device permission box isn't accessible using keyboard

RESOLVED DUPLICATE of bug 1335018

Status

()

Firefox
Site Identity and Permission Panels
P1
normal
RESOLVED DUPLICATE of bug 1335018
10 months ago
7 months ago

People

(Reporter: Hani Yacoub, Unassigned)

Tracking

(Blocks: 1 bug, {access, regression})

54 Branch
All
Mac OS X
access, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox51 wontfix, firefox52 fixed, firefox53 fixed, firefox54 verified)

Details

(Whiteboard: [fxprivacy])

(Reporter)

Description

10 months ago
[Affected versions]: 
Nightly 54.0a1

[Affected platforms]:
Platforms: Mac OS X 10.11 and Mac OS X 10.12

[Steps to reproduce]:
1. Go to permission.site.
2. Click Camera + Microphone.
3. Press tab to navigate to device permission icon in identity block and press enter.
4. Press tab.

[Expected result]:
You should be able to navigate throw the device permission dialog box using the keyboard

[Actual result]:
The navigation isn't accessible using the keyboard.

[Note]:
Device permission box is accessible using keyboard on Mac OS X 10.10
(Reporter)

Updated

10 months ago
Blocks: 1188147

Updated

10 months ago
Blocks: 1333437
Hani, can you check if this is affecting older versions as well? Thanks!
Flags: needinfo?(hani.yacoub)
Priority: -- → P2
Whiteboard: [fxprivacy]
(Reporter)

Comment 2

10 months ago
It's affected on Firefox Nightly 51.0a1, 52.0a1 and 53.0a1 also.
status-firefox51: --- → affected
status-firefox52: --- → affected
status-firefox53: --- → affected
Flags: needinfo?(hani.yacoub)
[Tracking Requested - why for this release]: a11y issue for ESR
status-firefox51: affected → wontfix
tracking-firefox52: --- → ?
Flags: qe-verify+
Keywords: access, regression
Priority: P2 → P1
As it looks right now this could be solved by bug 1335018.
Depends on: 1335018
The solution to this is indeed part of bug 1335018, so I'm duping this. Please make sure to verify that this is fixed, too. Thanks!
Status: NEW → RESOLVED
Last Resolved: 10 months ago
tracking-firefox52: ? → ---
Resolution: --- → DUPLICATE
Duplicate of bug: 1335018
status-firefox52: affected → fixed
status-firefox53: affected → fixed
status-firefox54: affected → fixed
I'm still not able to navigate through the permission or identity pop-up using the keyboard on OS X 10.11, 10.12, 55.0a1 (2017-04-26).
Status: RESOLVED → REOPENED
Flags: needinfo?(jhofmann)
Resolution: DUPLICATE → ---
OS: Unspecified → Mac OS X
Hardware: Unspecified → All
(In reply to Paul Silaghi, QA [:pauly] from comment #6)
> I'm still not able to navigate through the permission or identity pop-up
> using the keyboard on OS X 10.11, 10.12, 55.0a1 (2017-04-26).

Did you enable Settings -> Keyboard -> Shortcuts -> All Controls?
Flags: needinfo?(jhofmann) → needinfo?(paul.silaghi)
(In reply to Johann Hofmann [:johannh] from comment #7)
> Did you enable Settings -> Keyboard -> Shortcuts -> All Controls?
No, I didn't. Thank you, works fine now, Fx 54b5, OS X 10.12.
Status: REOPENED → RESOLVED
Last Resolved: 10 months ago7 months ago
status-firefox54: fixed → verified
Flags: qe-verify+
Flags: needinfo?(paul.silaghi)
Resolution: --- → DUPLICATE
Duplicate of bug: 1335018
You need to log in before you can comment on or make changes to this bug.