Closed Bug 1334095 Opened 4 years ago Closed 2 years ago

Intermittent test_navigation.py TestNavigate.test_about_blank_for_new_docshell | TimeoutException: Timed out after 5.2 seconds with message: No new tab has been opened

Categories

(Testing :: Marionette, defect, P5)

Version 3
ARM64
Android
defect

Tracking

(firefox65 disabled, firefox66 fixed)

RESOLVED FIXED
mozilla66
Tracking Status
firefox65 --- disabled
firefox66 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: whimboo)

References

(Depends on 1 open bug)

Details

(Keywords: intermittent-failure, mobile)

Attachments

(1 file)

We will have to keep this test disabled due to the failure as listed above. I have no idea why this is always failing on our test machines. I absolutely cannot reproduce it locally when running with a real device. 

Maybe it's just too slow and we have to bump the timeout.
Blocks: 1297394
Keywords: mobile
Priority: -- → P5
OS: Unspecified → Android
Hardware: Unspecified → ARM64
Might be related in how we open the new tab. So bug 1504756 might help here. Or it is related to bug 1506782, where we also want to get rid of the initial `about:newtab` like page for Fennec.
Depends on: 1504756, 1506782

Bug 1500509 might also help here which will make running tests way faster.

Depends on: 1500509

In some cases I have seen that opening a new tab can take longer than 5s. With the "New window" command we don't make use of a timeout anymore. As such this test should pass on Android now.

Here a try build:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=282b8f9bbb092fe7252b75be375cc6f1889133e6

Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/da9f91aaa74b
[marionette] Re-enable TestNavigate.test_about_blank_for_new_docshell on Android. r=ato
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
Assignee: nobody → hskupin
You need to log in before you can comment on or make changes to this bug.