[e10s] Pasting using Cmd-V results in two consecutive pastes

VERIFIED FIXED in Firefox 54

Status

()

defect
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: mconley, Assigned: spohl)

Tracking

({regression})

50 Branch
mozilla54
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox51 unaffected, firefox52 unaffected, firefox53 unaffected, firefox54 verified)

Details

STR:

1) Copy this string to the clipboard "This should only appear once"
2) Open a new tab to data:text/html,<html contenteditable>
3) Select the white background, and use Cmd-V to paste the string from step 1 into the editable area.

ER:

A single instance of the string from step 1.

AR:

The string is pasted twice.

I bisected this - this is a regression from bug 429824.
Reporter

Updated

2 years ago
Keywords: regression
Assignee

Comment 1

2 years ago
Looking into it. Thanks for reporting!
Assignee: nobody → spohl.mozilla.bugs
Status: NEW → ASSIGNED
Assignee

Comment 2

2 years ago
Looks like this is e10s-only.
Summary: Pasting using Cmd-V results in two consecutive pastes → [e10s] Pasting using Cmd-V results in two consecutive pastes
Reporter

Updated

2 years ago
Duplicate of this bug: 1334240
Assignee

Comment 4

2 years ago
There is a difference between e10s and non-e10s deep within PresShell::HandleEvent here, which causes mTextInputHandler->HandleKeyDownEvent(theEvent)[1] to report that the event hasn't been handled when in fact it has. Even though I'm making progress I don't expect to have this fixed by EOD today. I've backed out bug 429824 since pasting via cmd+v is pretty fundamental functionality.

[1] https://dxr.mozilla.org/mozilla-central/rev/d92fd6b6d6bfc5b566222ae2957e55772d60151a/widget/cocoa/nsChildView.mm#5474
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1334382
Duplicate of this bug: 1334362
Duplicate of this bug: 1334391
Target Milestone: --- → mozilla54
Flags: qe-verify+
Reproduced the issue using STR from comment 0.
This is verified fixed on 54 beta 4 under Mac OS X 10.10.5.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.