Closed Bug 1334964 Opened 3 years ago Closed 3 years ago

mozapps/skin/aboutNetworking.css uses float: inline-start, will cause browser_parsable_css.js to permafail on Gecko 53 merge to beta on March 6th

Categories

(Core :: Networking, defect)

53 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla54
Tracking Status
firefox51 --- unaffected
firefox52 --- unaffected
firefox53 + fixed
firefox54 --- fixed

People

(Reporter: philor, Assigned: tomer)

References

Details

(Whiteboard: [necko-active])

Attachments

(1 file)

Same story as bug 1334956, no float: inline-* on Gecko 53 once it hits beta so both browser_parsable_css.js and the actual use of inline-start will begin to fail when 53 merges to beta on March 6th.

[Tracking Requested - why for this release]: permaorange, closed tree, wailing and gnashing of teeth.
Assignee: nobody → tomer.moz.bugs
Status: NEW → ASSIGNED
See Also: → 1335010
Attachment #8831675 - Flags: review?(jaws)
Whiteboard: [necko-active]
Comment on attachment 8831675 [details]
Bug 1334964 - mozapps/skin/aboutNetworking.css uses float: inline-start

https://reviewboard.mozilla.org/r/108222/#review109338
Attachment #8831675 - Flags: review?(jaws) → review+
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/e2b34e5ebd80
mozapps/skin/aboutNetworking.css uses float: inline-start r=jaws
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/e2b34e5ebd80
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
Please request Aurora approval on this at your earliest convenience :)
Flags: needinfo?(tomer.moz.bugs)
Comment on attachment 8831675 [details]
Bug 1334964 - mozapps/skin/aboutNetworking.css uses float: inline-start

Approval Request Comment
[Feature/Bug causing the regression]: bug 902596
[User impact if declined]: test failures
[Is this code covered by automated tests?]: no, but it cause failures due to unimplemented keywords.  
[Has the fix been verified in Nightly?]: yes.
[Needs manual test from QE? If yes, steps to reproduce]: probably not
[List of other uplifts needed for the feature/fix]: no dependencies beside bug 902596 which this patch fix.
[Is the change risky?]: not too much.
[Why is the change risky/not risky?]: Just backporting CSS code to use :dir().
[String changes made/needed]:
Flags: needinfo?(tomer.moz.bugs)
Attachment #8831675 - Flags: approval-mozilla-aurora?
Duplicate of this bug: 1336453
Comment on attachment 8831675 [details]
Bug 1334964 - mozapps/skin/aboutNetworking.css uses float: inline-start

Fix test failures. Aurora53+.
Attachment #8831675 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Track 53+ as this will happen when merging to mozilla-beta.
You need to log in before you can comment on or make changes to this bug.