close() should be in DedicatedWorkerGlobalScope and SharedWorkerGlobalScope only

RESOLVED FIXED in Firefox 54

Status

()

defect
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: baku, Assigned: baku, NeedInfo)

Tracking

(Blocks 2 bugs, {dev-doc-complete})

unspecified
mozilla54
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox54 fixed)

Details

Attachments

(1 attachment)

Comment hidden (empty)
(Assignee)

Comment 1

2 years ago
Posted patch close.patchSplinter Review
Assignee: nobody → amarchesini
Attachment #8832825 - Flags: review?(bkelly)
Comment on attachment 8832825 [details] [diff] [review]
close.patch

Review of attachment 8832825 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #8832825 - Flags: review?(bkelly) → review+
This is a compat fix for service workers.  We used to have a self.close() in the SW that always threw, but after this patch we will not.
Status: NEW → ASSIGNED
Keywords: dev-doc-needed

Comment 4

2 years ago
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/bf20544a7385
close() should be in DedicatedWorkerGlobalScope and SharedWorkerGlobalScope only, r=bkelly
Backed out for failing wpt interfaces.worker.html:

https://hg.mozilla.org/integration/mozilla-inbound/rev/d28b08ef0a0ad6fe4447983d87af0106ca1cc90a

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&revision=bf20544a7385ff761ba0da45fb4996153d88025f
Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=73939413&repo=mozilla-inbound

[task 2017-02-02T16:23:06.373627Z] 16:23:06     INFO - TEST-START | /workers/interfaces.worker.html
[task 2017-02-02T16:23:06.997746Z] 16:23:06     INFO - 
[task 2017-02-02T16:23:06.997867Z] 16:23:06     INFO - TEST-PASS | /workers/interfaces.worker.html | EventTarget interface: operation removeEventListener(DOMString,EventListener,boolean) - {}
[task 2017-02-02T16:23:06.997912Z] 16:23:06     INFO - {}
[task 2017-02-02T16:23:06.997978Z] 16:23:06     INFO - TEST-PASS | /workers/interfaces.worker.html | EventTarget interface: operation dispatchEvent(Event) - {}
[task 2017-02-02T16:23:06.998016Z] 16:23:06     INFO - {}
[task 2017-02-02T16:23:06.998086Z] 16:23:06     INFO - TEST-PASS | /workers/interfaces.worker.html | EventListener interface: existence and properties of interface object - {}
[task 2017-02-02T16:23:06.998123Z] 16:23:06     INFO - {}
[task 2017-02-02T16:23:06.998194Z] 16:23:06     INFO - TEST-PASS | /workers/interfaces.worker.html | WorkerGlobalScope interface: existence and properties of interface object - {}
[task 2017-02-02T16:23:06.998230Z] 16:23:06     INFO - {}
[task 2017-02-02T16:23:06.998291Z] 16:23:06     INFO - TEST-PASS | /workers/interfaces.worker.html | WorkerGlobalScope interface object length - {}
[task 2017-02-02T16:23:06.998656Z] 16:23:06     INFO - {}
[task 2017-02-02T16:23:06.999011Z] 16:23:06     INFO - TEST-PASS | /workers/interfaces.worker.html | WorkerGlobalScope interface object name - {}
[task 2017-02-02T16:23:06.999348Z] 16:23:06     INFO - {}
[task 2017-02-02T16:23:06.999729Z] 16:23:06     INFO - TEST-PASS | /workers/interfaces.worker.html | WorkerGlobalScope interface: existence and properties of interface prototype object - {}
[task 2017-02-02T16:23:07.000105Z] 16:23:06     INFO - {}
[task 2017-02-02T16:23:07.000547Z] 16:23:07     INFO - TEST-PASS | /workers/interfaces.worker.html | WorkerGlobalScope interface: existence and properties of interface prototype object's "constructor" property - {}
[task 2017-02-02T16:23:07.000889Z] 16:23:07     INFO - {}
[task 2017-02-02T16:23:07.001254Z] 16:23:07     INFO - TEST-PASS | /workers/interfaces.worker.html | WorkerGlobalScope interface: attribute self - {}
[task 2017-02-02T16:23:07.001585Z] 16:23:07     INFO - {}
[task 2017-02-02T16:23:07.001985Z] 16:23:07     INFO - TEST-PASS | /workers/interfaces.worker.html | WorkerGlobalScope interface: attribute location - {}
[task 2017-02-02T16:23:07.002401Z] 16:23:07     INFO - {}
[task 2017-02-02T16:23:07.002798Z] 16:23:07     INFO - TEST-UNEXPECTED-FAIL | /workers/interfaces.worker.html | WorkerGlobalScope interface: operation close() - assert_own_property: interface prototype object missing non-static operation expected property "close" missing
[task 2017-02-02T16:23:07.003171Z] 16:23:07     INFO - IdlInterface.prototype.test_member_operation/<@http://web-platform.test:8000/resources/idlharness.js:1261:13
[task 2017-02-02T16:23:07.003528Z] 16:23:07     INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:1406:20
[task 2017-02-02T16:23:07.003892Z] 16:23:07     INFO - IdlInterface.prototype.test_member_operation@http://web-platform.test:8000/resources/idlharness.js:1213:5
[task 2017-02-02T16:23:07.004271Z] 16:23:07     INFO - IdlInterface.prototype.test_members@http://web-platform.test:8000/resources/idlharness.js:1440:21
[task 2017-02-02T16:23:07.004630Z] 16:23:07     INFO - IdlInterface.prototype.test@http://web-platform.test:8000/resources/idlharness.js:748:5
[task 2017-02-02T16:23:07.004982Z] 16:23:07     INFO - IdlArray.prototype.test@http://web-platform.test:8000/resources/idlharness.js:398:9
[task 2017-02-02T16:23:07.005344Z] 16:23:07     INFO - request.onload@http://web-platform.test:8000/workers/interfaces.worker.js:16:3
[task 2017-02-02T16:23:07.005701Z] 16:23:07     INFO - EventHandlerNonNull*@http://web-platform.test:8000/workers/interfaces.worker.js:7:1
[task 2017-02-02T16:23:07.008391Z] 16:23:07     INFO -
Flags: needinfo?(amarchesini)
(Assignee)

Updated

2 years ago
Flags: needinfo?(amarchesini)

Comment 6

2 years ago
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/eefc0b77e8cd
close() should be in DedicatedWorkerGlobalScope and SharedWorkerGlobalScope only, r=bkelly

Comment 7

2 years ago
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/4d159a0c8114
close() should be in DedicatedWorkerGlobalScope and SharedWorkerGlobalScope only, r=me

Comment 8

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/eefc0b77e8cd
https://hg.mozilla.org/mozilla-central/rev/4d159a0c8114
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla54

Updated

2 years ago
Flags: needinfo?(benjasdad)
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1336236
You need to log in before you can comment on or make changes to this bug.