Roll out WEBGL_debug_renderer_info to Beta and Release

RESOLVED FIXED in Firefox 53

Status

()

defect
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: jgilbert, Assigned: jgilbert)

Tracking

({dev-doc-complete})

unspecified
mozilla54
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox53 fixed, firefox54 fixed)

Details

(Whiteboard: gfx-noted)

Attachments

(1 attachment)

Assignee

Description

2 years ago
No description provided.
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)

Comment 3

2 years ago
mozreview-review
Comment on attachment 8833559 [details]
Bug 1336645 - Roll out WEBGL_debug_renderer_info to Beta and Release. -

https://reviewboard.mozilla.org/r/109782/#review110820
Attachment #8833559 - Flags: review?(mchang) → review+
See Also: → 1175424
How privacy concerns are resolved? Or declared not resolved?
Assignee

Comment 5

2 years ago
(In reply to Masatoshi Kimura [:emk] from comment #4)
> How privacy concerns are resolved? Or declared not resolved?

I'm not aware of any outstanding privacy concerns here. You'll have to be more specific.
More fingerprinting vector. I'm OK if we don't care fingerprinting anymore and punting problems into "privacy.resistFingerprinting" pref. But we should not pretend as if we have no privacy issue at all.
Assignee

Comment 7

2 years ago
(In reply to Masatoshi Kimura [:emk] from comment #6)
> More fingerprinting vector. I'm OK if we don't care fingerprinting anymore
> and punting problems into "privacy.resistFingerprinting" pref. But we should
> not pretend as if we have no privacy issue at all.

Tracking this in bug 1337157.
Assignee

Comment 8

2 years ago
Comment on attachment 8833559 [details]
Bug 1336645 - Roll out WEBGL_debug_renderer_info to Beta and Release. -

Approval Request Comment
[Feature/Bug causing the regression]:
[User impact if declined]: Slow roll-out of a pref flip.
[Is this code covered by automated tests?]:
[Has the fix been verified in Nightly?]:
[Needs manual test from QE? If yes, steps to reproduce]: 
[List of other uplifts needed for the feature/fix]:
[Is the change risky?]: no
[Why is the change risky/not risky?]: It just flips a pref.
[String changes made/needed]: none
Attachment #8833559 - Flags: approval-mozilla-beta?
Attachment #8833559 - Flags: approval-mozilla-aurora?

Comment 9

2 years ago
Pushed by jgilbert@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/aaff9aacbf67
Roll out WEBGL_debug_renderer_info to Beta and Release. - r=mchang
The uplift request doesn't explain why this should go to beta today as opposed to next cycle (when bugs 1171228/1175424 have been around for a couple of years), or why it should land without bug 1337157 :(

Comment 11

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/aaff9aacbf67
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
Assignee

Comment 12

2 years ago
(In reply to Julien Cristau [:jcristau] from comment #10)
> The uplift request doesn't explain why this should go to beta today as
> opposed to next cycle (when bugs 1171228/1175424 have been around for a
> couple of years), or why it should land without bug 1337157 :(

Bug 1171228 wasn't meant to leave it #ifndef RELEASE forever, and the Intent to Ship email thread exposed no blockers to implementing this. Safari also rolled this out in the mean time.

Bug 1337157 is nice-to-have, since there are already prefs to spoof and/or disable this extension. They just aren't hooked up to the central pref.
Assignee

Comment 13

2 years ago
Since we're shipping this in 54, and since there's no reason to not roll out this pref-only change to 53 and 52, we should just take it there too.
Comment on attachment 8833559 [details]
Bug 1336645 - Roll out WEBGL_debug_renderer_info to Beta and Release. -

Well, let's bring it to aurora at least.
Attachment #8833559 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Comment on attachment 8833559 [details]
Bug 1336645 - Roll out WEBGL_debug_renderer_info to Beta and Release. -

Seems to me this can go in 53.
Attachment #8833559 - Flags: approval-mozilla-beta? → approval-mozilla-beta-
Depends on: 1338862
You need to log in before you can comment on or make changes to this bug.