Let browser spellcheck forum posts

RESOLVED FIXED in 2017q1

Status

support.mozilla.org - Lithium
Feature request
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: Bruce A. Johnson, Unassigned)

Tracking

unspecified
2017q1

Details

(Whiteboard: [phase2])

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170125094131

Steps to reproduce:

Write forum post as "Rich Text"


Actual results:

Spellcheck only happens if you select all your text and click the spellcheck button.


Expected results:

Let the browser do the spellcheck, which works much better and easier.
(Reporter)

Comment 1

a year ago
Further explanation:

I am aware that I can click that "ABC" button.  That spellcheck function does not work very well.  When turned on, it only checks the spelling in the existing text, not new text that is typed.  To check the new text, you have to turn this function off, then back on.

The built in spellchecking in the browser works much better, as it works constantly.

That is what I have requested with the bug, to let our great web browser do its thing, not block it in the very forums used to support it.

Comment 2

a year ago
Note that you can use a bookmarklet to toggle or remove the spellcheck="false" attribute that the TinyMCE editor uses for the rich-text editor.
You can also do this via the built-in Inspector (right-click: Inspect Element).

javascript:void(document.querySelector("#tinyMceEditor_ifr").contentDocument.body.setAttribute("spellcheck","true"));

javascript:void(document.activeElement.contentDocument.body.setAttribute("spellcheck","true"));

Comment 3

a year ago
Marking this as [phase2] as there are other more urgent bugs to fix first
Whiteboard: [phase2]

Updated

a year ago
Component: Lithium Migration → Feature request
Product: support.mozilla.org → support.mozilla.org - Lithium
A workaround not needing anything additional is simply to lick on the option for HTML in HTML mode it looks awful, 
(Something in itself that probably need a bug filing surely it could do an equvalent of pretty print the HTML for display & purposes.)
but your standard and possibly personalised Firefox spell checker then immediately works on it and picks up wrongly spelled words (Assuming the spellchecker is not disabled, or it is en-GB with no spellchecker by default.).

I consider it more important that for new contributors and the vast numbers of visitors looking for help we should Fix the native built in spell checker. I imagine that it probably something done easily by those with Admin rights in the forum. I presume it will be an easy minor customization option to add new words to the spell checker. I have filed a bug for that and at Rachel's suggestion started a contribs discussion thread
> Do others agree the spellchecker needs fixing
> https://support.mozilla.org/t5/SUMO-community-discussions/Do-others-agree-the-spellchecker-needs-fixing/m-p/1372360#M25792

(And In Due Course we probably need a bugzilla bug for bug1344367 )

Comment 5

a year ago
I looks from the outside like fixing the current spell checker is not all that simple, or the spelling for Mozilla and Firefox would already have been entered into it.  Or at least that is my assumption.  Let alone a user dictionary.
(Reporter)

Comment 6

a year ago
Using "Inspect Element", it is clear that it would be very easy to fix the code so the browser spellchecker will work:

<body id="tinymce" class="mce-content-body lia-message-editor" data-id="tinyMceEditor" spellcheck="false" contenteditable="true">

All that has to be done is to change spellcheck="false" to spellcheck="true".

Comment 7

a year ago
@Madalina - as per Bruce's last comment, can we bump this up since it seems like an easy/quick fix and a lot of contributors and users could benefit from this? Thanks!
Flags: needinfo?(mana)

Comment 8

a year ago
The built-in Firefox spellcheck feature is now working for both Rich Text and for HTML.
I certainly do not want to complain about a bug being actioned and fixed quickly but
See also bug1341574 this bug is still [phase2], unassigned and unconfirmed, perhaps a relevant person could update it. We were not even aware anyone from Lithium or Sumo was even considering actioning this yet!

See also bug1344300
I hope this does not preclude work on the Lithium spell checker to customise that properly for Lithium.

It is probably worth noting that the Lithium spell checker is available in other languages not just en-US and it is worth remembering not all Firefox installs will have spell checking by default. For instance I use Lithium's British English spellchecker. Note that the default install of British English Firefox does not come with any built-in spell checker.

Additionally we have Android support on lithium sumo. Firefox Android does not have built in Firefox spell checking.
Or a Lithium spellchecker. Lithium Sumo probably has a lot of unreported problems (I have not checkedv
 yet but I wonder do we have a component for Lithium Android bugs.)

Comment 10

a year ago
The spellchecker settings available currently are as follows:

Spellchecker to use:
- Browser
- Community Message Editor
- None

As you can see, the choice is pretty binary. Customizing this to allow both options to co-exist depends on the Lithium dev team and may not be possible. I am not a developer and I don't know Lithium's code, so what we can do is spec out what we need spellchecking to work like and hope for the best, while keeping in mind that we may be forced to use only one of those.
Michal, 
You are missing the point that something has changed and by default Lithium is now checking spellings with the browser. So it appears someone has changed something, possibly in response to this bug or similar discussions, but the bug has not been updated to indicate this. It is still unconfirmed and unassigned with a NI from you for Madalina outstanding.

I am missing something. You said:
> ...
>Spellchecker to use:
>- Browser
>- Community Message Editor
>- None
>
>As you can see, the choice is pretty binary. Customizing this ...

I do not see am not such settings.
I do not notice it in "my settings" 
I do not notice it in the reply thread options.
I do not even see any spellchecker icon in replies, that has gone.
I could previously use the Lithium spell-checker by default or with a simple click on the HTML icon spell check with the browser.
I do not now seem to have an option to use Lithium's; albeit uncustomised spellchecker at all.


Does that indicate you have changed the settings for everyone from using  the "Community Message Editor" to "Browser"

It is possibly worth remembering:
* Not all Firefox installs will have a spellchecker.
** By default British  en-GB builds do not. Presumably other Fiferox Mozilla builds also install without spell checkers.
* The Lithium spell checker did:
** allow the user to choose the language of the spellchecking.
** permit the user to spellcheck with the browser
I do not see *am not* settings
I should have said
I do not see *any such* settings

Comment 13

a year ago
There have been Lithium updates within the last week and inline spell checking is now enabled.

If I set the wrong Target, please correct.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(mana)
Resolution: --- → FIXED
Target Milestone: --- → 2017q1

Comment 14

a year ago
Hi John,

(In reply to John Hesling [:John99] (NeedInfo me) from comment #11)
> Michal, 
> You are missing the point that something has changed and by default Lithium
> is now checking spellings with the browser. So it appears someone has
> changed something, possibly in response to this bug or similar discussions,
> but the bug has not been updated to indicate this. It is still unconfirmed
> and unassigned with a NI from you for Madalina outstanding.
> 
> I am missing something. You said:
> > ...
> >Spellchecker to use:
> >- Browser
> >- Community Message Editor
> >- None
> >
> >As you can see, the choice is pretty binary. Customizing this ...
> 
> I do not see am not such settings.
> I do not notice it in "my settings" 
> I do not notice it in the reply thread options.
> I do not even see any spellchecker icon in replies, that has gone.
> I could previously use the Lithium spell-checker by default or with a simple
> click on the HTML icon spell check with the browser.
> I do not now seem to have an option to use Lithium's; albeit uncustomised
> spellchecker at all.

I was not clear enough, sorry.

The platform offers three options for Admin-level users to set up spell checking:

- Browser (this is enabled right now)
- Community Message Editor (this was enabled before, but was insufficient - if we want to use this instead of the browser spell-checker, we need to customize its settings for all locales separately; this may not be worth the effort, since everyone's browser spell checker is probably 'trained' better - for new contributors, style guides should be the way to go)
- None (we probably don't want to use that option)
- None

> Does that indicate you have changed the settings for everyone from using 
> the "Community Message Editor" to "Browser"

Yes.
 
> It is possibly worth remembering:
> * Not all Firefox installs will have a spellchecker.
> ** By default British  en-GB builds do not. Presumably other Firefox Mozilla
> builds also install without spell checkers.

I suggest having a spell checker is a best practice for our contributors that we should capture in the documentation for KB editors of all languages.

> * The Lithium spell checker did:
> ** allow the user to choose the language of the spellchecking.
> ** permit the user to spellcheck with the browser

This would be pending https://bugzilla.mozilla.org/show_bug.cgi?id=1344300. I'm +NI Madalina for handling and prioritization of that bug, on that bug.
Thanks for the clarification Michał.
Personally I do and will continue using the Browser spell checker either in addition to the Lithium one or instead of it.   

However as far as this bug is concerned my closing comments:
**The browser spell checker may have been used even when the Lithium spellchecker is available.**
The *Fix* prevents use of the Lithium built in spellchecker.
From your explanation the current settings mean no one will be able to use the built in spell checker, so at a later date we may need to consider either  
A.) - Reverse that change 
-- That permits browser spell checking when the HTML mode is temporarily toggled on.
B.) - Improve Lithium. So the two spell checkers can coexist on the Rich Text mode
C.) - Consider some other solution. 
-- Such as cor-el's comment2 which we could document and explain
===>
>Note that you can use a bookmarklet to toggle or remove the spellcheck="false" attribute that the TinyMCE editor uses for the rich-text editor.
>You can also do this via the built-in Inspector (right-click: Inspect Element).
>  
>javascript:void(document.querySelector("#tinyMceEditor_ifr").contentDocument.body.setAttribute("spellcheck","true"));
> 
>javascript:void(document.activeElement.contentDocument.body.setAttribute("spellcheck","true"));  
-- Note we do already document use of Bookmarklets ("Use bookmarklets to quickly perform common web page tasks")
> https://support.mozilla.org/t5/Learn-the-Basics-get-started/Use-bookmarklets-to-quickly-perform-common-web-page-tasks/ta-p/5218
>   Bookmarklets allow you to always keep your common tasks on a web page just a click away. This article tells you what bookmarklets are, and explains how to install and use them. ...
You need to log in before you can comment on or make changes to this bug.