Bug 1341574 (Improve_Sumo_Bugs)

Improve bug handling: cc, whiteboard, triage and follow up, needs owners, & possibly additional components

RESOLVED FIXED

Status

support.mozilla.org - Lithium
General
P1
enhancement
RESOLVED FIXED
a year ago
9 months ago

People

(Reporter: John99, Assigned: madalina)

Tracking

Details

When Sumo Lithium bugs are entered they apparently have no owner|qa contact, maybe it helps if we have an improved template available.  Which Sumo Admins are responsible for the lithium buglist generally. Little point in saying everyone or we get in to the situation 
":-) Anybody could, but nobody did because ..." 
and quite possibly some of the reviewing  could easily be delegated to contributors.

CC
There are no CC entries made at all.  So I have taken the liberty of adding what would appear likely to be appropriate staff to this bug's cc list.
It should be set up to CC someone presumably including Sumo staff.

WHITEBOARD & TRIAGE
We are using a whiteboard entries on some bugs. Sumo bugs were previously controlled and tracked on third party software I believe is that going to be reintroduced? or are we sticking with bugzilla's features - that appears to be the current methodology.
If we are using a whiteboard we should have a good and easily accessible listing of when they are to be used, and whether anyone can enter  these or is it only a triager or Admin. Presumably most or all bugs should have at least one Whiteboard entry.
Who if anyone id Triaging and reviewing bugs
We do have some comments about the whitelist in the "Agenda" currently
> https://docs.google.com/document/d/1iz1xp2Iie4dvdy5WKC6aL8Nyx1tbLZE_6WQop4htTw8/edit#
>[26th Jan]  ... the ones that will be fixed in the first two weeks after launch (1st2weeks) and the one who will be fixed later (phase2). Just search via the bugzilla field “Details->Whiteboard” for [phase2] and [1st2weeks].
    
We probably could do with considering additional whiteboard words. The first two weeks has passed, so everything else is going to be [phase2] that makes it rather redundant, and what about priorities, as clearly some will be more important than others. Do we for instance use merely the bugzilla priority & severity fields or maybe supplement that with whiteboard words and meta bugs. 

COMPONENTS
We probably need to clear or archive old sumo bugs and components or they will end up being reused for new bugs. We probably need to add other Lithium Related components. How long is a Lithium migration period lasting? before bugs become: Lithium KB issues, Lithium Search issues, or whatever.

And of course where does Lithium come in to this process with their staff and contacts and any bugtracking they may have upstream of our own.

I could have started this as a forum discussion but there are clear directives that we are now tracking Lithium Migration issues using Bugzilla bugs.
(Reporter)

Updated

a year ago
Blocks: 1316839
(Reporter)

Updated

a year ago
Depends on: 1341579
Note at platform meeting 16th feb it was mentioned new components being added to bugzilla and Roland minuted platform meeting 23rd feb to confirm new components would be added.
(Assignee)

Comment 2

a year ago
I expect the new components to be added this week. These will mirror the ones we had on Kitsune with the same owners.

If you cannot figure out who needs to be cc'ed on what bug, feel free to just cc myself as PM.I can then redirect to the right people.

Assigning this to myself so I can close it when the new components are added.
Assignee: nobody → mana
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Depends on: 1343105

I wonder if we are getting any more whiteboard names.
It is rather pointless to use [1st2weeks] now.  [kitsune-parity] may be a useful one for any enhancement or fixes that provide features similar to what existed in Kitsune.
(Reporter)

Updated

a year ago
Component: Lithium Migration → General
Depends on: 1343105
Product: support.mozilla.org → support.mozilla.org - Lithium
 (In reply to madalina from comment #2)
> I expect the new components to be added this week. These will mirror the
> ones we had on Kitsune with the same owners. ... 

Thanks and your new post about this in the contribs section noted. It is @ 
https://support.mozilla.org/t5/SUMO-community-discussions/New-Bugzilla-Components/m-p/1370269#M25753 
> ...
> If you cannot figure out who needs to be cc'ed on what bug, feel free to
> just cc myself as PM.I can then redirect to the right people.
> ...

Possibly it has not yet been finalised which staff members are responsible for each component.
I notice that currently the Lithium related bugs do not create initial cc contact lists.
Is this something that should be done ?
In addition to a CC generally for Bugzilla/QA or Mozilla presumably the cc list should include on the Sumo side the following classes of staff members 
1.)  Whoever has overall responsibility for triage and progress of bugs
2.)  One or more staff members primarily responsible for the component
3.)  A secondary contact, both for any other interest and in case of needing to delegate when the primary contact is absent PTO etc

Possibly that will be a list with 3 or more persons on it for any component or with the overlapping and changing responsibilities it may just be a couple of names. Surely it is best to have such initial CCs automated. I imagine that is relatively straightforward on bugzilla. Does an additional bug need to be filed for this ? probably not.

NI Roland, I guess you are the expert on this, as I note you filed the bug for the new components.

Additionally and I will file a sumo lithium bug for this, but it may need a bugzilla admin bug I note we are not able to add see also to sumo lithium destinations.
Flags: needinfo?(rtanglao)
hi john:

madalina will assign sumo staff to the components (i'll take feature requests and anything "phase2" related" madalina please)

Please don't auto-cc anybody, with bugzilla the staff or whoever wants to monitor components can figure out a workflow that works best for them, auto-cc imposes a workflow on them which is not optimal for many people including myself

the staff members or volunteers responsible for a component will be responsible for triaging and moving bugs to the correct component

indeed volunteers like philipp and maybe you :-) with editbugs privileges could/and should triage and move bugs

volunteers can and should be secondary contacts in my opinion (and primary contacts too for those volunteers with the time and expertise)

finally please don't CC me on bugs unless i ask you to on irc or email, just either assign me the bug or need info me.

cheers and happy weekend!
..Roland
Flags: needinfo?(rtanglao) → needinfo?(mana)
Thanks for the speedy reply Roland and info noted.
I have been filing bugs so far often with blank CC,
 or as Madalina suggested above adding her rather than no one.

I know some people prefer NI to cc, I  never bother with my sumo/bugzilla emails I us PMs or NI,
but I do use the CC listing from bugzilla which allows me to follow any bug I have posted in or CC ed myself in.

Talking generally rather than about myself I just worry we could get a lot of  bugs filed but ignored if we are not careful. But at least thanks to you we now have new components which has to be a help in keeping things tidy, and with any luck bug numbers will drop off rapidly with Lithium after the initial period, that was the main point in using third party software.
A lot more mistakes in bug handling like this would soon clear our bugs list.
Bug1338018 comment9
>I certainly do not want to complain about a bug being actioned and fixed quickly but
>See also bug1341574 this bug is still [phase2], unassigned and unconfirmed, 
>perhaps a relevant person could update it. 
>We were not even aware anyone from Lithium or Sumo was even considering actioning this yet!

Also would it help to have a Sumo Lithium component for Mobile or Android because we obviously provide Firefox Andtoid support on Lithium. We have a separate section for that. Lithium display and behaves diferently on Android mobiles and I have discovered and commented in our fora about bugs on Android but not yet filed on bugzilla.
See Also: → bug 1338018

Comment 8

a year ago
We met with Lithium's support representative yesterday and we are going to decide how to handle bugs and feature requests - and share this information with you - in the coming days.
(Reporter)

Comment 9

11 months ago
There have been comments made in the two platform videos and very brief notes in the platform agenda/minutes. The last platform meeting expected this week seems not to have occurred, but vesper posted an update Today about the redirect issue including a comment on bug handling:
>  https://support.mozilla.org/t5/SUMO-community-discussions/Redirects-update/td-p/1384527
...  
We have made a lot of progress on bug prioritization and feature planning that we are going to share with you next week. Stay tuned and thanks for all your hard work. ....


TRACKING BY SPREADSEET !?
I just hope we are not heading for a system of keeping bugs on a spreadsheet and only unasigned bugs and meta bugs on Bugzilla, because that make Bugzilla rather pointless and raises  a distinct likelhood of bugs being filed and and remaining ignored because no one will be able to work on them.

Sure I see a good points in keeping a spreadsheet. For instance showing what resources are allocated where and recording how decisions on priorities have been made. 
That is good management practice. 
Just as long as we do not get back to the old Kitsune situation of hundreds of bugs filed and no action able to be taken due to lack of resources, and no resources to even keep the bugs that are filed under review. 

YES MANY BUGS WILL NEVER GET FIXED.
If we have a priority range from say P1 to P5 the chances of a P5 bug ever being fixed are remote, but as I say that is down to resource management and makes sense. It can also be easily discovered by anyone using Bugzilla with the bug progress, status and priority being clear for all to see.
(Reporter)

Comment 10

11 months ago
NI Roland

Hi Roland, any thoughts or comments please on the need for a Firefox Android component within sumo Lithium product.
You added https://bugzilla.mozilla.org/enter_bug.cgi?product=support.mozilla.org%20-%20Lithium 
and I guess as it stands something being broken when used from Firefox Android but not when used from Firefox Desktop still goes in the relevant component such as general or UX, would it help to have an Android component or not. 

(In reply to John Hesling [:John99] (NeedInfo me) from comment #7)
> ....
> Also would it help to have a Sumo Lithium component for Mobile or Android
> because we obviously provide Firefox Andtoid support on Lithium. We have a
> separate section for that. Lithium display and behaves diferently on Android
> mobiles and I have discovered and commented in our fora about bugs on
> Android but not yet filed on bugzilla.
Flags: needinfo?(rtanglao)
no need for an Android component in my opinion since Lithium should have a responsive design that works on Android and iOS and mobile in general as well as desktop
Flags: needinfo?(rtanglao)
(Reporter)

Comment 12

9 months ago
Update: This is receiving attention again.

There is currently 
* Discussion and draft policy 
> https://wiki.mozilla.org/User_talk:Rtanglao/bugzilla-sumo-lithium

* A trello card for the current sprint  
> https://trello.com/c/7WJ6zCL6/24-improve-bug-handling-cc-whiteboard-triage-and-follow-up-needs-owners-possibly-additional-components

* A spread sheet with the first few bugs triaged 
> https://docs.google.com/spreadsheets/d/1-vR2awxQwQej4o7HzZ6Tf_fXcp9sLUmd31PVzrFWUTo/edit#gid=794502132

* Contributors discussion thread started by Roland (Sumo Kitsune of course)
> https://support.mozilla.org/forums/contributors/712427

I am hoping the policy discussion will be finalised soon and with any luck all Sumo Lithium bugs will have been: initially triaged, prioritised, and commented on; by the start of the next Marketing Sprint (About 2 weeks time).
(Assignee)

Updated

9 months ago
Flags: needinfo?(mana)
Priority: -- → P1
(Assignee)

Comment 13

9 months ago
Process has been agreed on and updated here: https://wiki.mozilla.org/Support/SUMO_Project_management
Status: ASSIGNED → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.