Per-server proxy prefrences

NEW
Unassigned

Status

MailNews Core
Networking: NNTP
16 years ago
9 years ago

People

(Reporter: Abhishek, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.9+)
Gecko/20020326
BuildID:    2002032603

I subscribe to two news servers. 

One news server is internal to our company. to access this server, I should
specify a proxy server in the browser.

I also subscribe to a news server which is external to our company. this news
server is newsgroups.bea.com. to access this news server I need to specify a
SOCKS server (we use SOCKS4 in our org).

When I click on any one of them after starting mozilla I can read the news (this
can be either the external or the internal news server)

Now when  I try to read news from the other news server, mozilla does not read
the news of the other one... Probably once it starts using the  socks server for
connectivity then it tries to read the internal server as well and the call
fails because internal news server is not available via the socks server.

similarly if I click on the internal server first and read news and then try to
go to the external server ... mozilla does not show any news for it ... may be
because its still trying to access the external server via the proxy.


Reproducible: Always
Steps to Reproduce:
1. configure two news accounts in mozilla
2. account 1 should be available only via a proxy server and subscribe to a few
news groups.
3. account 2 should be available only via a socks server and subscribe to a few
news groups.
4. re-start mozilla
5. read news on account 1.
6. now click on any news groups in account 2
7. mozilla will not show the news items of the newsgroups in account 2.

Actual Results:  when I switch from an external(socks) to internal (proxy) or
from internal to external, mozilla does not read the news from the news server
switched to. If I go back to a newsgroup of the news server which I was using
initially, then it reads it succesfully. but it will not read news of the other
news server at this time.

Expected Results:  I should be able to read newsgroups on both the servers
internal (via proxy) and external (via socks) and mozilla should determine which
is the right server to use(proxy or the socks) and connect to the news server
accordingly.
Right, SOCKS is currently implemented 'all or nothing', that is to say, it'll
use SOCKS to connect to all protocols it can once you've set the pref.  If you
set the hostname exclusion in the Edit | Advanced | Proxies | No Proxy For
section, this should work for all servers you don't with to use SOCKS for.  This
would require an architecture change, that I think is covered by 
bug 51472.  Ben will correct me if I'm wrong ;-)
Summary: socks server and proxy server → socks server and proxy server
Rather, I think this is covered by bug 89928.

*** This bug has been marked as a duplicate of 89928 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
REOPEN:
The bug you duplicated to is more about using PAC to make it so we can change
the manual prefs UI w/ recoding every protocol handler each time.

What is desired can be done w/ a PAC file, but I think the manual + "no proxy"
configuration will work best here.

So, we should get this working for you. Once it is working, we should ponder the
other comments made, we probably need to open several bugs on error handling, as
well as connections not working well when you change configs w/o restarting the
browser.

Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Ben - you marked http://bugzilla.mozilla.org/show_bug.cgi?id=60337 a dup of bug
89928, and as far as I can tell, but 60337 wasn't specific to proxy autoconfig.

Also, in http://bugzilla.mozilla.org/show_bug.cgi?id=132540#c4

------- Additional Comment #4 From Benjamin Chuang 2002-04-03 08:48 -------

MailNews should only obey the "SOCKS" and "No Proxy" fields.

If the contents of the other fields affect your connectivity, clear them to
verify the problem. This would be a bug.

As for making proxy preferences more robust for Mail News users, I think you
really want bug 89928.

So, what is the actual bug that exists for expanding the UI to be more robust?

Comment 5

16 years ago
Yeah :)

I should probably explain this offline, but I'm going to try to do it here anyhow.

Bug 60337, was basically me whining that nobody knew what the proxy features
were, so nobody could tell if the prefs were broken. That was a long time ago,
through many small improvements, we have pretty good 4xp compatability. For a
while, it looked like we would have the same UI, but be hopeless 4xp broken,
enough where migrated profiles would go deaf b/c the proxy prefs would mean
different things to mozilla and comm 4.

That isn't the case any more, so the answer was sort of "without doing it on
purpose, support 4xp". But the bug does discuss larger aspects of adding new
proxy protocol support as well as adding other protocols that have proxy
support.  Bug 89928 contemplates an architectural solution to the problem.

Bug 132540 is an example of a change best done through using Bug 89928, this is
a request for a "News" field, because the "SOCKS" pref is too all-encompasing on
a protocol basis (hence we need a new field). The "no proxy" and other
suggestions I made are workarounds. If you use lots of different new servers,
then using no-proxy becomes really onerous.

In this bug, the problem is that we have two new servers, but on different
network horizons. Getting a "news" field doesn't solve the user problem, because
you would still have the same problem.

The reason this is not a good dupe is that this type of config is best done via
a PAC file. You could change the manual config to support a configuration like
this, but remember, manual config needs to be something that works for lots of
configs. I don't know of many simple UI that express a split horizon (esp by
protocol) very well.
Basically, we need a per-account UI (server settings?) ala Outlook Express,
whereby you can specify which connection type and prefs associated with that to use.

Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

16 years ago
Bug 144696 seems like it's asking for the same thing for mail accounts that
Stephen suggests in the last comment to do for news accounts (reporter
experiences same issue with his internal/external mail servers as reporter of
this bug did with internal/external news servers).  Just thought maybe a fix for
this bug would fix that one.

Comment 8

14 years ago
I don't know how the proxy config is applied to connections, if it is bound at
the protocol handler, or if a proxy object is attached to each new connection.

It probably varies by setting (manual vs. PAC).

The best solution would be to support this behavior via PAC. I think nobody will
find the cost-benefit of adding more UI for proxy prefs (you want to stick the
whole manual proxy functionality INSIDE each news server config?) would be
really low. Tons of implementation pain, for how many real-world situations?

The real problem here is that many of these protocols (news and proxy
especially) are no longer current, and it becomes increasingly difficult to add
these features when the usage is going down.
Summary: socks server and proxy server → Per-server proxy prefrences
Product: MailNews → Core
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody
Filter on "Nobody_NScomTLD_20080620"
QA Contact: stephend → networking.news
(Assignee)

Updated

9 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.