Crash in nsAString_internal::Assign | nsAString_internal::Assign | nsAutoString::operator=

RESOLVED DUPLICATE of bug 1339603

Status

()

Core
IPC
--
critical
RESOLVED DUPLICATE of bug 1339603
9 months ago
9 months ago

People

(Reporter: marcia, Unassigned)

Tracking

({crash, regression})

Trunk
x86
Windows 7
crash, regression
Points:
---

Firefox Tracking Flags

(firefox53 unaffected)

Details

(crash signature)

(Reporter)

Description

9 months ago
This bug was filed from the Socorro interface and is 
report bp-46cfddd2-6a46-4aaf-accb-268bb2170216.
=============================================================

Seen while looking at nightly crash stats - crashes started with 20170215030342:

Possible regression range: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=195049fabb7ac5709e5f75614ba630ba3d1b5a9b&tochange=0a7831d838f793a263456df62f95a615472a7f95

Possibly Bug 1337537? ni on :billm
Flags: needinfo?(wmccloskey)

Updated

9 months ago
Component: XPCOM → IPC
This looks like a null deref in code added by bug 1337518.
Blocks: 1337518
Flags: needinfo?(wmccloskey) → needinfo?(dvander)
Keywords: regression
GPUChild::ActorDestroy calls mCrashReporter->GenerateCrashReport with one argument, so we end up with aOutMinidumpID = nullptr, so then we crash at the end of CrashReporterHost::GenerateCrashReport on this line:
  *aOutMinidumpID = dumpID;
[Tracking Requested - why for this release]: crash regression
status-firefox53: --- → unaffected
tracking-firefox54: --- → ?
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Flags: needinfo?(dvander)
Resolution: --- → DUPLICATE
Duplicate of bug: 1339603
(Reporter)

Comment 5

9 months ago
Updating tracking flags so it doesn't show up on the release health dashboard.
status-firefox54: affected → ---
tracking-firefox54: ? → ---
You need to log in before you can comment on or make changes to this bug.