Closed Bug 1340538 Opened 3 years ago Closed 3 years ago

Refresh a page when permission pop-up is opened will make the permission pop-up to be displayed in the bottom of the page

Categories

(Firefox :: Site Identity and Permission Panels, defect, P1)

54 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 55
Tracking Status
firefox53 - verified
firefox54 --- verified
firefox55 --- verified

People

(Reporter: Ovidiu, Assigned: Paolo)

References

(Depends on 2 open bugs, Blocks 1 open bug)

Details

(Whiteboard: [fxprivacy])

Attachments

(3 files)

Attached video Recording #5.mp4
Affected versions]: 
DeveloperEdition 53.0a2  (2017-02-17)
Nightly 54.0a1 (2017-02-17)

[Affected platforms]:
All platforms: Ubuntu 16.04 x64, Windows 10 x 64, Mac OS X 10.12

[Steps to reproduce]:

1. Go to http://permission.site/ and click on Notification.
2. Click on the URL bar and write something 
3. Click anywhere on the browser window (permission pop-up appears)
4. Refresh the page

[Expected result]:

The page is refreshed and the permission pop-up is displayed under the URL bar.

[Actual result]:

The page is refreshed and the permission pop-up is displayed in the bottom of the page. 

Please see the attached video.
Whiteboard: [fxprivacy] [triage]
What happens here is that we display the original anchor icon again for a short time, then we hide it indirectly from CSS after we've called the last PopupNotifications.jsm update method, thus the panel is still displayed, but loses the anchor.

The support for hiding the panel automatically added in bug 1109868 is apparently what we need to solve the bug. This used to trigger test failures there, let's see if this is still the case:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=fa0d244d49271077e01a8619e8d6c4183405caca
Assignee: nobody → paolo.mozmail
Status: NEW → ASSIGNED
Depends on: 1109868
Also, this is not reproducible while debugging, it probably depends on the exact timing of events. If the one-line fix doesn't trigger test failures, I'd just land this without any automated test changes.
Flags: qe-verify+
Flags: in-testsuite-
Flags: needinfo?(enndeakin)
Comment on attachment 8843577 [details]
Bug 1340538 - Refresh a page when permission pop-up is opened will make the permission pop-up to be displayed in the bottom of the page.

https://reviewboard.mozilla.org/r/117244/#review119152

r=me. I still see a very slight flicker of the notification at the bottom of the page when following the steps in comment 0, though. But it's much better than what we have right now.

Thanks!
Attachment #8843577 - Flags: review?(jhofmann) → review+
Duplicate of this bug: 1341286
Flags: needinfo?(enndeakin)
Duplicate of this bug: 1343907
Priority: -- → P1
Whiteboard: [fxprivacy] [triage] → [fxprivacy]
Pushed by paolo.mozmail@amadzone.org:
https://hg.mozilla.org/integration/mozilla-inbound/rev/57759203e1f7
Refresh a page when permission pop-up is opened will make the permission pop-up to be displayed in the bottom of the page. r=johannh
[Tracking Requested - why for this release]:
This is likely a regression from bug 1300755.
Blocks: 1300755
https://hg.mozilla.org/mozilla-central/rev/57759203e1f7
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
status-firefox55: verified & fixed.
Depends on: 1345429
Attached video Recording #4.mp4
I can still reproduce this issue but this time the permission pop-up isn't appearing in the bottom of the page, it appears only when Firefox Nightly isn't full screen in the top of the page as a flicker using the same steps.
(In reply to Hani Yacoub from comment #11)
> I can still reproduce this issue but this time the permission pop-up isn't
> appearing in the bottom of the page, it appears only when Firefox Nightly
> isn't full screen in the top of the page as a flicker using the same steps.

This is the same as bug 1345429. The situation is still an improvement since we don't keep the panel open.
Comment on attachment 8843577 [details]
Bug 1340538 - Refresh a page when permission pop-up is opened will make the permission pop-up to be displayed in the bottom of the page.

Approval Request Comment
[Feature/Bug causing the regression]: Permission Notifications
[User impact if declined]: Permission Notification panels may stay open even if the user reloaded the page
[Is this code covered by automated tests?]: Permission Notifications are covered by regression test, this particular issue requires manual testing
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: See comment 0. Also, exploratory testing around Permission Notifications is advised, although the code is also covered by regression tests. Note that bug 1345429 still exists.
[List of other uplifts needed for the feature/fix]: Bug 1109868
[Is the change risky?]: Risk is limited to the feature
[Why is the change risky/not risky?]: The feature has extensive regression tests
[String changes made/needed]: None
Attachment #8843577 - Flags: approval-mozilla-beta?
Attachment #8843577 - Flags: approval-mozilla-aurora?
Build ID: 20170313030209
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0

Verified as fixed on Windows 10 x 64, Mac OS X 10.11 and Ubuntu 16.04 x64 on Firefox Nightly 55.0a1.
Comment on attachment 8843577 [details]
Bug 1340538 - Refresh a page when permission pop-up is opened will make the permission pop-up to be displayed in the bottom of the page.

permission popup fix, for aurora54 and beta53
Attachment #8843577 - Flags: approval-mozilla-beta?
Attachment #8843577 - Flags: approval-mozilla-beta+
Attachment #8843577 - Flags: approval-mozilla-aurora?
Attachment #8843577 - Flags: approval-mozilla-aurora+
This can't apply to beta until bug 1109868 lands there, and it hit conflicts.
Also confirming that this no longer reproduces on Windows 10 x64, Mac OS X 10.11.6 and Ubuntu 14.04 x64 using:
* 53 beta 2, build ID: 20170313154936
* Latest 54.0a2 DevEdition, build ID: 20170314004020.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Untrack for 53 as it's verified.
Depends on: 1353980
Depends on: 1355000
See Also: → 1377802
You need to log in before you can comment on or make changes to this bug.